The officially official Devuan Forum!

You are not logged in.

#26 2021-02-25 00:54:26

zapper
Member
Registered: 2017-05-29
Posts: 895  

Re: PulseAudio always resets to mute

MLEvD wrote:
fsmithred wrote:

MLEvD, I hope you have better luck. Are you sure you need pulseaudio? Maybe plain alsa would behave better.

I'm doing sychronised multi-room audio with asus eee pc as receiver boxes. Why not rpi? Because eee pc have screens and input attached, and are dust proof, have cases, are portable (own battery!). In addition to music. They also provide wifi, a digital picture frame/show, and anything else you might do with an 800x600 screen.

I read back at the start that one must use pulse or sndio for this avahi magic, alsa is a one horse town. Hopefully I am wrong?

Hack: I *could* just hack the scripts to enforce defaults and policies, but this is something clearly broken compared to the last version of devuan or the contemporary version of debian, so it's possibly an indication of some wider improvement opportunity in the development sphere. It's a very long time since I was a pro tester so forgive my antiquated language please!

Probably, its a debian issue inflicted on devuan.

Though, pulseaudio imo sucks.

Sndio is the best, if you have alsa-sndio and aucatctl installed. smile

Otherwise, use alsa

Last edited by zapper (2021-02-25 00:55:34)


Freedom is never more than one generation away from extinction. Feelings are not facts
If you wish to be humbled, try to exalt yourself long term  If you wish to be exalted, try to humble yourself long term
Favourite operating systems: Hyperbola Devuan OpenBSD
Peace Be With us All!

Offline

#27 2021-02-25 14:38:00

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,125  
Website

Re: PulseAudio always resets to mute

Fun fact: the GNOME desktop in Debian bullseye no longer needs PulseAudio at all. PipeWire is the future...


Brianna Ghey — Rest In Power

Offline

#28 2021-02-26 02:37:26

bgstack15
Member
Registered: 2018-02-04
Posts: 205  

Re: PulseAudio always resets to mute

Head_on_a_Stick wrote:

Fun fact: the GNOME desktop in Debian bullseye no longer needs PulseAudio at all. PipeWire is the future...

Head_on_a_Stick, what is your opinion of PipeWire? I don't know anything about it, or if there are good reasons to dislike it or its architecture in the same vein as PulseAudio.


This space intentionally left blank.

Offline

#29 2021-02-26 02:53:55

golinux
Administrator
Registered: 2016-11-25
Posts: 3,229  

Re: PulseAudio always resets to mute

IIRC it's linked to wayland and not friendly to X11.  There was some discussion perhaps here recently.  In the meantime from https://en.wikipedia.org/wiki/PipeWire

"One of the initial goals was to improve handling of video on Linux the same way PulseAudio improved handling of audio"

That about says everything . . .

Online

#30 2021-02-26 06:06:47

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,125  
Website

Re: PulseAudio always resets to mute

bgstack15 wrote:

what is your opinion of PipeWire?

I quite like it because it provides a unified management stream for both audio and video under Wayland and it's 100% ABI compatible with both Jack and PulseAudio. But then I also like GNOME and Wayland so...


Brianna Ghey — Rest In Power

Offline

#31 2021-03-12 09:48:11

MLEvD
Member
Registered: 2021-02-14
Posts: 141  

Re: PulseAudio always resets to mute

Hi again, I've found two things from playing with the default.pa file

Firstly, no configuration allows one to save a user preference for a network sink. RTP multicast is retainable, like local sound cards, but not even my precious lmde saves a network card.

Secondly, default.pa has nothing to do with hardware profile. This is just good old fashioned not being saved.
Is it the case that mate have stopped supporting sysv? Can't reproduce the problem under any systemd system, or under an older sysv system.

Offline

#32 2021-03-12 16:19:36

MLEvD
Member
Registered: 2021-02-14
Posts: 141  

Re: PulseAudio always resets to mute

More news, Spent all day installing antix. Same versions of sysv, pulse, mate-media as Beowulf.

Antix seems to do better than all the others. Not only does it save hardware profiles (the Beowulf Bug), it also saves your output choices even if they are on a networked device.

Somewhere under the hood of antix lies the answer perhaps? If would be great to be better than debian and lmde at doing pulseaudio with mate-media settings persistence.

Antix is interesting, but I'd still rather have devuan.

Offline

#33 2021-03-13 03:44:46

zapper
Member
Registered: 2017-05-29
Posts: 895  

Re: PulseAudio always resets to mute

Let's see, pipewire or pulseaudio which is worse...

How about neither...

Since they both are redhat garbage software.

I tire of the corporate ideal to eff things up that work well just to make people depend on software that is bloated and sux...

Smh...  greed does wonders... or horrors if you prefer.

sad


Freedom is never more than one generation away from extinction. Feelings are not facts
If you wish to be humbled, try to exalt yourself long term  If you wish to be exalted, try to humble yourself long term
Favourite operating systems: Hyperbola Devuan OpenBSD
Peace Be With us All!

Offline

#34 2021-04-08 05:00:38

mirrortokyo
Member
Registered: 2021-04-08
Posts: 45  

Re: PulseAudio always resets to mute

I registered here to just to report on this issue (long time Devuan user).

Thanks to this thread I solved the issue for myself and filed a bug report:

https://bugs.debian.org/cgi-bin/bugrepo … bug=986211

My solution was to do:

pacmd list-cards

(program pacmd is in package pulseaudio-utils)

to find the actual output that I wanted to use (in my case, analogue stereo output on a Soundblaster Audigy 2 ZS)

then at the end of /etc/pulse/default.pa I put:

# set-card-profile name-of-card-without-angle-brackets name-of-profile-without-trailing-colon
set-card-profile alsa_card.pci-0000_03_06.0 output:analog-stereo+input:analog-mono

I also recommend installing the package pavucontrol and using the command pavucontrol if something gets accidentally muted.

This seems to be a problem of lack of documentation on setting the default audio profile.

Offline

#35 2021-11-29 01:21:27

mirrortokyo
Member
Registered: 2021-04-08
Posts: 45  

Re: PulseAudio always resets to mute

mirrortokyo wrote:

then at the end of /etc/pulse/default.pa I put:

# set-card-profile name-of-card-without-angle-brackets name-of-profile-without-trailing-colon
set-card-profile alsa_card.pci-0000_03_06.0 output:analog-stereo+input:analog-mono

After adding another PCI-Express card to the pc, I needed to comment out the line referencing the sound card in /etc/pulse/default.pa and re-run:

pacmd list-cards

which gave the new name of the card as:

alsa_card.pci-0000_04_06.0

and updated the line in /etc/pulse/default.pa to:

set-card-profile alsa_card.pci-0000_04_06.0 output:analog-stereo+input:analog-mono

Offline

#36 2023-07-13 10:07:42

mirrortokyo
Member
Registered: 2021-04-08
Posts: 45  

Re: PulseAudio always resets to mute

Does anyone have ideas for a more elegant way of setting the default pulseaudio device?

Offline

#37 2023-07-13 13:30:01

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: PulseAudio always resets to mute

Elegant way is to just use alsa alone.
Anything on top of alsa that 'modifies' 'enhances' sound file, is for retards, use ffmpeg.

If (like me,) you can not, for example, get sound out of your hdmi monitor speakers, all alsa configuration methods will fail, I tell you no lie, I am not the only one, we are many.

apt-get install alsa-topology-conf alsa-ucm-conf alsa-utils

/etc/init.d/alsa-utils reset

apt-get install pulseaudio pavucontrol

In GUI, run pavucontrol and setup configuration, e.g., I want sound out of line out on my box and my HDMI monitor speakers as well.

Purge pulseaudio and pavucontrol, I purge the flipping lot with debfoster (& rm /var/lib/debfoster/keepers.)

touch /etc/asound.conf

vi (or whatever,) /etc/asound.conf
defaults.pcm.card 0
defaults.pcm.device 3 # my flipping HDMI monitor speakers
defaults.ctl.card 0

pavucontrol does something that makes alsa asound.conf 'work.'

Do `/etc/init.d/alsa-utils reset` again, and it will trash it.

A very clever person could tell us what pavucontrol 'modifies,' so we wouldn't have to do the pavucontrol thing, and we are many.
If somebody tells us what pavucontrol does, without actually doing it themselves, that's not very clever.
AT ALL

P.S., try pavucontrol before jerking around with modules, and firmware-intel-sound firmware-misc-nonfree firmware-sof-signed

Last edited by andyp67 (2023-07-13 15:22:56)

Offline

#38 2023-07-17 04:18:56

zapper
Member
Registered: 2017-05-29
Posts: 895  

Re: PulseAudio always resets to mute

andyp67, mostly agree, one exception though,pure alsa is only beaten by one thing, alsa-lib + sndio - alsasound.

If you can get it working of course. wink

Some distros can, hard to know if Devuan is one of them, never tried before for whatever reason. Perhaps I didn't know if the service's name. Idk...

People who need pipewire and pulseaudio aren't dumb, they just like unneeded bloatware.

Still foolish? In my opinon, yes... but what can you do.

:shrug:

btw, nice necro. This page was dead 2 years ago. tongue

Last edited by zapper (2023-07-17 04:19:23)


Freedom is never more than one generation away from extinction. Feelings are not facts
If you wish to be humbled, try to exalt yourself long term  If you wish to be exalted, try to humble yourself long term
Favourite operating systems: Hyperbola Devuan OpenBSD
Peace Be With us All!

Offline

#39 2023-07-17 07:44:41

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: PulseAudio always resets to mute

zapper, it's grand that you've added some more intel about this minefield,
I do wax lyrical some you know, we all try and that's not dumb.
Now I am introduced to sndio, there's a wikipedia page and packages.debian Description search found 11 matching packages.
I suppose we all gather intel from many sources of course.
All the docs are greatly better these days in it, certainly Arch Linux.
Distro's that I spin to troubleshoot, well Knoppix, thesedays easyos certainly, MX Linux is greatly popular.
Pipewire appears to be the way forward, I buy that, head on a sticks two penneth.
So actually pulseaudio is my best friend because it appears to work some magic under the hood and hey presto asound.conf then works and can be configured as total as you like.
Thanks zapper.

Last edited by andyp67 (2023-07-17 07:46:03)

Offline

#40 2023-08-06 01:02:01

zapper
Member
Registered: 2017-05-29
Posts: 895  

Re: PulseAudio always resets to mute

Given the version devuan has, currently, or at least last I checked, it might be more beneficial to have alsasound.

This being said, to each their own.


Freedom is never more than one generation away from extinction. Feelings are not facts
If you wish to be humbled, try to exalt yourself long term  If you wish to be exalted, try to humble yourself long term
Favourite operating systems: Hyperbola Devuan OpenBSD
Peace Be With us All!

Offline

#41 2024-01-10 22:43:43

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 612  

Re: PulseAudio always resets to mute

Hi, you can make the changes to /etc/asound.conf, by using
~/.asoundrc

defaults.ctl.card 0
defaults.pcm.card 0
defaults.timer.card 0

use your researched values...

~/.asoundrc has precedence over /etc/asound.conf

I use this to Not use hdmi (desktop-tower, not laptop)... I've sure it works both ways.


pic from 1993, new guitar day.

Offline

#42 2024-04-18 21:25:16

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,457  

Re: PulseAudio always resets to mute

Finally, there's a solution. Someone figured out that pulseaudio saves settings in files that are named with the dbus machine-id. In Devuan, that machine-id changes with each reboot. They're kept in ~/.config/pulse.

You can edit /etc/default/dbus to comment the last line as shown below to disable the machine-id change.

# This is a configuration file for /etc/init.d/dbus; it allows you to
# perform common modifications to the behavior of the dbus daemon
# startup without editing the init script (and thus getting prompted
# by dpkg on upgrades).  We all love dpkg prompts.

# Parameters to pass to dbus.
PARAMS=""

# IDTYPE: how to deal with /var/lib/dbus/machine-id:
# 
# if IDTYPE="RANDOM": regenerate /var/lib/dbus/machine-id at each boot
# else keep it fixed across reboots
#IDTYPE="RANDOM"

It's also possible to rename those files so they use the current machine-id so they work.

Online

#43 Yesterday 20:38:36

grunchy
Member
Registered: 2024-01-01
Posts: 12  

Re: PulseAudio always resets to mute

thanks fsmithred! forum search led me here.

the IDTYPE=RANDOM was the problem for me. comment-out this line and machine_id
remains stable across boots.

this change keeps pulseaudio stable with no build-up of junk files in ~/.config/pulse.
it also keeps the ~/.dbus/session-bus/ directory clean as well, which is welcome.

i had scripts to handle the build-up of junk files in these two dirs, which have now been deleted.

FYI, after making the above change i came across this blog post, which adds a little more info:

https://kelar.org/~bandali/blog/pacify.html

Offline

#44 Today 08:39:58

alexkemp
Member
Registered: 2018-05-14
Posts: 311  

Re: PulseAudio always resets to mute

My desktop works under Daedalus. /etc/default/dbus looks nothing like the above for me:

$ cat /etc/init.d/dbus | fgrep -i IDTYPE
  if [ "${IDTYPE}" = "RANDOM" ] && \

Here is the only bit of /etc/init.d/dbus that applies:

create_machineid() {
  # Create or recreate machine-id file
  
  UPTIME=$(cat /proc/uptime | cut -d " " -f 1 | sed 's/\..*//g')
  # re-create machine-id if it already exists and this is the first 
  # time the initscript is called (either PIDDIR does not exist or
  # uptime is less than GRACETIME)
  if [ "${IDTYPE}" = "RANDOM" ] && \
     [ -f "${MACHINEID}" ] && \
     [ ! -d "$PIDDIR" -o ${UPTIME} -lt ${GRACETIME} ]; then 
        rm -f "${MACHINEID}"
  fi 
  if [ -x $UUIDGEN ]; then
    $UUIDGEN $UUIDGEN_OPTS
  fi
}

Presumably something sets $IDTYPE to "RANDOM", but it is not in that script-file.

Offline

#45 Today 11:39:47

aluma
Member
Registered: 2022-10-26
Posts: 617  

Re: PulseAudio always resets to mute

The same one, open it in the editor.
I placed ~/.dbus/session-bus/ in RAM and the sound works from pure alsa, so there are no such problems.
35.jpg

Offline

#46 Today 12:07:49

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,190  

Re: PulseAudio always resets to mute

@alexkemp; late evening perhaps smile
Please check /etc/default/dbus again (which indeed is different from  /etc/init.d/dbus).

Offline

#47 Today 12:23:05

alexkemp
Member
Registered: 2018-05-14
Posts: 311  

Re: PulseAudio always resets to mute

aluma wrote:

The same one, open it in the editor.

I opened '/etc/init.d/dbus' in Mousepad. It reported "1 occurrence" when I searched for 'IDTYPE'.

$ uname -a
Linux ng3 6.1.0-22-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.94-1 (2024-06-21) x86_64 GNU/Linux

Where is the 'dbus' that you opened in KWrite?

Ah! No need to respond! It took a while, then I spotted that I mis-read: it is in /etc/default/dbus.

Many thanks. I've now changed that setting.

Offline

Board footer