The officially official Devuan Forum!

You are not logged in.

#26 2024-01-23 15:47:50

mirrortokyo
Member
Registered: 2021-04-08
Posts: 44  

Re: How to: Devuan 5 Daedalus an pipewire

Thanks @steve_v, one last thing - you should have mentioned that /usr/bin/daemon is in package daemon.

Offline

#27 2024-01-23 18:09:33

steve_v
Member
Registered: 2018-01-11
Posts: 342  

Re: How to: Devuan 5 Daedalus an pipewire

I kinda did, a few posts earlier in this thread:

steve_v wrote:

using daemon to manage pipewire (and cdemu, which has the same problems). Binding to the user session requires [e]logind and backporting daemon from unstable

daemon has very few dependencies, so a backport is trivial.

Last edited by steve_v (2024-01-23 18:11:56)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#28 2024-02-23 18:00:29

ffp
Member
Registered: 2024-02-23
Posts: 1  

Re: How to: Devuan 5 Daedalus an pipewire

Hello friends, I tried the implementations listed here on my Dell Latitude 7480 laptop and while they do work, I sometimes had to reboot my laptop a few times to get working audio or manually kill and start the pipewire processes from terminal.
I found a different solution which worked for me and I wanted to share it with you too in case you have a similar problem:

In /etc/X11/Xsession.d/ create a file and call it 98-pipewire and put the following script into it:

#!/bin/bash

# We need to kill any existing pipewire instance to restore sound
pkill -u "${USER}" -fx /usr/bin/pipewire-pulse 1>/dev/null 2>&1
pkill -u "${USER}" -fx /usr/bin/pipewire-media-session 1>/dev/null 2>&1
pkill -u "${USER}" -fx /usr/bin/wireplumber 1>/dev/null 2>&1
pkill -u "${USER}" -fx /usr/bin/pipewire 1>/dev/null 2>&1

exec /usr/bin/pipewire &

# wait for pipewire to start before attempting to start related daemons
while [ "$(pgrep -f /usr/bin/pipewire)" = "" ]; do
        sleep 1
done

if [ -x /usr/bin/wireplumber ]; then
	exec /usr/bin/wireplumber &
elif [ -x /usr/bin/pipewire-media-session ]; then
	exec /usr/bin/pipewire-media-session &
fi

[ -f "/usr/share/pipewire/pipewire-pulse.conf" ] && exec /usr/bin/pipewire-pulse &

And with this I get audio on every reboot so no more restarting my laptop multiple times.

The only issue I had after doing this is that sometimes the audio was a bit choppy.
I found a solution on the Debian wiki but it had to be applied on every boot so I did this:

In /usr/share/pipewire/pipewire.conf I uncommented and changed the settings

default.clock.allowed-rates = [ 44100 48000 ]
default.clock.quantum       = 2048
default.clock.min-quantum   = 2048

And after rebooting this was solved for me too. I hope this can help you as well!

Offline

#29 2024-02-27 17:41:55

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 186  

Re: How to: Devuan 5 Daedalus an pipewire

I hope this can help you as well!

Thank you ffp!  This got pipewire working on a daedalus install that has been dist-upgraded from ascii > beowulf > chimaera > to daedalus!

Offline

#30 2024-02-29 18:29:04

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 186  

Re: How to: Devuan 5 Daedalus an pipewire

steve_v, would you please elaborate how you used daemon to run the commands you quoted?  Specifically, where did you put these commands and how did you "autostart" them?

In 3 autostart files (or wherever else you might want them).

I have tried to run them from /etc/rc.local.  I tried to add your commands to the /etc/daemon.conf file and tried to add them individually to /etc/daemon.conf.d folder.  Try as I might, I can only get the "daemon --list --verbose" command to output "No named daemons are running".  I was just trying things because my web searching on how to use "daemon" was not very successful.

But, I added the three commands to a file in /usr/local/bin and set it to autostart upon login with xfce and pipewire does work.  But I still get the "No named daemons are running" output from the terminal. 

I have tried this on both daedalus and ceres and I get the same results.  Any additional information would be appreciated.

Last edited by nixer (2024-02-29 18:30:04)

Offline

#31 2024-03-23 23:53:14

mweishaar
Member
Registered: 2018-11-11
Posts: 34  

Re: How to: Devuan 5 Daedalus an pipewire

@nixer I couldn't get it to work either, but when I run the daemon command from the terminal I get "unrecognized option '--bind' " which would explain why it isn't working. I have daemon 0.8-1+b1 from backports. But re-reading, steve_v said unstable backports.
I'll have to look up how to install from unstable, I usually don't mess with that. smile

Maybe you have the same issue.

Offline

Board footer