The officially official Devuan Forum!

You are not logged in.

#1 2024-01-10 02:13:50

Zen997
Member
Registered: 2021-12-22
Posts: 2  

pavucontrol sound card settings change after reboot

I have 2 sound output devices on my Devuan 5 system - Analog and HDMI Digital. When I set the pavucontrol > Configuration > Built-in Audio to HDMI Digital, it always defaults to Analog after reboot, the HDMI cable is always connected and nothing else have changed. How to set the pavucontrol to keep all the settings after reboot? This applies only to Devuan 4 and Devuan 5. Debian 11, Debian 12 and Ubuntu 22.04 LTS keep all pavucontrol settings until I change them. Is it somehow related to sysvinit (Devuan) vs. systemd (Debian, Ubuntu)? Is pulseaudio in some way dependent on systemd? Thank you.

Offline

#2 2024-01-10 06:54:39

mirrortokyo
Member
Registered: 2021-04-08
Posts: 39  

Re: pavucontrol sound card settings change after reboot

Are you using pulseaudio? When I was using pulseaudio I had to set the default output in a configuration file, see this post and the following post:

https://dev1galaxy.org/viewtopic.php?pid=28936#p28936

I haven't had to do that with pipewire as the settings in KDE/plasma audio settings have held.

Last edited by mirrortokyo (2024-01-10 06:58:20)

Offline

#3 2024-01-20 00:29:28

Zen997
Member
Registered: 2021-12-22
Posts: 2  

Re: pavucontrol sound card settings change after reboot

Thank you for the answer. Yes, I use pulseaudio and pavucontrol, which might be, as someone described "Red Hat garbage" (including the pipewire and systemd as well). The best way is to only use alsa, however setting default sound inputs, outputs, etc. is much less convenient. Also, sound in Firefox only works with pulseaudio (the workaround is to use apulse). Waterfox doesn't have this problem, so the sound works with alsa only. I will try your solution. Strange fact is that the bug is in Debian, but in my case Debian and Ubuntu keep all the sound settings perfectly after reboot. Only Devuan requires changing the sound card settings manually after every reboot. I am not the only one having this problem. I have seen many reports regarding the sound issues in Devuan on the web and in Devuan reviews on Distrowatch.

Offline

#4 2024-01-20 00:57:08

stultumanto
Member
Registered: 2023-12-12
Posts: 42  

Re: pavucontrol sound card settings change after reboot

Also, sound in Firefox only works with pulseaudio (the workaround is to use apulse).

We were just discussing this issue in another thread, as I recently discovered the version of Firefox in the repositories does not require PA. According to other posters, it never has, so I must have been remembering some other distribution.

FWIW I also noticed my PA settings were being reset on every reboot with Devuan, but I only had it installed briefly, and never tried to fix the issue.

Offline

#5 2024-01-20 01:32:28

quickfur
Member
Registered: 2023-12-14
Posts: 132  

Re: pavucontrol sound card settings change after reboot

A year or two ago firefox (from the Debian repo, so by extension in Devuan as well) indeed failed to play audio without pulseaudio. Or rather, it did so erratically, sometimes it would work, sometimes it wouldn't. Googling online turned up discussions about no longer supporting ALSA.  But recently this problem has gone away. I don't know if it's because they got enough backlash that they reconsidered this decision, or something else changed, but now firefox audio works fine without PA running.

Online

#6 2024-01-20 01:57:39

golinux
Administrator
Registered: 2016-11-25
Posts: 3,105  

Re: pavucontrol sound card settings change after reboot

I have never had a problem using apulse with an .asoundrc file.

Offline

Board footer