The officially official Devuan Forum!

You are not logged in.

#151 2020-05-06 09:12:11

Andre4freedom
Member
Registered: 2017-11-15
Posts: 38  

Re: Beowulf Beta is here!

Testing the new isos Beta2: devuan_beowulf_3.0.0_beta2_amd64_desktop-live.iso

Result: great. far better that beta1. The only bug I have detected I have just filed a bugreport for: lightdm.
Here are my comments for those interested:
Installed a new system on a Dell Optiplex GX780 (BIOS/MBR)

1. Created new user
2. Login as new user:
--> Message: Unable to contact the Wicd daemon due to an access denied error from DBus. Please check that your user is in the netdev group.

3. sudo usermod -aG netwdev andre

4. Login as new user:
--> Problem still there.

5. Installed lightdm and lightdm-gtk-greeter-settings

6. Reboot and login using lightdm:
--> OK, but actions-menu-entries still greyed.
--> Wicd message gone, --> problem gone

7. Corrected:
    sudo vi /etc/pam.d/lightdm-greeter
    changed line to: session   optional pam_elogind.so (I have filed a bugreport for that)

8. Reboot --> actions-menu-entries now working on login screen

9: /etc/pulse/client.conf.d/00-disable-autospawn.conf
    is corrected in this release. Great! Bravo!

10. Synaptic: added Cinnamon

11. Reboot and login (Cinnamon): works perfectly well.

12. Bug: Installer did not respect locale settings, corrected:
--> sudo dpkg-reconfigure locales

13. Missing software: Java Runtime 8 (jre8)
    (where is the nvidia-openjdk-8-jre package?)

Andre, May 5, 2020

THANK YOU FOR YOUR GREAT WORK AND FOR DEVUAN LINUX!

Offline

#152 2020-05-06 14:08:25

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

5. Installed lightdm and lightdm-gtk-greeter-settings

6. Reboot and login using lightdm:
--> OK, but actions-menu-entries still greyed.

7. Corrected:
    sudo vi /etc/pam.d/lightdm-greeter
    changed line to: session   optional pam_elogind.so (I have filed a bugreport for that)

8. Reboot --> actions-menu-entries now working on login screen

This is fixed in ceres. The fix might make it into beowulf for a later (not too much later) point-release.
Manual fix is already described in the release notes.


9: /etc/pulse/client.conf.d/00-disable-autospawn.conf
    is corrected in this release. Great! Bravo!

Only in the desktop-live, where it's really easy to make such changes.


12. Bug: Installer did not respect locale settings, corrected:
--> sudo dpkg-reconfigure locales

This needs to be fixed in the live installer. If you select your locale and keyboard when you boot the live media, those settings will be carried over to the installed system.

13. Missing software: Java Runtime 8 (jre8)
    (where is the nvidia-openjdk-8-jre package?)

That package is in non-free. You'll need to add that to your software sources and update/refresh before installing it.

Offline

#153 2020-05-06 14:12:35

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

To get rid of those repeating udev warnings, I tried (and failed) disabling lvm. Made a new snapshot and booted it from DVD. It booted without the repeated warnings. Instead, I got them on shutdown, and whenever it reached the end of the list, it would start over.

It's the device mapper that's doing this, but I don't know what calls it or how it's called. It appears to be confused.

Offline

#154 2020-05-06 15:07:27

Andre4freedom
Member
Registered: 2017-11-15
Posts: 38  

Re: Beowulf Beta is here!

Thank you, fsmithred!
I'm very happy with the Devuan linux and I recommend it to everyone.

Offline

#155 2020-05-07 12:48:38

pcalvert
Member
Registered: 2017-05-15
Posts: 75  

Re: Beowulf Beta is here!

fsmithred wrote:

To get rid of those repeating udev warnings, I tried (and failed) disabling lvm. Made a new snapshot and booted it from DVD. It booted without the repeated warnings. Instead, I got them on shutdown, and whenever it reached the end of the list, it would start over.

I found something that looks like it could be a possible solution (or workaround):

https://bbs.archlinux.org/viewtopic.php … 5#p1867015


The Gentoo wiki page that he linked to seems to have some good info (based on my limited understanding) about this problem.


Phil


“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln

Offline

#156 2020-05-07 14:27:15

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

Oh, you are my hero, Phil. Nice find!

I made a test refracta iso because it's easier to include a custom initrd, and it seems to fix the issue. DVD boots without the udev warnings or any other delays, and then I have no mouse or keyboard on the desktop. Plugging a mouse into the laptop wakes up the trackpad and the keyboard. Plugging in a usb flash drive does not wake up the inputs.

Test iso is here:
https://get.refracta.org/files/testing/ … 7_1346.iso

sha256sum:

f527940265e4dff0b7b807611e1ebb96fc870ab03e505a4bb52c70b9aa5fefaf  refracta10-beta2+_xfce_amd64-20200507_1346.iso

Here is what I changed in /etc/lvm/lvm.conf inside initrd.img:

devices {
    # Disable scanning udev for md/multipath components.
    # This is required with recent versions of lvm2, even if you use another solution for
    # your LV device nodes; without it lvm commands will stall for minutes waiting for udev.
    multipath_component_detection = 0
    md_component_detection = 0
}
activation {
    # Set to 0 to disable udev synchronisation (if compiled into the binaries).
    udev_sync = 0
    # Set to 0 to disable the udev rules installed by LVM2
    udev_rules = 0
}

Reference: https://wiki.gentoo.org/wiki/Custom_Initramfs#LVM

Offline

#157 2020-05-09 00:27:28

golinux
Administrator
Registered: 2016-11-25
Posts: 2,032  

Re: Beowulf Beta is here!

Seems you are unaware of the significance of Beowulf.  It was a bloody mess.   Devuan is different.  Maybe when you're no longer a self-proclaimed  noob, you will be better able to appreciate that difference.  If you want mainstream, you certainly have plenty of options.

Offline

#158 2020-05-09 05:29:10

darry1966
Member
Registered: 2017-06-14
Posts: 75  

Re: Beowulf Beta is here!

Quote"Oh, you are my hero, Phil. Nice find!

I made a test refracta iso because it's easier to include a custom initrd, and it seems to fix the issue. DVD boots without the udev warnings or any other delays, and then I have no mouse or keyboard on the desktop. Plugging a mouse into the laptop wakes up the trackpad and the keyboard. Plugging in a usb flash drive does not wake up the inputs.

Test iso is here:
https://get.refracta.org/files/testing/ … 7_1346.iso"


@fsmithred  Thanks for the new Refracta Buster Iso you seemed to have fixed the dpkg problems that I have had with Debian Buster and Devuan Beowulf - lovely to use so far Compaq CQ61. Was able to use dpkg-reconfigure tzdata without problems.

Gdebi-gtk which I use working well with .deb. 

Will keep testing a big thank you for this.

Last edited by darry1966 (2020-05-09 05:55:03)

Offline

#159 2020-05-09 20:53:48

pcalvert
Member
Registered: 2017-05-15
Posts: 75  

Re: Beowulf Beta is here!

I upgraded from ASCII to Beowulf last night, and things did not exactly go well. I'm getting the udev warnings, but that wasn't a complete surprise. When the system boots up, it never switches to framebuffer mode. The worst part is that I can't log in because I get this message on my monitor:

Input Signal Out of Range
Change Settings to 1600x900 - 60Hz

I can get to the GRUB screen, and I can log in as root using Recovery Mode, so I may be able to fix things (if I knew what to do).

Phil

Last edited by pcalvert (2020-05-09 23:06:17)


“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln

Offline

#160 2020-05-10 12:45:05

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

pcalvert: check ~/.xsession-errors, /var/log/Xorg.0.log, /var/log/apt/history.log (to see if something important got removed), maybe try grub-install and update-grub again.

darry1966: The problem is not with dpkg. The behavior of su changed when they moved it to a different source package. I've found the easiest way to restore the old behavior is to put ALWAYS_SET_PATH yes in /etc/default/su. (create the file if it doesn't exist)

I fixed root's path in Refracta isos, where I have more freedom to stray from the default settings. The Devuan live isos won't get that fix, same as if someone installs from the installer isos.

Edit: pcalvert,  Maybe edit the grub screen at boot, add set gfxpayload=1600x900 before the linux line.

Offline

#161 2020-05-10 19:21:20

darry1966
Member
Registered: 2017-06-14
Posts: 75  

Re: Beowulf Beta is here!

Thankyou Fsmithred.

I'll test this out in a Devuan install.

Offline

#162 2020-05-11 10:45:29

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 133  
Website

Re: Beowulf Beta is here!

I have been working on Beta and Beta2 for a while. Thank you to all you people for your work.

I always use expert install from devuan_beowulf_3.0.0_beta2_amd64_netinstall.iso

Standard XFCE instalation was fine, with the already said glitches about locales and tzdata. Not big deal.

Then I tried KDE install and it was fine: KDE is far more usable on low specs computer with Beowulf than with Stretch. But the instaler put on the drive both KDE and XFCE. This is a bug, IMHO.

Then I went to my real test: from a minimal install going installing just what I want, without metapackages, avoiding possible unwanted packages. I did two tries:

First try was what I already do succesfully with Devuan 2 ASCII: from expert netinstall, not choose any software nor configure apt, and do it after instalation. I could not finish that way because the system installed missed important packages, as the dhcp client.

Second try, from expert netinstall also, I choose configure apt, but not marking any task at all: the installed system had standard XFCE. Another bug, IMHO.

I'm stuck now. Do you have any advice about how to get a very minimal setup workable? It is top priority now for me, as I'm going to install ASAP Beowulf on a work computer for my wife to use her brand new Wacom tablet, so I'm able to work on this as much as needed.

Thanks to all of you.

Offline

#163 2020-05-11 13:01:47

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 453  

Re: Beowulf Beta is here!

You should rather use the "server" iso, which is intended for offline installation.

In fact, all the beowulf installation iso have the same basic installer, but they differ in their on-media pool. The netinstall pool is just enough to let you install from the network, and if you don't, you don't get a very useful system. For beowulf beta3, now available, the netinstall iso pool has been inflated beyond bare necessity to correspond to a debootstrap minbase package collection. That is still not really intended to be used for an offline installation, but it might be possible.

Offline installation is rather what the server iso is intended for, or the desktop iso, if you want a desktop environment but don't want to juggle the CD sized expansion isos for the server iso. Both server and desktop also allow network mirror during installation the same way as the netinstall iso, in which case of course the whole package pool is available.

Online

#164 2020-05-11 13:37:03

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

FWIW, I did an offline install with the beta3 netinstall iso, and it had the necessary packages to edit sources.list and get online. I'm guessing the build was not limited to minbase, which doesn't include those packages.

Also...

beta3 live isos have been uploaded. The lvm/udev issue seems to be resolved.

Offline

#165 2020-05-11 14:17:51

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 133  
Website

Re: Beowulf Beta is here!

ralph.ronnquist wrote:

For beowulf beta3, now available, ...

fsmithred wrote:

I did an offline install with the beta3 netinstall iso

Thank you both. Downloading beta3...

It works, minimal install gave me a working system, with network and apt fully operative. Fixed.

Last edited by PedroReina (2020-05-11 15:40:47)

Offline

#166 2020-05-11 18:26:43

rolfie
Member
Registered: 2017-11-25
Posts: 400  

Re: Beowulf Beta is here!

fsmithred wrote:

beta3 live isos have been uploaded.

Use the beta3 netinstall for an encrypted LVM offline installation to command line. Polished the sources.list, made the network available and installed my preferred DE. Perfect install, all previous issues I had are resolved.

A very big "Well Done" to the Devuan team.

rolfie

Offline

#167 2020-05-11 22:15:25

dev-1-dash-1
Member
Registered: 2018-08-02
Posts: 80  

Re: Beowulf Beta is here!

fsmithred wrote:

The lvm/udev issue seems to be resolved.

Not so fast big_smile
Still there, unfortunately

Offline

#168 2020-05-12 12:57:41

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

dev-1-dash-1 wrote:
fsmithred wrote:

The lvm/udev issue seems to be resolved.

Not so fast big_smile
Still there, unfortunately

Please give more details about what you did so that someone can reproduce it.

Offline

#169 2020-05-12 15:42:56

dev-1-dash-1
Member
Registered: 2018-08-02
Posts: 80  

Re: Beowulf Beta is here!

fsmithred wrote:

Please give more details about what you did so that someone can reproduce it.

Same thing - booting from dvd.
Lvm/udev loop timeout, mouse and kb not working in desktop (though they do in console).
"Toram" helps, I can login to desktop, but I have a freeze on shutdown (maybe the same loop going on somewhere in the background).

One thing is constant among all beta versions: screen font doesn't change when things aren't working (from dvd, no "toram") - means problem is already there when udev is detecting my videocard? Also when mouse/kb stop working, it happens exactly the moment when display manager starts and switches me to the x display-console away from console.

Maybe my video driver gives udev some confusion? i915 module. Any way to boot with some kind of "default generic safe-mode video driver"?

Beowulf already installed to hd using debootstrap continues to work marvelously through all of this.

Offline

#170 2020-05-13 19:18:31

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

One thing is constant among all beta versions: screen font doesn't change when things aren't working (from dvd, no "toram") - means problem is already there when udev is detecting my videocard? Also when mouse/kb stop working, it happens exactly the moment when display manager starts and switches me to the x display-console away from console.

I'm not sure what to do about this, but I'm quoting it to remind me about it.

Meanwhile, the changes to the initramfs that I made did not actually get applied, and I'm not sure why. I may have to do that part manually.

Anyway...   beta-#*@%ing-4 coming soon.

Offline

#171 2020-05-13 20:16:43

dev-1-dash-1
Member
Registered: 2018-08-02
Posts: 80  

Re: Beowulf Beta is here!

fsmithred wrote:

One thing is constant among all beta versions: screen font doesn't change when things aren't working (from dvd, no "toram") - means problem is already there when udev is detecting my videocard? Also when mouse/kb stop working, it happens exactly the moment when display manager starts and switches me to the x display-console away from console.

I'm not sure what to do about this, but I'm quoting it to remind me about it.

In more detail what I've tried:
Boot from dvd, do not use "toram".
Boot into single user mode, lvm timeout errors come up, but ctrl-c gets rid of them.
Disable slim from being autostarted in runlevel 2.
Press ctrl-d to exit single user, boot goes on to runlevel 2.
All init scripts (except slim) get started up.
I log in, do dhclient eth0, it works, install gpm, it works.
So network, mouse and kbd are working well in runlevel2 with everything except slim being started.

After that I type service slim start and keep pressing caps-lock to see if kb responds - it does, until the resolution gets changed, I am switched to another display and exactly at that moment mouse and kb stop responding, unplugging and replugging them doesn't help, though the system isn't frozen - the clock on taskbar keeps changing every minute.

Next time I've tried to install lightdm, thought maybe it's slim going crazy, but no, the same happens when starting lightdm.

Other thing: there's a whole lot of drivers loaded when live image boots. Maybe some conflicts with specific drivers for some types of hardware? Are those raid<whatever> drivers really needed by default on livecd?

Meanwhile, the changes to the initramfs that I made did not actually get applied, and I'm not sure why. I may have to do that part manually.

Anyway...   beta-#*@%ing-4 coming soon.

Great tempo, keep them coming!

PS I am writing this from a beowulf system. It really does not feel like a beta/testing release, at least for my desktop needs.

Offline

#172 2020-05-14 01:39:32

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

Yeah, beowulf is ready - it's just the installation media we're struggling with. I've been using beowful since the beginning of this year.

The Refracta isos use lxdm, and the input problem exists there, too.

Editing /etc/lvm/lvm.conf in the initramfs gets rid of the repeated udev warnings on boot.
Editing /etc/lvm/lvm.conf in the live system gets rid of the repeated udev warnings on shutdown.

Replacing xserver-xorg-input-libinput with xserver-xorg-input-evdev didn't help the mouse/keyboard problem.

I've considered removing lvm2 and mdadm, but they're nice to have if you're using the live-iso as a rescue system or if you want to go to the trouble of manually setting up lvm or raid to install from the live. (It's possible, just not obvious.) And they were added in ascii by request from the community. Disabling lvm in runlevel 2 didn't fix the problem. But editing lvm.conf in both places did get rid of the messages.

Thanks for the detailed testing and report. Not exactly sure what I'll try next. Something tomorrow.

Offline

#173 2020-05-14 15:50:23

dev-1-dash-1
Member
Registered: 2018-08-02
Posts: 80  

Re: Beowulf Beta is here!

Editing /etc/lvm/lvm.conf in the initramfs gets rid of the repeated udev warnings on boot.
Editing /etc/lvm/lvm.conf in the live system gets rid of the repeated udev warnings on shutdown.

I don't think lvm is the root cause of the problem here.
Including the fixes does sound like a good idea though.

Also, maybe don't start lvm at all during boot?
People who will mount complex lvm/raid configs will type a lot of commands, it's probably not too much trouble to type one more command to start lvm.
On the other hand, if you freeze during boot or your mouse/kb won't work, lvm is useless for you.

Also: what is it that the "toram" parameter does that unhugs the boot process and allows everything to work?
It can't be just the delay, because "rootdelay=300" doesn't help.
Maybe take a closer look at the scripts activated by "toram" parameter. Something they do allows the boot to proceed.

I'm not that familiar with the internals of a debian/devuan initramfs to know where to look.

Offline

#174 2020-05-14 18:40:19

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,621  

Re: Beowulf Beta is here!

With a Refracta DVD, I can ssh in when it gets to the desktop. I tried several things to get mouse and keyboard to work.

All of the following failed:
- restart lxdm
- restart eudev
- restart dbus
- disable autologin in lxdm and restart it
- init 1, ctrl-d


What does work:
- modprobe -r psmouse && modprobe psmouse   (I don't even need to kill the desktop and restart it for this to work)

Offline

#175 2020-05-15 13:52:08

dev-1-dash-1
Member
Registered: 2018-08-02
Posts: 80  

Re: Beowulf Beta is here!

Here's a trick I've tried:
Boot beta3 live dvd
In the grub screen, edit default command line:
Replace username=devuan with username=root
Boot to desktop
(Use the usual ctrc+c to get out of lvm loop)
Desktop comes up, mouse and kb NOT working, but after I disconnect/reconnect the mouse, dvd starts screeching for a few seconds(loading something), and mouse/kb start working, and I have a working desktop. Which doesn't happen when I boot as username=devuan, it doesn't react to disconnect/reconnect of the mouse. Which probably means that there are at least some permission issues.

Offline

Board footer