The officially official Devuan Forum!

You are not logged in.

#1 2017-05-15 09:14:12

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

[SOLVED] Redshift fails to start - .service files missing?

DELL Inspiron 5559
Processor: IntelCore i7-6500U CPU 2 Cores, 4 Logical Processors
Integrated Graphics Processor: Intel HD Graphics 520
Discrete Graphics Processor: AMD Radeon R5 M335
Drive: Crucial CT750MX3 SSD size: 750GB
Memory: 16GB

Hi, I have installed the latest image 'devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso' on my DELL laptop.

Then I installed 'gtk-redshift' via synaptic package manager (couldn't find usual redshift-gtk package)

I have also copied my config file as I would normally do....

sudo cp redshift.conf ~/.config/

here is contents of redshift.conf

; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=6500
temp-night=3400

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9

; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4

; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: 'geoclue', 'geoclue2', 'manual'
; type 'redshift -l list' to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings.
; ex: 'redshift -l manual:help'
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=55.825
lon=-4.417

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings.
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust _all_ screens.
[randr]
screen=0

I have used this config file many times in the past and it usually works ok.

...but redshift fails to start via the applications menu (this also happens with Synaptic Package Manager, not sure why this is happening) so I need to start via terminal but I get following error message...

hugh@DELL-INSP-DEVUAN:~$ sudo redshift
[sudo] password for hugh: 
Trying location provider `geoclue'...
Unable to obtain master client: The name org.freedesktop.Geoclue.Master was not provided by any .service files
Failed to start provider geoclue.
Trying next provider...
Trying location provider `manual'...
Latitude and longitude must be set.
hugh@DELL-INSP-DEVUAN:~$ 

I tried installing 'geoclue' then 'geoclue-2.0' but made no difference.

I have installed redshift several times in the past and normally have no problems.

I'm not sure if there is something wrong with my configuration so I was wondering if anyone had experienced this same error on Devuan and how I can fix it.  I have limited technical skills but can use terminal if I know the correct syntax. Any help/advice would be appreciated.

EDIT: I just noticed my ~/.config/redshift.conf file had [redshift] on second line so I tried changing this to [redshift-gtk] to see if this makes a difference

$ sudo nano ~/.config/redshift.conf
; Global settings for redshift
[redshift]

change to ...

; Global settings for redshift
[redshift-gtk]

Now I can start Redshift from the menu where I couldn't before. I can also now start from the termininal as well by entering ...

hugh@DELL-INSP-DEVUAN:~$ redshift-gtk

The '~/.config/redshift.conf' file that I used is normally used for the newer 'redshift-gtk' v1.11-1 package and not the older 'gtk-redshift' v1.9.1-4 which was all that was available in Synaptic Package Manager.  I think the name change adds a bit of confusion as well.

I will wait till this evening to see if the screen does change colour to indicate it is working as intended, and will update this post with results.

EDIT2: I checked Redshift again tonight but although it starts and icon is displayed in the app indicator panel along the top, the screen colour doesn't change as expected. So there must be something wrong with my ~/.config/redshift.conf file.  I know it does work with the the newer 'redshift-gtk' v1.11-1 but looks like it won't work with older 'gtk-redshift' v1.9.1-4 which is the only version in the stable repositories. 

I will need to investigate how to make changes in my sources.list to see if I can get the newer version installed.  Is it possible to do this on the Devuan system?

Is it ok to just add following line?

deb http://ftp.debian.org/debian jessie-backports main

Or will there be any conflict with Devuan by doing this?
Is there a devuan equivalent to this line?

I had a look at the sources.list ....

hugh@DELL-INSP-DEVUAN:~$ cat /etc/apt/sources.list
## package repositories
deb [url]http://auto.mirror.devuan.org/merged[/url] jessie main contrib non-free
deb [url]http://auto.mirror.devuan.org/merged[/url] jessie-updates main contrib non-free
deb [url]http://auto.mirror.devuan.org/merged[/url] jessie-security main contrib non-free
#deb [url]http://auto.mirror.devuan.org/merged[/url] jessie-backports main contrib non-free

and I see there is a line for jessie-backports so I will try to enable that line and see if can install the newer 'redshift-gtk' v1.11-1

EDIT3: I enabled devuan jessie-backports and ran apt update but couldn't find the newer 'redshift-gtk' v1.11-1 package to install.  I wonder is there any other way to install this package?

Last edited by hughparker1 (2017-05-19 22:58:22)

Offline

#2 2017-05-16 16:40:04

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

I found a "redshift-gtk_1.11-1_all.deb" package on the debian website....

https://packages.debian.org/stretch/redshift-gtk

Looks like this version is for Debian stretch, but I wondered if it was worth trying to install it, or does anyone know if it would NOT be advisable to do this in Devuan as I understand that Devuan RC2 is based on Debian stable.

I haven't installed from a .deb file before but I had a look online and found this can be done by running following command in terminal...

$ sudo dpkg -i redshift-gtk_1.11-1_all.deb

Would it be safe enough to install this package?  I'm not very knowledgeable on installing from terminal, as I have only installed via Synaptic Package Manager before now. 

Alternatively, is adding a jessie-backports line to my sources.list a viable option...

deb http://ftp.debian.org/debian jessie-backports main

I apologise if is this a stupid idea, but I'm still learning Linux so not sure if these are realistic options.  Any advice/guidance would be appreciated.

Offline

#3 2017-05-16 17:00:33

golinux
Administrator
Registered: 2016-11-25
Posts: 238

Re: [SOLVED] Redshift fails to start - .service files missing?

Would be better to get the pkg from Devuan Ascii than Debian Stretch to avoid conflicts down the line.  No guarantee that either one won't break jessie though . . .

Offline

#4 2017-05-16 17:23:03

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

golinux wrote:

Would be better to get the pkg from Devuan Ascii than Debian Stretch to avoid conflicts down the line.  No guarantee that either one won't break jessie though . . .

I'll check out your recommendation, haven't heard about Devuan Ascii but I'll have a look for it.  Thanks @golinux for your help.

Offline

#5 2017-05-16 17:27:45

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

golinux wrote:

Would be better to get the pkg from Devuan Ascii than Debian Stretch to avoid conflicts down the line.  No guarantee that either one won't break jessie though . . .

Thanks again @golinux, I just found this link ... https://talk.devuan.org/t/upgrading-dev … -ascii/363

...the steps look straightforward enough, is there anything I should be careful about? I realise there are no guarantees though.

Offline

#6 2017-05-16 18:14:23

golinux
Administrator
Registered: 2016-11-25
Posts: 238

Re: [SOLVED] Redshift fails to start - .service files missing?

You probably don't want to upgrade to ascii - it is a bit broken atm.  Just enable the ascii repo to get that one package then disable it immediately.  Along the way, there may be unresolved dependencies and installing from different releases always has a risk of 'unintended consequences'.  Depends how adventurous you are and on your tolerance for breaking things.  Of course it may be perfectly fine.  Your choice.

Look at the bottom of this page for source information.

Note that I am very conservative while others think nothing of leaping into the unknown.

Offline

#7 2017-05-16 22:11:55

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

1. First. Important: What golinux said. Don't upgrade to ascii, just take what you need and then disable ascii. I can confirm that it runs on jessie. I only tested it on command-line. I didn't set it up to run automatically, and I don't like that it wants my latitude and longitude.

This works:

 2111  redshift -O 3500
 2112  redshift -O 5500

apt-cache policy shows:

  Version table:
redshift-gtk 
    1.11-1 0
         90 http://us.mirror.devuan.org/merged/ ascii/main amd64 Packages

gtk-redshift
     1.9.1-4 0
        500 http://us.mirror.devuan.org/merged/ jessie/main amd64 Packages

Offline

#8 2017-05-16 22:50:31

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

Thanks for feedback.

I created a new file...  /etc/apt/sources.list.d/devuan-ascii.list
and added these lines...

# for the testing suite
deb http://auto.mirror.devuan.org/merged ascii main

then run sudo apt update then opened Synaptic Package Manager: search for 'redshift'    (select redshift-gtk for install)

then start redshift from menu and icon appears but error message window popped up...

  • Failed to run Redshift
    Gamma ramp size too  small: 0
    Failed to start adjustment method randr.
    (B) Close

then icon disappears again.

There are several computers in my home with redshift installed and working, I checked what also gets installed along with redshift-gtk....

these packages should be installed:   

  • redshift-gtk        installed = yes
    redshift        installed = yes
    geoclue-2.0        installed = yes
    iio-sensor-proxy    installed = no
    libgeoclue-2.0        installed = yes

So 'iio-sensor-proxy' is missing in Devuan and perhaps this is significant, but not sure.

but when I try to install 'iio-sensor-proxy' I get following message...

  • Could not mark all packages for installation or upgrade
    The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences
    iio-sensor-proxy    Depends: systemd but it is not installable

not sure what I can do, I have Debian on another partition on my laptop and redshift is working ok.

Also, I just noticed that my brightness function keys are not working, so not sure if that gives us a clue as to why I am having problems with redshift not working.

Offline

#9 2017-05-16 23:07:31

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

Just thought I would mention that when I run open terminal and run 'redshift -v' it does seem to pick up details from '~/.config/redshift.conf' OK ....

hugh@DELL-INSP-DEVUAN:~$ redshift -v
Location: 55.83 N, 4.42 W
Temperatures: 6500K at day, 3400K at night
Solar elevations: day above 3.0, night below -6.0
Brightness: 1.00:1.00
Gamma (Daytime): 0.800, 0.800, 0.800
Gamma (Night): 0.800, 0.800, 0.800
Gamma ramp size too small: 0
Failed to start adjustment method randr.
hugh@DELL-INSP-DEVUAN:~$ 

so redshift.conf file seems to be recognised, but it shows error in the last two lines...

Gamma ramp size too small: 0
Failed to start adjustment method randr.

Offline

#10 2017-05-17 00:32:37

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

Make sure randr is installed. Check in synaptic. You can also see what methods are available to redshift with

redshift -m list

I can start 'redshift-gtk' on the command line if I give it my latitude and longitude. It works, it puts an icon in the system tray, and I can get an information window from that.

Offline

#11 2017-05-17 14:08:11

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

fsmithred wrote:

Make sure randr is installed. Check in synaptic. You can also see what methods are available to redshift with

redshift -m list

I can start 'redshift-gtk' on the command line if I give it my latitude and longitude. It works, it puts an icon in the system tray, and I can get an information window from that.

thanks for feedback, I opened terminal and ran 'redshift -m list'...

hugh@DELL-INSP-DEVUAN:~$ redshift -m list
Available adjustment methods:
  drm
  randr
  vidmode
  dummy

Specify colon-separated options with `-m METHOD:OPTIONS'.
Try `-m METHOD:help' for help.
hugh@DELL-INSP-DEVUAN:~$ 

Not sure what the output means to be honest, any advice would be appreciated.

I also tried opening terminal and running command with my my latitude and longitude....

$ redshift-gtk -l 55.82:-4.42 -t 6500:3400

but same happens as before, icon appears and error message window popped up...

  • Failed to run Redshift
    Gamma ramp size too  small: 0
    Failed to start adjustment method randr.
    (B) Close

then icon disappears again when I click OK

This is the same error that appears when I start redshift from the menu

I also opened synaptic package manager and searched for 'randr' and following packages were returned .....

  • libxcb-randr0   
    libxrandr2   
    x11-xserver-utils
    xserver-xorg-video-nouv

I didn't see a separate package specifically called 'randr'

Then I checked the same packages/versions in my other two partitions Debian and Linux Mint where redshift is working OK, and compared them with Devuan...

                                     Debian            Mint          Devuan         
libxcb-randr0               1.12-1              1.11.1      1.10-3+b1
libxrandr2                    2:1.5.1-1          2:1.5.0-1  2:1.4.2-1+b1
x11-xserver-utils          7.7+7+b           1 7.7+7     7.7+3+b1   
xserver-xorg-video-nouv1:1.0.13-3    1:1.0.12    1:1.0.11-1

I noticed there are slightly older versions for the four packages in Devuan

Also noticed there is a slightly different package name in Devuan for package 'xserver-xorg-video-nouveau'

So I upgraded the four packages to latest versions by re-enabling testing suite 'ascii' in /etc/apt/sources.list.d/devuan-ascii.list

reboot but still redshift no different from before.

not sure what else I can try.  I have this feeling that it might be related to the fact I needed to add nomodeset to linux boot line in grub, since redshift works in both Debian and Mint partitions so the hardware seems to be OK.  And I don't need to have 'nomodeset' in the linux boot line in grub for Debian and Mint partitions.  So maybe that's the problem? Just a wild guess as I'm not too technical with linux yet.

Last edited by hughparker1 (2017-05-17 14:09:16)

Offline

#12 2017-05-17 14:31:36

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

Upgrading those four packages was probably not the right thing to do. I don't know if that will cause problems or not.

There is no randr package. Sorry. But you can run 'xrandr' on the command line to see your display settings. You should be able to change settings with xrandr, too, but maybe it's not working. Run it with no arguments to get the display name (maybe VGA-1, DVI-something, or maybe it's just called 'default').
Then try

xrandr --output <the display name> --brightness 0.7

and see if it decreases the brightness to 70%.

You might be able to use one of the other methods listed. There's a line for it in the config file. Mine says "adjustment-method=randr". You could try replacing randr with the other methods (vidmode, drm or dummy). That's my best guess. I don't really know anything about it.

Last edited by fsmithred (2017-05-17 14:45:12)

Offline

#13 2017-05-17 15:44:32

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

I have this feeling that it might be related to the fact I needed to add nomodeset to linux boot line in grub

Trust the Force, Luke. You are correct.
I just booted with 'nomodeset' and redshift no longer works. Neither does my brightness script that I've been using.

Offline

#14 2017-05-18 14:42:08

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

fsmithred wrote:

I have this feeling that it might be related to the fact I needed to add nomodeset to linux boot line in grub

Trust the Force, Luke. You are correct.
I just booted with 'nomodeset' and redshift no longer works. Neither does my brightness script that I've been using.

Thanks for feedback.  I was wondering if the problem I'm having is something to do with the kernel I am using in Devuan which is a lot older than the other two OS I use on my laptop which I bought just last year ...

  • .......................            Kernel version
    Devuan Xfce               3.16.43-2
    Linux Mint Xfce           4.10.0-20
    Debian Stretch Xfce    4.9.18-1

Would it be worth installing the latest testing kernel on Devuan while I still have ascii in my sources.list?  ( EDIT: then maybe I wouldn't need to add nomodeset to linux boot line)

I had a look at what is currently available....

hugh@DELL-INSP-DEVUAN:~$ apt-cache search linux-image
linux-image-3.16.0-4-amd64 - Linux 3.16 for 64-bit PCs
linux-image-3.16.0-4-amd64-dbg - Debugging symbols for Linux 3.16.0-4-amd64
linux-image-amd64 - Linux for 64-bit PCs (meta-package)
linux-image-amd64-dbg - Debugging symbols for Linux amd64 configuration (meta-package)
linux-image-4.9.0-0.bpo.2-amd64-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-amd64
linux-image-4.9.0-0.bpo.2-amd64-unsigned - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-0.bpo.2-rt-amd64-dbg - Debugging symbols for Linux 4.9.0-0.bpo.2-rt-amd64
linux-image-4.9.0-0.bpo.2-rt-amd64-unsigned - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-2-grsec-amd64 - Linux 4.9 for 64-bit PCs, Grsecurity protection
linux-image-grsec-amd64 - Linux image meta-package, grsec featureset
linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
linux-image-rt-amd64-dbg - Debugging symbols for Linux rt-amd64 configuration (meta-package)
linux-image-4.9.0-0.bpo.2-amd64 - Linux 4.9 for 64-bit PCs (signed)
linux-image-4.9.0-0.bpo.2-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT (signed)
linux-image-4.9.0-2-amd64-unsigned - Linux 4.9 for 64-bit PCs
linux-image-4.9.0-2-rt-amd64-unsigned - Linux 4.9 for 64-bit PCs, PREEMPT_RT
linux-image-4.9.0-2-amd64 - Linux 4.9 for 64-bit PCs (signed)
linux-image-4.9.0-2-rt-amd64 - Linux 4.9 for 64-bit PCs, PREEMPT_RT (signed)
hugh@DELL-INSP-DEVUAN:~$ 

... and I thought Linux 4.9+79 for 64-bit PCs (signed) looks like the latest...

hugh@DELL-INSP-DEVUAN:~$ apt show linux-image-4.9.0-2-amd64
Package: linux-image-4.9.0-2-amd64
Source: linux-signed (4.4)
Version: 4.9.18-1
Installed-Size: 189 MB
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Replaces: linux-image-4.9.0-2-amd64-unsigned
Depends: kmod, linux-base (>= 4.3~), initramfs-tools (>= 0.120+deb8u2) | linux-initramfs-tool
Recommends: firmware-linux-free, irqbalance
Suggests: linux-doc-4.9, debian-kernel-handbook, grub-pc | grub-efi-amd64 | extlinux
Conflicts: linux-image-4.9.0-2-amd64-unsigned
Breaks: initramfs-tools (<< 0.120+deb8u2), xserver-xorg-input-vmmouse (<< 1:13.0.99)
Homepage: https://www.kernel.org/
Built-Using: linux (= 4.9.18-1)
Section: kernel
Priority: optional
Download-Size: 39.1 MB
APT-Sources: http://auto.mirror.devuan.org/merged/ ascii/main amd64 Packages
Description: Linux 4.9 for 64-bit PCs (signed)

hugh@DELL-INSP-DEVUAN:~$ 

Would I just need to run following command to install...

$ sudo apt-get install linux-image-4.9.0-2-amd64

.. or is there more steps required?  I've never upgraded kernel from the terminal before so don't know if there is more to this than a single command.

the other option I suppose is to do full ascii upgrade except I remember what @golinux said the other day....

golinux wrote:

You probably don't want to upgrade to ascii - it is a bit broken atm.  Just enable the ascii repo to get that one package then disable it immediately.  Along the way, there may be unresolved dependencies and installing from different releases always has a risk of 'unintended consequences'.  Depends how adventurous you are and on your tolerance for breaking things.  Of course it may be perfectly fine.  Your choice.

Look at the bottom of this page for source information.

Note that I am very conservative while others think nothing of leaping into the unknown.

So I'm wondering if it's worth a try.  I could just follow the steps I found in this link https://talk.devuan.org/t/upgrading-dev … -ascii/363  do those instructions looks OK?

Since Devuan isn't my daily driver at the moment (especially with no redshift for late evening work) I wonder if a full upgrade would be worth considering.  At the moment I mainly use Debian Stretch and haven't come across any problems since since installing late last year.  That's why I was thinking that Devuan testing might be worth considering. I do realise there is always some risk.  Any advice/guidance would be appreciated.

Last edited by hughparker1 (2017-05-18 14:45:17)

Offline

#15 2017-05-18 15:18:59

golinux
Administrator
Registered: 2016-11-25
Posts: 238

Re: [SOLVED] Redshift fails to start - .service files missing?

hughparker1 wrote:

Would it be worth installing the latest testing kernel on Devuan while I still have ascii in my sources.list?

Disable the ascii repo.  Add the Devuan backports repo and try that kernel first.  I think it's at least 4.9 something.

Offline

#16 2017-05-18 15:23:47

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

Yes, go with backports. Disable ascii. All the devs have been focused on getting jessie ready, and not much work has been done on ascii.

apt-get -t jessie-backports install linux-image-4.9.0-0.bpo.2-amd64

Offline

#17 2017-05-18 20:46:45

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

golinux wrote:
hughparker1 wrote:

Would it be worth installing the latest testing kernel on Devuan while I still have ascii in my sources.list?

Disable the ascii repo.  Add the Devuan backports repo and try that kernel first.  I think it's at least 4.9 something.

fsmithred wrote:

Yes, go with backports. Disable ascii. All the devs have been focused on getting jessie ready, and not much work has been done on ascii.

apt-get -t jessie-backports install linux-image-4.9.0-0.bpo.2-amd64

Thanks @golinux and @fsmithred for advice and continued support

I installed latest kernel ...

$ apt-get -t jessie-backports install linux-image-4.9.0-0.bpo.2-amd64

and now boots to Desktop without 'nomodeset' in linux line.     Success!

Also Redshift is working perfectly now at sunset                Success!

And my Brightness function keys are working now            Success!

Only one small problem, no wi-fi detected which was working before I installed new kernel, very strange.

When I click on Wicd Network Manager is just says 'No wireless network found'

I plugged in a network cable and tried installing the non-free package I normally use for Debian install...

$ sudo apt install firmware-iwlwifi
hugh@DELL-INSP-DEVUAN:~$ sudo apt install firmware-iwlwifi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
firmware-iwlwifi is already the newest version.
The following packages were automatically installed and are no longer required:
  grub-pc-bin libelfg0 libgeoclue0 libnm-glib4 libnm-util2 libuuid-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
hugh@DELL-INSP-DEVUAN:~$ 

... so it looks like it's already installed but it's not working. Has anyone encountered this before?

this is the output for '$ lspci -k'

hugh@DELL-INSP-DEVUAN:~$ lspci -k
00:00.0 Host bridge: Intel Corporation Device 1904 (rev 08)
	Subsystem: Dell Device 06b2
	Kernel driver in use: skl_uncore
00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)
	Subsystem: Dell Device 06b2
	Kernel driver in use: i915
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: xhci_hcd
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: intel_pch_thermal
00:15.0 Signal processing controller: Intel Corporation Device 9d60 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: intel-lpss
00:15.1 Signal processing controller: Intel Corporation Device 9d61 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: intel-lpss
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
	Kernel driver in use: mei_me
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
	Kernel driver in use: pcieport
00:1c.4 PCI bridge: Intel Corporation Device 9d14 (rev f1)
	Kernel driver in use: pcieport
00:1c.5 PCI bridge: Intel Corporation Device 9d15 (rev f1)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
	Subsystem: Dell Device 06b2
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
	Subsystem: Dell Device 06b2
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: snd_hda_intel
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
	Subsystem: Dell Device 06b2
	Kernel driver in use: i801_smbus
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] (rev 81)
	Subsystem: Dell Device 06b2
	Kernel driver in use: radeon
02:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
	Subsystem: Intel Corporation Dual Band Wireless AC 3160
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
	Subsystem: Dell Device 06b2
	Kernel driver in use: r8169
hugh@DELL-INSP-DEVUAN:~$ 

Is there something else I can do to get wi-fi working again?  I checked and wi-fi still works with live USB and on other partitions.

Thanks for all the help received so far, it is much appreciated.  Just one little hurdle to overcome.

Last edited by hughparker1 (2017-05-18 20:48:52)

Offline

#18 2017-05-18 23:16:58

greenjeans
Member
Registered: 2017-04-07
Posts: 78
Website

Re: [SOLVED] Redshift fails to start - .service files missing?

Well i'm not the ninja here obviously, but wondering if maybe you need to run update-initramfs -u?

I would think that would occur as part of the process after installing a new kernel but I could be wrong, thus my suggestion.


http://www.mrgreenjeans.net
http://www.mrgreenjeans.net/vuudo Vuu-do GNU/Linux, minimal Devuan-based openbox and mate systems to build on.
MAKE IT YOUR OWN. wink

Offline

#19 2017-05-19 08:50:53

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

greenjeans wrote:

Well i'm not the ninja here obviously, but wondering if maybe you need to run update-initramfs -u?

I would think that would occur as part of the process after installing a new kernel but I could be wrong, thus my suggestion.

Thanks @greenjeans I didn't know if there was any other step  required as I haven't done kerknel upgrade in terminal before.  I'll try it later today when I get home and let you know how I get on. Cheers.

Offline

#20 2017-05-19 10:40:55

lazlo
Member
From: the Top Left of the Noosphere
Registered: 2017-05-15
Posts: 10

Re: [SOLVED] Redshift fails to start - .service files missing?

@hughparker1  The kernel module for the wifi NIC isn't loading.  The firmware and the kernel module are two separate things that work together and both have to be running. 

No wifi driver is listed in your lspci output:

...
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] (rev 81)
    Subsystem: Dell Device 06b2
    Kernel driver in use: radeon
02:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
    Subsystem: Dell Device 06b2
    Kernel driver in use: r8169
...

So if the update-initramfs -u and a reboot doesn't fix it try this:

sudo modprobe iwlwifi

If that works there will be no output from the command.  If it doesn't work you'll get a an error and can check the kernel logs for more info.

To see what is keeping it from loading (either with modprobe or on boot) check the kernel log for errors:

dmesg | egrep 'error|iwlwifi'

If you want to keep the latest portion of the kernel log updating in another TTY you can use tail:

tail -f /var/log/dmesg

That would allow you execute a command in one TTY and then switch to the one running tail to see what the kernel just logged into dmesg.  That's handy if the grep command is returning information that is not useful for some reason.

If the module loads then check if the WNIC is running with ifconfig:

sudo ifconfig

If needed do:

sudo ifconfig wlan0 up

Once you can see it listed in the output from ifconfig wicd should be able to handle everything else though.

Good luck!


lazlo

Last edited by lazlo (2017-05-19 10:56:40)

Offline

#21 2017-05-19 15:45:23

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

lazlo wrote:

@hughparker1  The kernel module for the wifi NIC isn't loading.  The firmware and the kernel module are two separate things that work together and both have to be running. 

No wifi driver is listed in your lspci output:

...
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M] (rev 81)
    Subsystem: Dell Device 06b2
    Kernel driver in use: radeon
02:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
    Subsystem: Intel Corporation Dual Band Wireless AC 3160
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
    Subsystem: Dell Device 06b2
    Kernel driver in use: r8169
...

So if the update-initramfs -u and a reboot doesn't fix it try this:

sudo modprobe iwlwifi

If that works there will be no output from the command.  If it doesn't work you'll get a an error and can check the kernel logs for more info.

To see what is keeping it from loading (either with modprobe or on boot) check the kernel log for errors:

dmesg | egrep 'error|iwlwifi'

If you want to keep the latest portion of the kernel log updating in another TTY you can use tail:

tail -f /var/log/dmesg

That would allow you execute a command in one TTY and then switch to the one running tail to see what the kernel just logged into dmesg.  That's handy if the grep command is returning information that is not useful for some reason.

If the module loads then check if the WNIC is running with ifconfig:

sudo ifconfig

If needed do:

sudo ifconfig wlan0 up

Once you can see it listed in the output from ifconfig wicd should be able to handle everything else though.

Good luck!

lazlo

Thanks @lazlo for your feedback and suggestions to resolve my problem with wireless network.

I have ran the commands you suggested and the outputs are below...

EDIT2: forgot to include these ...

$ sudo update-initramfs -u

hugh@DELL-INSP-DEVUAN:~$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.9.0-0.bpo.2-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
live-boot: core filesystems devices utils udev wget blockdev.
hugh@DELL-INSP-DEVUAN:~$ 

    REBOOT but still no wi-fi

so run this command...

$ sudo modprobe iwlwifi

hugh@DELL-INSP-DEVUAN:~$ sudo modprobe iwlwifi
[sudo] password for hugh: 
hugh@DELL-INSP-DEVUAN:~$ 

    no output but also no error messages

    no wi-fi yet so REBOOT but still no wi-fi

first terminal window........

hugh@DELL-INSP-DEVUAN:~$ sudo dmesg | egrep 'error|iwlwifi'
[sudo] password for hugh: 
[    2.364163] tpm_crb: probe of MSFT0101:00 failed with error -16
[    2.539868] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    2.542515] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[    2.547727] iwlwifi 0000:02:00.0: firmware: failed to load iwlwifi-3160-17.ucode (-2)
[    2.547731] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3160-17.ucode failed with error -2
[    2.633304] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_pfp.bin failed with error -2
[    2.633823] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_me.bin failed with error -2
[    2.635139] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_ce.bin failed with error -2
[    2.635350] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_rlc.bin failed with error -2
[    2.635565] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_mc.bin failed with error -2
[    2.636201] radeon 0000:01:00.0: Direct firmware load for radeon/hainan_k_smc.bin failed with error -2
[    2.683163] bluetooth hci0: Direct firmware load for intel/ibt-hw-37.7.10-fw-1.0.1.2d.d.bseq failed with error -2
hugh@DELL-INSP-DEVUAN:~$ 

second terminal window....

hugh@DELL-INSP-DEVUAN:~$ sudo tail -f /var/log/dmesg
[sudo] password for hugh: 
[    4.288739] lp: driver loaded but no devices found
[    4.292337] ppdev: user-space parallel port driver
[    4.301771] fuse init (API version 7.26)
[    4.675720] RPC: Registered named UNIX socket transport module.
[    4.675721] RPC: Registered udp transport module.
[    4.675722] RPC: Registered tcp transport module.
[    4.675722] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    4.678942] FS-Cache: Loaded
[    4.687961] FS-Cache: Netfs 'nfs' registered for caching
[    4.697357] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).

first terminal window........

hugh@DELL-INSP-DEVUAN:~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 84:7b:eb:13:91:2f  
          inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::867b:ebff:fe13:912f/64 Scope:Link
          inet6 addr: fd58:1f28:a661:b500:867b:ebff:fe13:912f/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16677 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1531 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1871547 (1.7 MiB)  TX bytes:167785 (163.8 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:33 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:3466 (3.3 KiB)  TX bytes:3466 (3.3 KiB)

hugh@DELL-INSP-DEVUAN:~$ 

first terminal window........

hugh@DELL-INSP-DEVUAN:~$ sudo ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
hugh@DELL-INSP-DEVUAN:~$ 

Note: no change in second terminal window after the additional commands were run in the first terminal

Wicd Network Manager still says "No wireless networks found"

To be honest I don't know enough about linux to be able to examine the output and diagnose what the problem is so any advice on what I can do would be appreciated. Thanks again for the continued support, very much appreciated.

EDIT:  would it help if i uninstalled and then reinstalled "firmware-iwlwifi"

Last edited by hughparker1 (2017-05-19 15:59:30)

Offline

#22 2017-05-19 20:33:26

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: [SOLVED] Redshift fails to start - .service files missing?

Maybe you need to install the firmware from backports.

apt-get -t jessie-backports install firmware-iwlwifi

Offline

#23 2017-05-19 22:56:57

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 21

Re: [SOLVED] Redshift fails to start - .service files missing?

fsmithred wrote:

Maybe you need to install the firmware from backports.

apt-get -t jessie-backports install firmware-iwlwifi

Thanks @fsmithred for your help, guess what, it worked! That was a good call, thank you for your recommendation.  Now I can set this topic to resolved.

I have learned a lot over this over the past 4 days , it looks like when you add backports to your sources.list, you have to explicitly install each package from backports using "apt-get -t jessie-backports install package_name" which allows you to control which distribution or release the packages will be retrieved from.  I guess it makes sense otherwise you might make you system unstable if you got everything upgraded when you run the usual "apt-get update/upgrade" command, therefore it looks to me that you are in control?

Also learned how to check wireless drivers.  But I think I have a lot more still to learn.  Thank you to @fsmithred, @lazlo, @golinux and @greenjeans for your excellent instructions and feedback.

Offline

Board footer