The officially official Devuan Forum!

You are not logged in.

#1 2021-06-10 13:17:15

VH
Member
Registered: 2018-07-31
Posts: 16  

At the shut down menu screen I choose shut down, but it reboots.

Hello,

I am using Beowulf on a chromebook with Xfce desktop environment. 

I set the Power Manager option so that when the power button is pressed it would ask me what to do - that is shut down menu will show up.  Then I click on the 'shut down' button.   

When I installed this a few days ago, it was shutting down just fine.  However, since a couple of days ago, when I choose 'shut down' it would reboot instead of shutting down. 

I did not do anything weird in between those periods.  What I did was change the Window Manager theme from 'Clearlook-Phenix-Cinnabar' to 'Default-hdpi,' then I changed to 'Default'  I mention this because this funny rebooting thing started to happen right after I changed the theme. 

Also, before that I installed some packages and also removed a few (I removed mostly multimedia related packages plus xarchiver).  I also changed desktop background several times. 

Anybody has any ideas? 

Thanks in advance. 

VH

Last edited by VH (Yesterday 12:55:12)

Offline

#2 2021-06-10 17:50:31

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,617  
Website

Re: At the shut down menu screen I choose shut down, but it reboots.

Can we see

apt policy

Black Lives Matter

Offline

#3 2021-06-12 00:20:54

VH
Member
Registered: 2018-07-31
Posts: 16  

Re: At the shut down menu screen I choose shut down, but it reboots.

Sorry for the late reply.  Here it is.

hello@InternetMachine:~$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 [url]http://us.deb.devuan.org/merged[/url] ascii-updates/main amd64 Packages
     release v=2.0.0,o=Devuan,a=oldstable-updates,n=ascii-updates,l=Devuan,c=main,b=amd64
     origin us.deb.devuan.org
 500 [url]http://us.deb.devuan.org/merged[/url] ascii-security/main amd64 Packages
     release v=2.0,o=Devuan,a=oldstable-security,n=ascii-security,l=Devuan-Security,c=main,b=amd64
     origin us.deb.devuan.org
 500 [url]http://us.deb.devuan.org/merged[/url] ascii/main amd64 Packages
     release v=2.1,o=Devuan,a=oldstable,n=ascii,l=Devuan,c=main,b=amd64
     origin us.deb.devuan.org
Pinned packages:

Last edited by VH (2021-06-12 00:25:23)

Offline

#4 2021-06-12 00:28:36

golinux
Administrator
Registered: 2016-11-25
Posts: 2,217  

Re: At the shut down menu screen I choose shut down, but it reboots.

Country Codes are deprecated and don't work properly.  Use http://deb.devuan.org instead.  That should fix it.

Offline

#5 2021-06-12 00:38:33

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 561  

Re: At the shut down menu screen I choose shut down, but it reboots.

There's a little bit of mismatch between:

VH wrote:

I am using Beowulf on a chromebook with Xfce desktop environment.

and:

VH wrote:
 500 [url]http://us.deb.devuan.org/merged[/url] ascii-updates/main amd64 Packages
     release v=2.0.0,o=Devuan,a=oldstable-updates,n=ascii-updates,l=Devuan,c=main,b=amd64
     origin us.deb.devuan.org
 500 [url]http://us.deb.devuan.org/merged[/url] ascii-security/main amd64 Packages
     release v=2.0,o=Devuan,a=oldstable-security,n=ascii-security,l=Devuan-Security,c=main,b=amd64
     origin us.deb.devuan.org
 500 [url]http://us.deb.devuan.org/merged[/url] ascii/main amd64 Packages
     release v=2.1,o=Devuan,a=oldstable,n=ascii,l=Devuan,c=main,b=amd64
     origin us.deb.devuan.org

Perhaps it's worth to deal with that first, and then see if the problem remains.

Offline

#6 2021-06-12 00:53:34

golinux
Administrator
Registered: 2016-11-25
Posts: 2,217  

Re: At the shut down menu screen I choose shut down, but it reboots.

Hahaha!  So much for my reading skills.  I'll go stand in a corner now . . .

Offline

#7 2021-06-12 08:33:46

Dutch_Master
Member
Registered: 2018-05-31
Posts: 192  

Re: At the shut down menu screen I choose shut down, but it reboots.

golinux wrote:

I'll go stand in a corner now . . .

I've burned the dunce hat so you can't have it tongue

Anyway, for the OP: post the contents of the file

/etc/apt/sources.list

Another wise thing to do:

su #type root password and press enter
#if your system uses sudo, use this command instead: sudo su
apt-get update && apt-get dist-upgrade && reboot

This updates your entire system and may take some time. It should also deal with any policy issues mentioned before. Notice the word should, I've never used this policy stuff before.

Offline

#8 2021-06-12 08:48:01

dice
Member
Registered: 2020-11-22
Posts: 518  
Website

Re: At the shut down menu screen I choose shut down, but it reboots.

Dutch_Master wrote:
golinux wrote:

I'll go stand in a corner now . . .

I've burned the dunce hat so you can't have it tongue

Anyway, for the OP: post the contents of the file

/etc/apt/sources.list

Another wise thing to do:

su #type root password and press enter
#if your system uses sudo, use this command instead: sudo su
apt-get update && apt-get dist-upgrade && reboot

This updates your entire system and may take some time. It should also deal with any policy issues mentioned before. Notice the word should, I've never used this policy stuff before.

or do a one liner as user.

su -c "apt-get update && apt-get dist-upgrade && reboot"

Last edited by dice (2021-06-12 08:48:14)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life
"everything is magnetized" - kmart employee
"you just opened pandora's shitbox ray" - jim lahey

Offline

#9 2021-06-12 22:30:09

VH
Member
Registered: 2018-07-31
Posts: 16  

Re: At the shut down menu screen I choose shut down, but it reboots.

How stupid of me.  I posted "apt policy" of the wrong machine.  Many apologies. 

Below is the apt policy of the machine I am having the problem. 

reader@ReaderMachine:~$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.devuan.org/merged beowulf-updates/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Pinned packages:

Below is etc/apt/sources.list

reader@ReaderMachine:/etc/apt$ cat sources.list
# 

# deb cdrom:[Devuan GNU/Linux 3.1 beowulf amd64 - desktop 20210315]/ beowulf contrib main non-free

# deb cdrom:[Devuan GNU/Linux 3.1 beowulf amd64 - desktop 20210315]/ beowulf contrib main non-free

deb http://deb.devuan.org/merged beowulf main
deb-src http://deb.devuan.org/merged beowulf main

deb http://deb.devuan.org/merged beowulf-security main
deb-src http://deb.devuan.org/merged beowulf-security main

# beowulf-updates, previously known as 'volatile'
deb http://deb.devuan.org/merged beowulf-updates main
deb-src http://deb.devuan.org/merged beowulf-updates main

Last edited by VH (2021-06-12 22:34:54)

Offline

#10 2021-06-13 15:51:12

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,617  
Website

Re: At the shut down menu screen I choose shut down, but it reboots.

Does the acpi=force kernel parameter help?


Black Lives Matter

Offline

#11 2021-06-13 17:45:38

Camtaf
Member
Registered: 2019-11-19
Posts: 93  

Re: At the shut down menu screen I choose shut down, but it reboots.

I did not do anything weird in between those period.  What I did was change the Window Manager theme from 'Clearlook-Phenix-Cinnabar' to 'Default-hdpi,' then I changed to 'Default'  I mention this because this funny rebooting thing started to happen right after I changed the theme.

Perhaps when you changed to 'Default' it also changed back whatever you set to its default values - did you try resetting what you wanted again(?).

I know from personal experience, with another distro, that changing WMs would reset everything to their default values, even though I'd only just switched - used to annoy me no end. wink

Last edited by Camtaf (2021-06-13 17:46:39)

Offline

#12 Yesterday 12:54:02

VH
Member
Registered: 2018-07-31
Posts: 16  

Re: At the shut down menu screen I choose shut down, but it reboots.

Hello,

Sorry for the late response. 

I tried

su -c "apt-get update && apt-get dist-upgrade && reboot"

but didn't work.

I also tried

acpi=force

and did not work either.

Camtaf,

Perhaps when you changed to 'Default' it also changed back whatever you set to its default values - did you try resetting what you wanted again(?).

I just cannot understand that - especially the bold and underlined text part.  Could you elaborate on that please?

Thanks for all the help.

Last edited by VH (Yesterday 12:54:26)

Offline

#13 Yesterday 14:48:54

Camtaf
Member
Registered: 2019-11-19
Posts: 93  

Re: At the shut down menu screen I choose shut down, but it reboots.

Sometimes, when you change a setting, all your options get removed, so when you return, you may have lost your options that you had previously set, that's why I asked whether you reset them when you returned to the previous WM theme.

(It was just a thought.)

Offline

#14 Yesterday 15:29:01

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,864  

Re: At the shut down menu screen I choose shut down, but it reboots.

Re-check your power manager settings as Camtaf suggested.

Look in /var/log/apt/history.log to see what packages you removed. (Let us see, too.)

FWIW, I tried your settings and theme choices, and it had no effect on shutdown. I'm guessing you removed something that you need.

Offline

Board footer