The officially official Devuan Forum!

You are not logged in.

#1 2018-04-13 08:08:05

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

National characters troubles

Hello, thank you all for ASCII Beta.

I'm reposting https://dev1galaxy.org/viewtopic.php?pid=8312#p8312 after recommendation.

Unfortunately, after upgrading from Devuan Jessie to ASCII Beta, I can't save adobe flash player archive file into directory which name consists of russian national character:

The file could not be saved because you do not have the proper permissions.  Choose another save directory.

I'm using Firefox ESR, Palemon, LXDE, LXDM (US language selected).
Kernel boot parameter:

locales=ru_RU.UTF-8 keyboard-layouts=ru

ls command in LXTerminal, XTerm, rxvt-unicode can't display these national character of that folder name but shows that I should have  proper permission.

Does anyone know please how to fix it ?

Offline

#2 2018-04-13 09:49:08

Geoff 42
Member
Registered: 2016-12-15
Posts: 177  

Re: National characters troubles

This is not a problem with fonts, is it? When I upgraded my desk top from Jessie to Ascii, it stopped displaying Chinese characters, although it would still display Hindi, Thai, Arabic and Cyrillic. My laptop on Ascii displays Chinese, but not Hindi and Thai. The problem was a missing font on my desktop. After installing fonts-arphic-ukai the Chinese came back. I still need to check the fonts on my laptop. I have not yet checked which fonts were removed in the upgrade.

Cyrillic is displayed in Pale Moon and if I run Lynx in rxvt-unicode. I have not tried filenames.

Geoff

Offline

#3 2018-04-13 10:05:23

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

Re: National characters troubles

Geoff 42 wrote:

This is not a problem with fonts, is it? When I upgraded my desk top from Jessie to Ascii, it stopped displaying Chinese characters, although it would still display Hindi, Thai, Arabic and Cyrillic. My laptop on Ascii displays Chinese, but not Hindi and Thai. The problem was a missing font on my desktop. After installing fonts-arphic-ukai the Chinese came back. I still need to check the fonts on my laptop. I have not yet checked which fonts were removed in the upgrade.

Cyrillic is displayed in Pale Moon and if I run Lynx in rxvt-unicode. I have not tried filenames.

Geoff

I can see Cyrillic in Pale Moon, Firefox, in file names in PCManFM, not in terminals.

Offline

#4 2018-04-13 13:10:07

fsmithred
Administrator
Registered: 2016-11-25
Posts: 754  

Re: National characters troubles

Is this what you want?
https://transfer.sh/FgcX7/ru.png

dpkg-reconfigure locales

checked ru_RU.UTF-8, selected en_US.UTF-8 as default locale.
Rebooted and added 'locales=ru_RU.UTF-8 keyboard-layouts=ru' to the linux line of the boot command, but this did not work. (It does work in a live iso). Rebooted again and tried another language to confirm. It still didn't work.

What did work:
On login with lxdm, selected Russian in language and keyboard boxes.
I'm using openbox, lxpanel, lxterminal, leafpad and spacefm. I opened a few other programs randomly (I can't read anything here) and I see Russian. Even xarchiver, which for some reason is in English in the apps menu, has Russian in the menu bar.

Offline

#5 2018-04-14 10:26:31

Geoff 42
Member
Registered: 2016-12-15
Posts: 177  

Re: National characters troubles

While the actual problem might not be the fonts, I did look at which fonts might be used for different scripts. Using Pale Moon and its Inspector to list the fonts used, I found that the following scripts used the fonts mentioned :-

Arabic     DejaVu Sans
Cyrillic    DejaVu Serif
Chinese (S&T)   Droid Sans Fallback
Hindi       FreeSans
Korean    Un Dotum (fonts-unfonts-core)
Thai        Noto Sans Thai

This was for a page that did not specify which font to use.
I see that following the Jessie-Ascii upgrade the following fonts were removed by apt-get autoremove :-

Removing fonts-droid (1:4.4.4r2-6) ...
Removing fonts-lyx (2.2.2-1) ...
Removing fonts-roboto (2:0~20160106-2) ...
Removing xfonts-mathml (6) ...

Geoff

(edit: added Korean)

Last edited by Geoff 42 (2018-04-17 14:48:11)

Offline

#6 2018-04-16 14:19:50

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

Re: National characters troubles

fsmithred wrote:

Is this what you want?
https://transfer.sh/FgcX7/ru.png

dpkg-reconfigure locales

checked ru_RU.UTF-8, selected en_US.UTF-8 as default locale.
Rebooted and added 'locales=ru_RU.UTF-8 keyboard-layouts=ru' to the linux line of the boot command, but this did not work. (It does work in a live iso). Rebooted again and tried another language to confirm. It still didn't work.

What did work:
On login with lxdm, selected Russian in language and keyboard boxes.
I'm using openbox, lxpanel, lxterminal, leafpad and spacefm. I opened a few other programs randomly (I can't read anything here) and I see Russian. Even xarchiver, which for some reason is in English in the apps menu, has Russian in the menu bar.

Hello,

I wanted something else, but your result could be correlated to my result.

I tried what you've done and it's not working on my Devuan like on your Devuan, almost nothing was in russian language.

Another problem has appeared:

# unattended-upgrade -v
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 29-34: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1209, in main
    " ".join(blacklisted_pkgs))
Message: '\u041f\u0430\u043a\u0435\u0442\u044b \u0432 \u0447\u0451\u0440\u043d\u043e\u043c \u0441\u043f\u0438\u0441\u043a\u0435 \u0438\u0437\u043d\u0430\u0447\u0430\u043b\u044c\u043d\u043e: %s'
Arguments: ('',)
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1209, in main
    " ".join(blacklisted_pkgs))
Message: '\u041f\u0430\u043a\u0435\u0442\u044b \u0432 \u0447\u0451\u0440\u043d\u043e\u043c \u0441\u043f\u0438\u0441\u043a\u0435 \u0438\u0437\u043d\u0430\u0447\u0430\u043b\u044c\u043d\u043e: %s'
Arguments: ('',)
Initial whitelisted packages: 
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 29-39: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1216, in main
    logging.info(_("Starting unattended upgrades script"))
Message: '\u0417\u0430\u043f\u0443\u0441\u043a\u0430\u044e\u0442\u0441\u044f \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0438 \u043d\u0435\u043e\u0431\u0441\u043b\u0443\u0436\u0438\u0432\u0430\u0435\u043c\u043e\u0439 \u0443\u0441\u0442\u0430\u043d\u043e\u0432\u043a\u0438'
Arguments: ()
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-10: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1216, in main
    logging.info(_("Starting unattended upgrades script"))
Message: '\u0417\u0430\u043f\u0443\u0441\u043a\u0430\u044e\u0442\u0441\u044f \u0441\u0446\u0435\u043d\u0430\u0440\u0438\u0438 \u043d\u0435\u043e\u0431\u0441\u043b\u0443\u0436\u0438\u0432\u0430\u0435\u043c\u043e\u0439 \u0443\u0441\u0442\u0430\u043d\u043e\u0432\u043a\u0438'
Arguments: ()
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 29-39: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1219, in main
    logging.info(_("Allowed origins are: %s"), allowed_origins)
Message: '\u0420\u0430\u0437\u0440\u0435\u0448\u0451\u043d\u043d\u044b\u0435 \u0438\u0441\u0442\u043e\u0447\u043d\u0438\u043a\u0438: %s'
Arguments: (['a=*-security'],)
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-10: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1219, in main
    logging.info(_("Allowed origins are: %s"), allowed_origins)
Message: '\u0420\u0430\u0437\u0440\u0435\u0448\u0451\u043d\u043d\u044b\u0435 \u0438\u0441\u0442\u043e\u0447\u043d\u0438\u043a\u0438: %s'
Arguments: (['a=*-security'],)
Packages that will be upgraded: libperl5.24 perl perl-base perl-modules-5.24
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 29-34: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1442, in main
    logfile_dpkg)
  File "/usr/bin/unattended-upgrade", line 879, in do_install
    logging.info(_("Writing dpkg log to '%s'"), logfile_dpkg)
Message: '\u0416\u0443\u0440\u043d\u0430\u043b dpkg \u0437\u0430\u043f\u0438\u0441\u044b\u0432\u0430\u0435\u0442\u0441\u044f \u0432 %s'
Arguments: ('/var/log/unattended-upgrades/unattended-upgrades-dpkg.log',)
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 983, in emit
    stream.write(msg)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
Call stack:
  File "/usr/bin/unattended-upgrade", line 1538, in <module>
    main(options)
  File "/usr/bin/unattended-upgrade", line 1442, in main
    logfile_dpkg)
  File "/usr/bin/unattended-upgrade", line 879, in do_install
    logging.info(_("Writing dpkg log to '%s'"), logfile_dpkg)
Message: '\u0416\u0443\u0440\u043d\u0430\u043b dpkg \u0437\u0430\u043f\u0438\u0441\u044b\u0432\u0430\u0435\u0442\u0441\u044f \u0432 %s'
Arguments: ('/var/log/unattended-upgrades/unattended-upgrades-dpkg.log',)
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 243, in <module>
    main(config)
  File "/usr/bin/apt-listchanges", line 106, in main
    frontend.update_progress()
  File "/usr/share/apt-listchanges/apt_listchanges.py", line 300, in update_progress
    ALCLog.info(_("Reading changelogs") + "...")
  File "/usr/share/apt-listchanges/ALCLog.py", line 36, in info
    print(_("apt-listchanges: %(msg)s") % {'msg': msg}, file=sys.stdout);
UnicodeEncodeError: 'ascii' codec can't encode characters in position 17-22: ordinal not in range(128)
Exception: 'ascii' codec can't encode characters in position 0-2: ordinal not in range(128)

Offline

#7 2018-04-18 16:35:57

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

Re: National characters troubles

Does anyone know please why there is high number of packages offered to autoremove ?

# apt-get -Vu upgrade && apt-get -Vu dist-upgradeReading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
   libpolkit-agent-1-0 (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   libpolkit-backend-1-0-elogind (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   libpolkit-gobject-1-0-elogind (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   policykit-1 (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
   espeak-ng-data (1.49.0+dfsg-11)
   evince-gtk (3.22.1-3+deb9u1)
   exfalso (3.7.1-2)
   fonts-font-awesome (4.7.0~dfsg-1)
   fonts-freefont-ttf (20120503-6)
   gir1.2-atspi-2.0 (2.22.0-6+deb9u1)
   gir1.2-gst-plugins-base-1.0 (1.10.4-1)
   gir1.2-gstreamer-1.0 (1.10.4-1)
   gir1.2-gtksource-3.0 (3.22.2-1)
   gir1.2-javascriptcoregtk-4.0 (2.18.6-1~deb9u1)
   gir1.2-keybinder-3.0 (0.3.1-1)
   gir1.2-soup-2.4 (2.56.0-2+deb9u1)
   gir1.2-webkit2-4.0 (2.18.6-1~deb9u1)
   gir1.2-wnck-3.0 (3.20.1-3)
   gnome-orca (3.22.2-3)
   gstreamer1.0-plugins-ugly (1.10.4-1)
   hyphen-en-us (2.8.8-5)
   libao-common (1.2.2-1)
   libao4 (1.2.2-1)
   libatk-adaptor (2.22.0-2)
   libbluetooth3 (5.43-2+deb9u1)
   libbrlapi0.6 (5.4-7)
   libdotconf0 (1.3-0.2)
   libespeak-ng1 (1.49.0+dfsg-11)
   libgles1-mesa (13.0.6-1+b2)
   libgles2-mesa (13.0.6-1+b2)
   libgpod-common (0.8.3-8.2)
   libgpod4 (0.8.3-8.2)
   libgtksourceview-3.0-1 (3.22.2-1)
   libgtksourceview-3.0-common (3.22.2-1)
   libjavascriptcoregtk-4.0-18 (2.18.6-1~deb9u1)
   libjs-modernizr (2.6.2+ds1-1)
   libjs-sphinxdoc (1.4.9-2)
   libjs-underscore (1.8.3~dfsg-1)
   libopencore-amrnb0 (0.1.3-2.1+b2)
   libopencore-amrwb0 (0.1.3-2.1+b2)
   libpcaudio0 (1.0-1)
   libqt5x11extras5 (5.7.1~20161021-2)
   libreoffice (1:5.2.7-1+deb9u3)
   libreoffice-help-en-us (1:5.2.7-1+deb9u3)
   libsgutils2-2 (1.42-2)
   libsidplay1v5 (1.36.59-10)
   libsonic0 (0.2.0-4+b1)
   libspeechd2 (0.8.6-4+deb9u1)
   libtidy-0.99-0 (20091223cvs-1.4+deb8u1)
   libwebkit2gtk-4.0-37 (2.18.6-1~deb9u1)
   libwnck-3-0 (3.20.1-3)
   libwnck-3-common (3.20.1-3)
   libxcb-xv0 (1.12-1)
   lxsession-data (0.5.3-2)
   media-player-info (22-3)
   mythes-en-us (1:5.2.5-1)
   python-feedparser (5.1.3-3)
   python-glade2 (2.24.0-5.1)
   python-gobject (3.22.0-2)
   python-libxml2 (2.9.4+dfsg1-2.2+deb9u2)
   python-musicbrainzngs (0.6-2)
   python-mutagen (1.36-1)
   python-notify (0.1.1-4)
   python-pyinotify (0.9.6-1)
   python-six (1.10.0-3)
   python-utidylib (0.3-1)
   python-wicd (1.7.4+tb2-4+devuan1)
   python3-brlapi (5.4-7)
   python3-louis (3.0.0-3+deb9u1)
   python3-pyatspi (2.20.3+dfsg-1)
   python3-speechd (0.8.6-4+deb9u1)
   python3-xdg (0.25-4)
   quodlibet (3.7.1-2)
   rfkill (0.5-1+b1)
   speech-dispatcher (0.8.6-4+deb9u1)
   speech-dispatcher-audio-plugins (0.8.6-4+deb9u1)
   speech-dispatcher-espeak-ng (0.8.6-4+deb9u1)
   sphinx-rtd-theme-common (0.1.9-1)
   vlc (2.2.7-1~deb9u1)
   vlc-l10n (2.2.7-1~deb9u1)
   vlc-plugin-notify (2.2.7-1~deb9u1)
   vlc-plugin-qt (2.2.7-1~deb9u1)
   vlc-plugin-samba (2.2.7-1~deb9u1)
   vlc-plugin-skins2 (2.2.7-1~deb9u1)
   vlc-plugin-video-output (2.2.7-1~deb9u1)
   vlc-plugin-video-splitter (2.2.7-1~deb9u1)
   vlc-plugin-visualization (2.2.7-1~deb9u1)
   wicd (1.7.4+tb2-4+devuan1)
   wicd-daemon (1.7.4+tb2-4+devuan1)
   wicd-gtk (1.7.4+tb2-4+devuan1)
   xbrlapi (5.4-7)
   xsane (0.999-5)
   xsane-common (0.999-5)
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
   consolekit (0.4.6-6)
   libpam-ck-connector (0.4.6-6)
   lxde-core (9)
   lxsession (0.5.3-2)
   lxsession-default-apps (0.5.3-2)
   lxsession-logout (0.5.3-2)
   openbox-lxde-session (0.99.2-3)
   slim (1.3.6-5.1+devuan2)
   task-xfce-desktop (3.39+devuan1.7)
The following NEW packages will be installed:
   libpolkit-backend-1-0 (0.105-18+devuan2.9)
   libpolkit-backend-elogind-1-0 (0.105-18+devuan2.9)
   libpolkit-gobject-1-0 (0.105-18+devuan2.9)
   libpolkit-gobject-elogind-1-0 (0.105-18+devuan2.9)
The following packages will be upgraded:
   libpolkit-agent-1-0 (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   libpolkit-backend-1-0-elogind (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   libpolkit-gobject-1-0-elogind (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
   policykit-1 (0.105-18+devuan2.4 => 0.105-18+devuan2.9)
4 upgraded, 4 newly installed, 9 to remove and 0 not upgraded.
Need to get 206 kB of archives.
After this operation, 2085 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://pkgmaster.devuan.org/merged ascii/main amd64 policykit-1 amd64 0.105-18+devuan2.9 [60.3 kB]
Get:2 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-backend-1-0-elogind all 0.105-18+devuan2.9 [10.1 kB]
Get:3 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-agent-1-0 amd64 0.105-18+devuan2.9 [22.6 kB]
Get:4 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-gobject-1-0-elogind all 0.105-18+devuan2.9 [10.1 kB]
Get:5 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-gobject-elogind-1-0 amd64 0.105-18+devuan2.9 [40.0 kB]
Get:6 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-gobject-1-0 all 0.105-18+devuan2.9 [10.1 kB]
Get:7 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-backend-elogind-1-0 amd64 0.105-18+devuan2.9 [42.4 kB]
Get:8 http://pkgmaster.devuan.org/merged ascii/main amd64 libpolkit-backend-1-0 all 0.105-18+devuan2.9 [10.2 kB]
Fetched 206 kB in 0s (598 kB/s)               
Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 243, in <module>
    main(config)
  File "/usr/bin/apt-listchanges", line 106, in main
    frontend.update_progress()
  File "/usr/share/apt-listchanges/apt_listchanges.py", line 327, in update_progress
    sys.stdout.write(line + '\r')
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-5: ordinal not in range(128)
(Reading database ... 234291 files and directories currently installed.)
Removing task-xfce-desktop (3.39+devuan1.7) ...
Removing slim (1.3.6-5.1+devuan2) ...
update-alternatives: warning: alternative /usr/share/slim/themes/default (part of link group desktop-slim-theme) doesn't exist; removing from list of alternatives
Removing lxde-core (9) ...
Removing openbox-lxde-session (0.99.2-3) ...
Removing libpam-ck-connector:amd64 (0.4.6-6) ...
Removing lxsession-default-apps (0.5.3-2) ...
Removing lxsession (0.5.3-2) ...
Removing lxsession-logout (0.5.3-2) ...
Removing consolekit (0.4.6-6) ...
(Reading database ... 234170 files and directories currently installed.)
Preparing to unpack .../0-policykit-1_0.105-18+devuan2.9_amd64.deb ...
Unpacking policykit-1 (0.105-18+devuan2.9) over (0.105-18+devuan2.4) ...
Preparing to unpack .../1-libpolkit-backend-1-0-elogind_0.105-18+devuan2.9_all.deb ...
Unpacking libpolkit-backend-1-0-elogind (0.105-18+devuan2.9) over (0.105-18+devuan2.4) ...
Preparing to unpack .../2-libpolkit-agent-1-0_0.105-18+devuan2.9_amd64.deb ...
Unpacking libpolkit-agent-1-0:amd64 (0.105-18+devuan2.9) over (0.105-18+devuan2.4) ...
Preparing to unpack .../3-libpolkit-gobject-1-0-elogind_0.105-18+devuan2.9_all.deb ...
Unpacking libpolkit-gobject-1-0-elogind (0.105-18+devuan2.9) over (0.105-18+devuan2.4) ...
Selecting previously unselected package libpolkit-gobject-elogind-1-0:amd64.
Preparing to unpack .../4-libpolkit-gobject-elogind-1-0_0.105-18+devuan2.9_amd64.deb ...
Unpacking libpolkit-gobject-elogind-1-0:amd64 (0.105-18+devuan2.9) ...
Selecting previously unselected package libpolkit-gobject-1-0.
Preparing to unpack .../5-libpolkit-gobject-1-0_0.105-18+devuan2.9_all.deb ...
Unpacking libpolkit-gobject-1-0 (0.105-18+devuan2.9) ...
Selecting previously unselected package libpolkit-backend-elogind-1-0:amd64.
Preparing to unpack .../6-libpolkit-backend-elogind-1-0_0.105-18+devuan2.9_amd64.deb ...
Unpacking libpolkit-backend-elogind-1-0:amd64 (0.105-18+devuan2.9) ...
Selecting previously unselected package libpolkit-backend-1-0.
Preparing to unpack .../7-libpolkit-backend-1-0_0.105-18+devuan2.9_all.deb ...
Unpacking libpolkit-backend-1-0 (0.105-18+devuan2.9) ...
Setting up libpolkit-gobject-elogind-1-0:amd64 (0.105-18+devuan2.9) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Setting up libpolkit-gobject-1-0-elogind (0.105-18+devuan2.9) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for dbus (1.10.22-1+devuan1) ...
Setting up libpolkit-gobject-1-0 (0.105-18+devuan2.9) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-18+devuan2.9) ...
Setting up libpolkit-backend-elogind-1-0:amd64 (0.105-18+devuan2.9) ...
Setting up libpolkit-backend-1-0 (0.105-18+devuan2.9) ...
Setting up libpolkit-backend-1-0-elogind (0.105-18+devuan2.9) ...
Setting up policykit-1 (0.105-18+devuan2.9) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...

Offline

#8 2018-04-18 17:09:06

golinux
Administrator
Registered: 2016-11-25
Posts: 1,098  

Re: National characters troubles

The *kit backends are not fully sorted in ascii. This post should point you in the right direction:
https://dev1galaxy.org/viewtopic.php?pid=8217#p8217

Offline

#9 2018-04-18 17:13:06

fsmithred
Administrator
Registered: 2016-11-25
Posts: 754  

Re: National characters troubles

That list of packages for autoremoval looks like stuff that came in with whatever task-*-desktop package was installed in your system. And I stress the "was" part of that. Past tense. Reinstall the one that's appropriate for your desktop environment. Did you remove something recently?

Now that I think about it, unattended upgrades on a testing system might not be the best choice.

Offline

#10 2018-04-19 08:10:27

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

Re: National characters troubles

golinux wrote:

The *kit backends are not fully sorted in ascii. This post should point you in the right direction:
https://dev1galaxy.org/viewtopic.php?pid=8217#p8217

Thank you, it has solved the problem.

Offline

#11 2018-04-19 08:15:18

boycottsystemd
Member
Registered: 2017-09-25
Posts: 42  

Re: National characters troubles

fsmithred wrote:

That list of packages for autoremoval looks like stuff that came in with whatever task-*-desktop package was installed in your system. And I stress the "was" part of that. Past tense. Reinstall the one that's appropriate for your desktop environment. Did you remove something recently?

Now that I think about it, unattended upgrades on a testing system might not be the best choice.

I've removed pulseaudio, mplayer.

Thank you, I will not use unattended upgrades in Beta. (Aim was to use security updates only)

Offline

Board footer