The officially official Devuan Forum!

You are not logged in.

#126 2024-01-05 02:57:41

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

aitor wrote:

Fixed in vdev-1.3.1. I've updated the images.

Wow, lightspeed fix!  🚀

Offline

#127 2024-01-06 02:21:56

zapper
Member
Registered: 2017-05-29
Posts: 861  

Re: GNUinOS - Libre

Btw, if you do have arm64 images for installing on a rockpro64, can you tell me what you recommend for installing it correctly?

Instructions another words. I read their website, but wasn't all too clear. Although, its possible I missed the 30MB unused partition part and thats why it failed lol.

Tried with devuan tho.

Last edited by zapper (2024-01-06 02:22:09)


Freedom is never more than one generation away from extinction. Feelings are not facts
If you wish to be humbled, try to exalt yourself long term  If you wish to be exalted, try to humble yourself long term
Favourite operating systems: Hyperbola Devuan OpenBSD
Peace Be With us All!

Offline

#128 2024-03-07 21:42:52

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

I have been trying to boot from the JWM iso, but am getting a flashing screen with umpteen lines of this error message:

fail: dbus: unable to change to service directory: file does not exist

EDIT: no luck with the plasma-sysvinit iso either. I am getting error messages about glamor not getting enough instructions (64 vs. 128), so this is probably hardware related. I may try the xfce-sysvinit iso and see how that goes.

EDIT: the xfce-sysvinit live iso is running great, difficult to tell the difference with the installed xfce-runit system.

Last edited by prospero (2024-03-09 10:18:31)

Offline

#129 2024-03-09 21:37:30

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

prospero wrote:

I have been trying to boot from the JWM iso, but am getting a flashing screen with umpteen lines of this error message:

fail: dbus: unable to change to service directory: file does not exist

This is the runit behavior when dbus is missing, and I consider it a bug because it's very annoying if the user starts the session without any display manager, or even GUI. This is not the case in the JWM iso, though. So, does it mean that the installed system doesn't end up at a login screen? In live sessions, live-config activates the autologin and display manager is skipped. But the annoying message is hidden by the X session in either case, and the flashing screen only appears when shutting down the system. At me at least.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#130 2024-03-10 00:34:12

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

I consider it a bug

... in gnuinos, I mean.

There are two runit services related to dbus in devuan: dbus itself, and the dependency fixer. Both services are provided by the same package, called runit-services. On the contrary, in gnuinos the latter is provided by runit-services, whereas the earlier is provided by dbus (since chimaera). This might be the source of the bug. Both packages should belong to the same packaging, being one or the other.

On the other hand, I noticed that one script has evaporated misteriously in my packaging. This script is invoked by the dependency fixer via sv check.

I'll try to fix these issues tomorrow.

Last edited by aitor (2024-03-10 00:34:41)


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#131 2024-03-10 11:17:43

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

Or maybe because the runit script should be provided by dbus-daemon instead of dbus.

Last edited by aitor (2024-03-10 11:18:24)


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#132 2024-03-10 11:35:43

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

I've updated the JWM images.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#133 2024-03-10 12:36:01

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

It looks like the new JWM image does not have the dbus problem any more, thanks!

After checking further, the issue that prevents the graphical session from starting seems to be the same as with plasma-sysvinit: glamor also complains that it does not get enough instructions. So it is likely hardware related. I now need to try with the latest xfce-runit image, maybe more recent versions of some GPU driver require higher specs.

The xfce-sysvinit image boots fine on the same hardware, though.

Last edited by prospero (2024-03-10 12:39:03)

Offline

#134 2024-03-10 13:26:52

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

The Intel dri2 driver. I thought that xserver-xorg-video-all would install xserver-xorg-video-intel, but it doesn't. New images will be available in a few minutes. Thanks for your tests.

Last edited by aitor (2024-03-10 13:28:12)


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#135 2024-03-10 15:03:47

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

aitor wrote:

I thought that xserver-xorg-video-all would install xserver-xorg-video-intel, but it doesn't. New images will be available in a few minutes

Done.

Last edited by aitor (2024-03-10 15:04:27)


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#136 2024-03-10 15:08:44

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

Great, thank you! Both now boot fine into their respective DE/WM. I can also confirm that the xfce-runit image is booting fine, as expected.

It is just amazing to have so much choice on aging harware, in complete freedom.

Offline

#137 2024-03-10 20:57:10

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

aitor wrote:

Both now boot fine into their respective DE/WM. I can also confirm that the xfce-runit image is booting fine, as expected.

Thanks for the info


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#138 2024-04-23 22:33:44

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

simple-netaid-gtk has been released:

https://git.devuan.org/aitor_czr/simple-netaid-gtk

Gnuinos images have been updated (except the plasma kde images) and now simple-netaid-gtk2 replaces to the ncurses interface simple-netaid-cdk.

Packages are available in Gtk2 and Gtk3 flavors:

https://packages.gnuinos.org/gnuinos/po … netaid-gtk


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#139 2024-04-24 20:18:17

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

Hi there, and thanks for the update! This does look like a nice Gtk GUI, so I thought I had to give it a try smile

Currently getting this when booting the runit XFCE amd64 live system:

elogind[XXXX]: Failed to connect to system bus: No such file or directory
elogind[XXXX]: Failed to fully start up daemon: No such file or directory

EDIT: it works fine on a VM, so the error could be caused by a failing USB flash drive.

Last edited by prospero (2024-04-24 21:03:40)

Offline

#140 2024-04-24 22:40:31

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

It works fine for me. However, there was a missing script /etc/sv/dbus/check in the openbox and xfce images. So, I recompiled and uploaded those images. Thanks for the advertisement!


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#141 2024-04-25 21:17:48

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

After further testing, both runit and sysvinit XFCE images boot fine on the usual laptop with Intel GMA 3150.

They also boot fine into a VM on the desktop I am currently testing on (with Intel HD 4600 graphics), but from the USB flash drive I keep getting crocus_dri related errors in the Xorg log. I can start a session through tty, but no graphical session so far. Crocus mystery.

Anyway, elogind seems to be happy now, no error messages any more. 👍

Last edited by prospero (2024-04-25 21:24:51)

Offline

#142 2024-04-27 08:23:38

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

I can't reproduce these errors in any of my computers. I wonder whether it's a vdev issue... Did you try with devuan live?


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#143 2024-04-27 14:15:05

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

I was able to boot from the USB into that computer using the devuan_daedalus_5.0.0_amd64_desktop-live image. 🤔

Crocus may be innocent after all.

Offline

#144 2024-04-27 17:26:52

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

Please, can you try with this other image?

https://www.gnuinos.org/eudev/

It's the same xfce x86_64, but with eudev instead of vdev.

Thanks in advance.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#145 2024-04-28 15:47:17

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

Thank you. Still no luck with the eudev image, same situation as with vdev. The first line in the Xorg log that seems to indicate an error is the following one:

nvc0_screen_create:1072 - Base screen init failed: -19

EDIT: I am getting the same error log as that one, just substitute "crocus" for "iris": https://bugs.debian.org/cgi-bin/bugrepo … 867;msg=45. The live system sends me to a blinking cursor every so often, which makes it a bit tricky to type in commands.

Last edited by prospero (2024-04-29 15:05:38)

Offline

#146 2024-04-29 16:26:29

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

Then it's not a vdev issue. Good..., and what about this other image?

https://www.gnuinos.org/tests/

I've installed the following additional packages:

i965-va-driver
intel-media-va-driver
iucode-tool
mesa-va-drivers
mesa-vdpau-drivers
mesa-vulkan-drivers
xserver-xorg-video-qxl

Thanks for your help!


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#147 2024-04-29 17:48:03

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

Just before seeing your last post, I had tried completely removing the nvidia GPU that was disabled at boot time but still plugged in, and I got an X session and a desktop, but no xfce4-panel.

I am now getting the same with the latest test image: graphical session starts, but no panel to be seen. So the last two test images (eudev and vdev) seem to behave the same when the integrated Intel graphics is the only GPU available. I will plug the nvidia GPU back in and let you know what happens.

UPDATE: I am getting the same Xorg error as with the previous test images when the nvidia GPU is plugged in (but disabled at boot time). So until now there has been no change in behavior, the only difference is triggered by unplugging the disabled external GPU.

Last edited by prospero (2024-04-29 18:13:25)

Offline

#148 2024-04-29 21:55:34

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 227  
Website

Re: GNUinOS - Libre

In order to discard possible issues with kernel drivers/modules I've recompiled the image replacing linux-libre with the stock kernel of debian:

https://www.gnuinos.org/tests/debian-kernel/

There is also another minor change: the option modprobe.blacklist=pcspkr has been removed from the boot parameters.

On the other hand, can you say me what's the output of the command below in the various scenarios (including devuan live)?

$ lspci -k | grep -EA3 'VGA|3D|Display'

Thanks again for your patience!

DISCLAIMER: debian-installer probably won't work with debian's kernel because it's built with linux-libre, but we're interested on live sessions.

Last edited by aitor (2024-04-29 21:58:36)


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#149 2024-04-30 00:42:06

prospero
Member
Registered: 2023-03-26
Posts: 34  

Re: GNUinOS - Libre

Updated summary of current results booting XFCE amd64 images from the USB flash drive on that workstation:

nvidia GPU plugged in - and set either as non-boot device or as primary VGA

  • all images return:

$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel [...] Integrated Graphics Controller
	Kernel driver in use: i915
01:00.0 VGA compatible controller: NVIDIA [...]
	Kernel driver in use: nouveau	
  • all gnuinos test images boot into tty1, no graphical session

  • Devuan desktop-live boots into XFCE session OK, using whichever GPU is set as primary VGA

NB: it transpired that the Devuan desktop-live image is loading a bevy of nvidia firmware blobs to be used with that NV137 (GP107) GPU. Maybe gnuinos could try defaulting to llvmpipe instead?

nvidia GPU unplugged

  • all images boot into XFCE session OK, kernel driver in use i915

Last edited by prospero (2024-05-05 09:07:41)

Offline

Board footer