The officially official Devuan Forum!

You are not logged in.

#1 2023-01-24 13:57:42

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Change locales issue

Hello everyone.

I seem to be unable to change locales (interface) on some applications, GIMP, Inkscape are the ones tested for now.
I am running on KDE and KDE apps seems to function fine in this regard so I guess it has to do with GTK applications; it didn't use to be like this before though.

All the appropriate language files are present but the programmes seem unable to read them; GIMP, for instance, regards the present of the lang-file but after a restart the language stays the same.

Any tips on this one?

Cheers,
Olav

Last edited by F_Sauce (2023-02-03 00:52:38)

Offline

#2 2023-01-24 18:14:20

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,125  
Website

Re: Change locales issue

Have you tried

# dpkg-reconfigure locales

See also https://wiki.debian.org/Locale.

If you have tried it then please post

locale -a
echo $LANG

Last edited by Head_on_a_Stick (2023-01-24 18:15:50)


Brianna Ghey — Rest In Power

Offline

#3 2023-01-24 21:35:11

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

Thanks a lot, and there are some progress, though not in the expected direction smile

I'll come back to it whether or not I manage to get the result I want; in the latter case, it might be helpful for others.

Cheers,
Olav

Last edited by F_Sauce (2023-01-24 21:36:33)

Offline

#4 2023-01-25 18:52:25

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

I have two locales enabled: en_GB and nn_NO, in that priority order.

[color=green]olav@DDAmt:~$ locale -a[/color]
C
C.UTF-8
en_GB.utf8
nn_NO.utf8
POSIX
[color=green]olav@DDAmt:~$ echo $LANG[/color]
nn_NO.UTF-8
[/quote]
As you may see, the latter command shows just Norwegian (nynorsk) as available.

If I disable nn_NO (dpkg-reconfigure locales), some of the «LC_ ...» parameters will state «not available» (those not set specifically as appropriate from a Norwegian and personal point of view: monetary, numeric, time etc.).
[quote][color=green]olav@DDAmt:~$ locale[/color]
LANG=nn_NO.UTF-8
LANGUAGE=en_GB:nn
LC_CTYPE="nn_NO.UTF-8"
LC_NUMERIC="nn_NO.UTF-8"
LC_TIME="nn_NO.UTF-8"
LC_COLLATE="nn_NO.UTF-8"
LC_MONETARY="nn_NO.UTF-8"
LC_MESSAGES="nn_NO.UTF-8"
LC_PAPER="nn_NO.UTF-8"
LC_NAME="nn_NO.UTF-8"
LC_ADDRESS="nn_NO.UTF-8"
LC_TELEPHONE="nn_NO.UTF-8"
LC_MEASUREMENT="nn_NO.UTF-8"
LC_IDENTIFICATION="nn_NO.UTF-8"
LC_ALL=
[color=green]olav@DDAmt:~$ locale[/color]
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nn_NO.UTF-8
LANGUAGE=en_GB:nn
LC_CTYPE="nn_NO.UTF-8"
LC_NUMERIC="nn_NO.UTF-8"
LC_TIME="nn_NO.UTF-8"
LC_COLLATE="nn_NO.UTF-8"
LC_MONETARY="nn_NO.UTF-8"
LC_MESSAGES="nn_NO.UTF-8"
LC_PAPER="nn_NO.UTF-8"
LC_NAME="nn_NO.UTF-8"
LC_ADDRESS="nn_NO.UTF-8"
LC_TELEPHONE="nn_NO.UTF-8"
LC_MEASUREMENT="nn_NO.UTF-8"
LC_IDENTIFICATION="nn_NO.UTF-8"
LC_ALL=

As I see it, this has to be some locale settings stuck from before a dist-upgrade/reinstall.

Last edited by F_Sauce (2023-02-02 10:00:17)

Offline

#5 2023-01-25 19:03:13

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

[color=green]olav@DDAmt:~$ locale
[/color]locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=nn_NO.UTF-8
LANGUAGE=en_GB
LC_CTYPE="nn_NO.UTF-8"
LC_NUMERIC="nn_NO.UTF-8"
LC_TIME="nn_NO.UTF-8"
LC_COLLATE="nn_NO.UTF-8"
LC_MONETARY="nn_NO.UTF-8"
LC_MESSAGES="nn_NO.UTF-8"
LC_PAPER="nn_NO.UTF-8"
LC_NAME="nn_NO.UTF-8"
LC_ADDRESS="nn_NO.UTF-8"
LC_TELEPHONE="nn_NO.UTF-8"
LC_MEASUREMENT="nn_NO.UTF-8"
LC_IDENTIFICATION="nn_NO.UTF-8"
LC_ALL=
[color=green]olav@DDAmt:~$ [/color]

This output is from after disabling «nn_NO.UTF-8» locally (KDE system settings) as well.
Just a final note, «kde-l10n-nn» wasn't even installed when I started this thread, so probably a reinstall, not a dist-upgrade; I haven't used this computer for a while and can't remember precisely.

Last edited by F_Sauce (2023-02-02 10:02:57)

Offline

#6 2023-01-25 19:51:35

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,125  
Website

Re: Change locales issue

What does this say:

gsettings get org.gnome.system.locale region

Use the set option (instead of get) to set the correct region. The gsettings command is supplied by the libglib2.0-bin package. Or use dconf-editor if you prefer a GUI.


Brianna Ghey — Rest In Power

Offline

#7 2023-01-26 15:37:09

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

It says nothing in fact smile

olav@DDAmt:~$ gsettings get org.gnome.system.locale region
''

Last edited by F_Sauce (2023-02-02 09:59:12)

Offline

#8 2023-01-26 15:42:18

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

By the way, what is the syntax?
Where should I put in the language code to use?

I was a bit confused by this output:

olav@DDAmt:~$ gsettings set org.gnome.system.locale region
Usage:
  gsettings [--schemadir SCHEMADIR] set SCHEMA[:PATH] KEY VALUE

Set the value of KEY to VALUE

Arguments:
  SCHEMADIR A directory to search for additional schemas
  SCHEMA    The name of the schema
  PATH      The path, for relocatable schemas
  KEY       The key within the schema
  VALUE     The value to set

Last edited by F_Sauce (2023-02-02 09:58:43)

Offline

#9 2023-01-26 15:56:23

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,125  
Website

Re: Change locales issue

The trick is to read the man page.

But I might be wrong about this because

gsettings range org.gnome.system.locale region

Outputs

type s

Which makes no sense hmm

You could try

gsettings set org.gnome.system.locale region nn_NO.UTF-8

And please use code tags rather than quote tags when posting terminal output.


Brianna Ghey — Rest In Power

Offline

#10 2023-01-26 16:40:06

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

And please use code tags rather than quote tags when posting terminal output.

OK, I'll try to remember that.

And thanks so far!

Last edited by F_Sauce (2023-01-26 16:40:29)

Offline

#11 2023-01-26 16:53:34

golinux
Administrator
Registered: 2016-11-25
Posts: 3,179  

Re: Change locales issue

@F_Sauce . . . You should be able to edit you previous posts to change the tag to code. wink

Offline

#12 2023-02-02 09:57:27

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

Okay smile

Offline

#13 2023-02-03 00:50:16

F_Sauce
Member
From: Noreg
Registered: 2017-07-07
Posts: 87  

Re: Change locales issue

I have now achieved what I wanted to do, i.e. I can change between languages within the individual GTK package; just to mention, I tested languages which weren't enabled on the system, en_GB and nn_NO are the system languages, and they worked as well.

olav@DDAmt:~$ gsettings set org.gnome.system.locale region en_GB.UTF-8

I find this very strange but setting a specific language code with the command above changed everything. The «org.gnome.system.locale» string used to be empty, as shown in an earlier post, setting it to en.GB, or any language-code other than empty I presume, just made it possible to swap between them. Furthermore, even though I had set en_GB as default language (system-wide and KDE locales), after a re-login GIMP started using the nn_NO.

I'll stop now, too much speculations and I haven't got the energy nor the capacity probably to dig deeper to find the, obvious, logic behind this behaviour.

One thing I'm quite sure of though is that the output of «gsettings get org.gnome.system.locale region» command can't show an empty string, for whatever reason, if it does you, or at least I wasn't (on two different computers in fact), won't be able to change the locale setting for GTK apps in accordance with your preference in KDE nor swap between translations from within the individual applications, GIMP and Inkscape tested in this case.

Some premises seeing the above to be (fairly)valid:
- Devuan Beowulf
- KDE
- everything up to date
- no repositories other than the official ones (apart from some application specific repoes which should not interfere with the system in any way)

Thanks for your help Head_on_a Stick!
(you have my vote if you wish to have it back on your shoulders)

Olav

Last edited by F_Sauce (2023-02-03 01:24:22)

Offline

Board footer