The officially official Devuan Forum!

You are not logged in.

#1 2022-02-09 02:56:19

Ron
Member
Registered: 2018-04-22
Posts: 397  

[SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Along the lines of my other recent post about browser crashes, I had a computer freeze-up while browsing the web, and for the first time Alt + SysRq then r e i s u b did not reboot the system. It stayed frozen; had to do a hard shut down. This has now happened more than once. Any idea what why the reboot didn't work?

Last edited by Ron (2022-02-09 14:04:49)

Offline

#2 2022-02-09 03:07:23

golinux
Administrator
Registered: 2016-11-25
Posts: 2,503  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Many years ago, I was advised to type those letters s-l-o-w-l-y or it wouldn't work.  Seems it needs time to do stuff along the way. This may or may not be true.  I also remember that something has to be allowed for it to work.  I think it has worked for me  but also seem to remember it failing at other times.  Maybe I'm just confused . . . LOL!

Offline

#3 2022-02-09 06:24:33

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,326  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

golinux wrote:

something has to be allowed for it to work

^ This.

@OP: create a file at /etc/sysctl.d/reisub.conf with this content:

kernel.sysrq=1

Then reboot.


To obtain a root shell use su -. Using just su will result in "command not found" messages.

Offline

#4 2022-02-09 07:06:10

golinux
Administrator
Registered: 2016-11-25
Posts: 2,503  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

HoaS . . . You are my hero!

Offline

#5 2022-02-09 13:55:24

Ron
Member
Registered: 2018-04-22
Posts: 397  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Thanks HoaS (again). It works now on an unfrozen system. Waiting for another freeze to see if it works then (I'm assuming it will).

Offline

#6 2022-02-09 17:27:37

Ron
Member
Registered: 2018-04-22
Posts: 397  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Question: since this has worked on older versions of Devuan, and since this file did not exist on my current system, does this mean that Devuan or Debian has deliberately made the choice to have this disabled?

Offline

#7 2022-02-09 17:38:37

golinux
Administrator
Registered: 2016-11-25
Posts: 2,503  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

That needed to be done long before Devuan existed.  That doesn't mean that it wasn't intentional but  not for reasons you might be imagining . . .  I can't explain why it was working on previous releases without enabling it.

Offline

#8 2022-02-09 18:20:34

Ron
Member
Registered: 2018-04-22
Posts: 397  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

golinux wrote:

That needed to be done long before Devuan existed.  That doesn't mean that it wasn't intentional but  not for reasons you might be imagining . . .

I don't know . . . I have a very vivid (and crazy) imagination at times.  lol

Offline

#9 2022-04-26 02:57:37

dave
Member
Registered: 2020-09-28
Posts: 8  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

A Quick Comment:

I had an opportunity to REISUB one of my Pi's the other day.  The R-E-I-S-U portion worked as displayed on my console.   But it refused to B-oot. 

This was all done using the RightHand Alt key. 

For some reason, I decided to try the LeftHand Alt key.  [ A finger stretching exercise. ]  And it booted. !!

I haven't dug into it, but for some reason the LH Alt + SysReq key boot request worked while the RH Alt didn't.  The rest of the SysReq R-E-I-S-U worked with either RH or LH Alt key.

Ditto for the REISU-O sequence.  PowerOff only worked with the LH Alt key.  Useful on hung Pi's when you need to pull the chip.

Offline

#10 2022-04-26 16:28:44

Altoid
Member
Registered: 2017-05-07
Posts: 1,045  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Hello:

Head_on_a_Stick wrote:

@OP: create a file at /etc/sysctl.d/reisub.conf ...

Yes.
Creating the file in my box made it work.

And yes, it did work before without the /etc/sysctl.d/reisub.conf file.

Now, how long ago was before, I have not had a chance to use it much, so I really can't say.

O.

Offline

#11 2022-04-26 20:22:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,068  

Re: [SOLVED-PENDING] First time r-e-i-s-u-b didn't work

Altoid wrote:

Hello:

Head_on_a_Stick wrote:

@OP: create a file at /etc/sysctl.d/reisub.conf ...

Yes.
Creating the file in my box made it work.

And yes, it did work before without the /etc/sysctl.d/reisub.conf file.

Now, how long ago was before, I have not had a chance to use it much, so I really can't say.

O.

echo "kernel.sysrq=1" >> /etc/sysctl.conf

That's in my script to make refracta-8, which was ascii, but not for 7, which was jessie. So it started in debian stretch.

And I quit using  -e and -i because all they do is generate a console message saying that they are disabled.

Offline

Board footer