The officially official Devuan Forum!

You are not logged in.

#1 2021-09-13 21:15:14

Dutch_Master
Member
Registered: 2018-05-31
Posts: 206  

Blanking screen

Plain Beowulf+Mate install. When I watch a video, the screen goes blank after a short time of no input (mouse/keyboard). I've already disabled the screensaver. On Ascii, when I played a video, the screen stayed active, whether or not the video was paused didn't matter. It's really annoying having to press a key or move the mouse pretty much continuously while watching a video >:-{

Any suggestions?

Last edited by Dutch_Master (2021-09-13 21:15:42)

Online

#2 2021-09-13 21:29:57

golinux
Administrator
Registered: 2016-11-25
Posts: 2,289  

Re: Blanking screen

I don't know about Mate but Xfce has display options in the power management settings.

Online

#3 2021-09-13 22:00:58

Dutch_Master
Member
Registered: 2018-05-31
Posts: 206  

Re: Blanking screen

Found those on Mate already, and the power settings management thing, no dice sad

Mind, I re-used my /home dir from Ascii, it's on a separate HDD.

Online

#4 2021-09-13 23:00:47

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,951  

Re: Blanking screen

Dutch_Master wrote:

Mind, I re-used my /home dir from Ascii, it's on a separate HDD.

Create a new user and log in as that user to test. If the problem is gone, it's something in your home configs. (~/.config)

Offline

#5 2021-09-14 09:17:32

Camtaf
Member
Registered: 2019-11-19
Posts: 123  

Re: Blanking screen

I'd been having screensaver problems for a long time - nowadays, I just increase the time before activation to a ridiculously long time, like 3 days!

(Power saving - everything set to 'never'.)

Offline

#6 2021-09-14 11:56:56

Altoid
Member
Registered: 2017-05-07
Posts: 863  

Re: Blanking screen

Hello:

Dutch_Master wrote:

Plain Beowulf+Mate install.

I run Beowulf on a backported kernel, Xfce and a three monitor setup:

Linux devuan 5.10.0-0.bpo.3-amd64 #1 SMP Debian 5.10.13-1~bpo10+1 (2021-02-11) x86_64 GNU/Linux

It uses two Nvidia FX 580 (G96GL) cards and Nvidia proprietary legacy drivers.

I set up my xorg.conf file with DPMS set to disabled:

Section "Screen"
    Identifier     "ScreenLeft"      <- same for "ScreenCenter and "ScreenRight" 
    Device         "DeviceLeft"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DPMS" "False"
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection

 
This is clearly reflected in /var/log/Xorg.0.log:

groucho@devuan:~$ cat /var/log/Xorg.0.log | grep -i dpms
[    33.335] (**) Extension "DPMS" is disabled
groucho@devuan:~$ 

In addition to all this, if I run Applications -> Settings -> Screensaver (XscreenSaver 5.42) I get a pop-up that says   

Warning:
The XScreenSaver daemon doesn't seem to be running on display ":0.0".
Launch it now?

My three monitors are 2x SyncMaster 940n + a Dell P1914S in the centre.

One would think that none of them would blank at all, no?

Well, one of the SyncMaster 940n units ("ScreenLeft" in xorg.conf) turns off after a while.   

No idea why and does not really matter but ....

Best,

A.

Last edited by Altoid (2021-09-14 17:40:31)

Offline

#7 2021-09-14 19:32:49

Dutch_Master
Member
Registered: 2018-05-31
Posts: 206  

Re: Blanking screen

Thx all! I had forgotten about DPMS and a quick search on the web gave me the command

xset dpms 0 0 0 && xset s noblank  && xset s off #as root!

After letting the machine idle for a few hours it appears this does the trick as the screen didn't blank. So, I'll add this to a boot-script somewhere.

Online

#8 2021-09-14 20:33:06

Altoid
Member
Registered: 2017-05-07
Posts: 863  

Re: Blanking screen

Hello:

Dutch_Master wrote:

... forgotten about DPMS and a quick search on the web gave me the command

xset dpms 0 0 0 && xset s noblank  && xset s off #as root!

I wonder how that command relates to the settings in xorg.conf.
ie: Does it write to the conf file?

Could you please post the link where you got the information?

TIA.

Best,

A.

Offline

#9 2021-09-14 22:28:55

Dutch_Master
Member
Registered: 2018-05-31
Posts: 206  

Re: Blanking screen

Altoid wrote:

ie: Does it write to the conf file?

No it doesn't. It bypasses xorg.conf completely.

Altoid wrote:

Could you please post the link where you got the information?

Sure:  https://unix.stackexchange.com/question … acking-out

I still need to figure out which system boot script would be the best to add this command to. Or perhaps add a new boot script specifically for it. May take a while I'm afraid roll

HTH!

Online

#10 2021-09-14 22:44:56

Altoid
Member
Registered: 2017-05-07
Posts: 863  

Re: Blanking screen

Hello:

Dutch_Master wrote:

... bypasses xorg.conf completely.

Interesting ...

Thanks.
I'll give it a read.

Dutch_Master wrote:

... need to figure out which system boot script would be the best ...

I guess (?) you could write up a script, save it to /usr/local/bin/ and put it in your /etc/rc.local so it will run.
eg: this is the stuff I have in mine, with comments.

groucho@devuan:~$ cat /etc/rc.local
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
#
# to set all /proc/acpi/wakeup entries to 'disabled'
# no wakeup from S4 for anything
# does not survire reboot that's why it is here
# see https://dev1galaxy.org/viewtopic.php?pid=29113#p29113
#
/usr/local/bin/acpi_wakeups.sh
#
# to disable wol via ethtool at boot
# does not survire reboot that's why it is here
#
# /sbin/ethtool -s eth0 wol d
#
# 20210602 - changed for script in /usr/local/bin
# see https://dev1galaxy.org/viewtopic.php?id=4349 
#
# /usr/local/bin/no_wol.sh
#
# e1000e module is now patched to disable WoL
# see /usr/src/e1000e-patch 1001
groucho@devuan:~$ 
Dutch_Master wrote:

May take a while I'm afraid ...

Nah!
Try the rc thing, should work.
The trick is to write the script with the correct syntax.  8^|

Best,

CIV

Last edited by Altoid (2021-09-14 22:46:39)

Offline

#11 2021-09-15 12:40:10

Altoid
Member
Registered: 2017-05-07
Posts: 863  

Re: Blanking screen

Hello:

Dutch_Master wrote:
Altoid wrote:

ie: Does it write to the conf file?

No it doesn't. It bypasses xorg.conf completely.

I found this bit at https://wiki.archlinux.org/title/Displa … _Signaling

Note:
XScreenSaver and xfce4-power-manager use their own DPMS settings and override xset configuration.

See XScreenSaver#DPMS https://wiki.archlinux.org/title/XScree … g_settings

and

Xfce#Display blanking https://wiki.archlinux.org/title/Xfce#Display_blanking

To note for anyone using Xfce:

XScreenSaver
If xscreensaver is installed and runs alongside Xfce Power Manager, it may not be clear which application is in control of blanking and DPMS as both are competing for control of the same settings. Therefore, in a situation where it is important that the monitor not be blanked (when watching a video for instance), it is advisable to disable blanking and DPMS through both applications. To know more about XScreenSaver options, see XScreenSaver#DPMS and blanking settings.

Hmm ...
... competing for control of the same settings.

A classic case of right hand not knowing what left one does or too many fingers in the pie.
Maybe a bit of both, you'd think the chaps at Xfce would be a bit more careful.

As my WS is not dependent on battery power, I long ago decided to get rid of xfce4-power-manager and all associated files.

Cheers,

A.

Last edited by Altoid (2021-09-15 12:41:39)

Offline

Board footer