The officially official Devuan Forum!

You are not logged in.

#1 2020-09-27 21:19:31

bbatten
Member
Registered: 2017-07-02
Posts: 53  

[SOLVED (sorta)]Fat xfce activity bars

I've finally upgraded to Beowulf. Everything went smoothly except for having to tweek pulseaudio and su -.

My problem is that the device activity bars that I've installed on xfce4 4.12.5 panels are very fat and push some items off the visible area on the screen. Does anyone know how to slim them down?

Thanks,

Last edited by bbatten (2020-10-05 21:20:38)

Offline

#2 2020-09-27 22:24:43

golinux
Administrator
Registered: 2016-11-25
Posts: 2,074  

Re: [SOLVED (sorta)]Fat xfce activity bars

Screenshot?

Online

#3 2020-09-28 05:54:58

larsH
Member
Registered: 2020-05-05
Posts: 143  

Re: [SOLVED (sorta)]Fat xfce activity bars

Hi

Settings > Panel > Bottom of front page > Choose the right panel > Height (among other settings). I hope this is understandable. I am not using a English i user interface.

Have a nice day
Lars H

Offline

#4 2020-09-28 17:55:13

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

Offline

#5 2020-09-29 14:44:16

dev2cosmos
Member
Registered: 2020-09-29
Posts: 12  

Re: [SOLVED (sorta)]Fat xfce activity bars

That is because device activity bars in xfce are not very customizable. You probably better of using a conky bar rather than xfce4 panel widgets.

Offline

#6 2020-09-29 18:12:03

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

Thanks for the replies. My panel settings are unchanged from what I was using in ascii. I think it has something to do with xfce4-panel 4.12.2-1 installed as part of beowulf. So I'm going to check over there and see what I find.

Thanks again,

Offline

#7 2020-09-30 11:58:52

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,643  

Re: [SOLVED (sorta)]Fat xfce activity bars

I can't see your screenshot, but I think I know what you're talking about. I removed the network monitor from the panel in beowulf because of the wide bars. If you go into ~/.config/xfce4/panel/ you may find a netload*.rc that contains some settings. I don't see anything relating to the bar size.

You would probably have to edit the source code and recompile the package to change the size of the bars.

Warning: Whoever thought that was a good idea has apparently infected whoever makes the cpugraph plugin, because those bars are wide in chimaera. I can't wait to see eight wide bars on my hyperthreaded quad-core.

Why don't we have a face-palm smiley?

Offline

#8 2020-09-30 13:53:34

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 468  

Re: [SOLVED (sorta)]Fat xfce activity bars

💁 ... someone just made this forum full utf8... enjoy
https://unicode.org/emoji/charts/full-emoji-list.html

Offline

#9 2020-09-30 14:12:38

brocashelm
Member
Registered: 2020-06-29
Posts: 59  

Re: [SOLVED (sorta)]Fat xfce activity bars

Does FluxBB support image attachments? That would make life a lot easier for people asking for or receiving support.


"In a Time of Universal Deceit — Telling the Truth Is a Revolutionary Act" | George Orwell
Cthulhu 2020 | No Lives Matter

Offline

#10 2020-09-30 16:57:52

golinux
Administrator
Registered: 2016-11-25
Posts: 2,074  

Re: [SOLVED (sorta)]Fat xfce activity bars

ralph.ronnquist wrote:

💁 ... someone just made this forum full utf8... enjoy
https://unicode.org/emoji/charts/full-emoji-list.html

Just great.  Something else to block.  Anyway to disable it?

Online

#11 2020-09-30 19:23:17

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

Thanks for the reply.

fmisthread wrote:

I can't see your screenshot,

I'm pretty sure I've seen screenshots here.What is the right way to upload one? At any rate, looking thru ~/.config/xfce4/panel/, I don't see anything to adjust size. The fatness seems to apply to all bars. My cpu, mem, and swap displays are all fat.

Thanks again,

Offline

#12 2020-09-30 19:27:14

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

Thanks for the reply.

fmisthread wrote:

I can't see your screenshot,

I'm pretty sure I've seen screenshots here.What is the right way to upload one? At any rate, looking thru ~/.config/xfce4/panel/, I don't see anything to adjust size. The fatness seems to apply to all bars. My cpu, mem, and swap displays are all fat.

Thanks again,

Offline

#13 2020-09-30 20:35:32

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,643  

Re: [SOLVED (sorta)]Fat xfce activity bars

I don't know what the deal is with google. Maybe they expected me to log in to see the image. I did allow javascript for all the sites that noscript listed.

Some of us use transfersh.com for sharing images. I'm happy with anything that doesn't require javascript.

That's really weird that you get it on the cpugraph-plugin. Are you sure you're on beowulf and not chimaera/ceres?

$ apt policy xfce4-cpugraph-plugin
xfce4-cpugraph-plugin:
  Installed: 1.0.5-2
  Candidate: 1.0.5-2
  Version table:
     1.1.0-1 50
         50 http://sledjhamr.org/devuan/merged ceres/main amd64 Packages
 *** 1.0.5-2 500
        500 http://sledjhamr.org/devuan/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status

$ apt policy xfce4-panel
xfce4-panel:
  Installed: 4.12.2-1
  Candidate: 4.12.2-1
  Version table:
     4.14.4-1 50
         50 http://sledjhamr.org/devuan/merged ceres/main amd64 Packages
 *** 4.12.2-1 500
        500 http://sledjhamr.org/devuan/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status

Offline

#14 2020-10-04 21:46:06

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

@fsmithred: Sorry about the screenshot. Pilot error. I forgot to set the right permissions for it.
Am I on beowulf?

-bash(root)# stripws /etc/apt/sources.list
deb [arch=amd64,i386] http://deb.devuan.org/merged beowulf          main contrib non-free
deb [arch=amd64,i386] http://deb.devuan.org/merged beowulf-updates  main contrib non-free
deb [arch=amd64,i386] http://deb.devuan.org/merged beowulf-security main contrib non-free
deb [arch=amd64,i386] http://deb.devuan.org/merged beowulf-backports main contrib non-free
-bash(root)#

Here's my cpugraph and panel info:

-bash(root)# apt policy xfce4-cpugraph-plugin
xfce4-cpugraph-plugin:
  Installed: 1.0.5-2
  Candidate: 1.0.5-2
  Version table:
 *** 1.0.5-2 500
        500 http://deb.devuan.org/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status
-bash(root)# apt policy xfce4-panel
xfce4-panel:
  Installed: 4.12.2-1
  Candidate: 4.12.2-1
  Version table:
 *** 4.12.2-1 500
        500 http://deb.devuan.org/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status
-bash(root)#

As you can see from my (hopefully) now readable screenshot, every plugin that shows a bar has a fat bar.

I'll take a look at transfersh.com.

Thanks,

Offline

#15 2020-10-05 16:16:36

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,643  

Re: [SOLVED (sorta)]Fat xfce activity bars

Yes, you are on beowulf. And I can see the screenshot.

Oh, I just discovered that the width of the netload plugin bars chages depending on which theme is set in Appearance.

FWIW: They're wide with the cinnabar and darkpurpy themes and narrow with the plain Clearlooks theme. Presence or absence of gtk2/3-engines-xfce makes no difference.

Wide with clearlooks-phenix-theme, too, so it's something we inherited.

Offline

#16 2020-10-05 21:19:26

bbatten
Member
Registered: 2017-07-02
Posts: 53  

Re: [SOLVED (sorta)]Fat xfce activity bars

Clearlooks (see screenshot) makes a difference. Now the bars are really narrow.

Looks like things are probably as good as they're going to get, so I think I'll mark this as solved (sorta).

Offline

Board footer