The officially official Devuan Forum!

You are not logged in.

#1 2017-05-19 02:37:31

mmmna
Member
Registered: 2017-05-12
Posts: 2

Time zone

Had a bit of confusion over incorrect clock in XFCE on Devuan 1.0.0 RC2.

In fact, the system clock was exactly the same error as XFCE.

My hardware clock is set to local time, not UTC.

Tried setting the timezone at the console (as root), but time data was offset despite selecting the correct timezone. Off by 4 time zones worth of hours.

Solution was to install these packages (and all dependencies which might not be listed); as soon as Synaptic completed installation, my clock popped to the correct time. I already had a working network connection.

Synaptic install history wrote:

Commit Log for Thu May 18 17:37:52 2017

Installed the following packages:
...
ntp (1:4.2.6.p5+dfsg-7+deb8u2)
ntpdate (1:4.2.6.p5+dfsg-7+deb8u2)
ntpstat (0.0.0.1-1)
...

Offline

#2 2017-05-19 03:49:29

golinux
Administrator
Registered: 2016-11-25
Posts: 238

Re: Time zone

FWIW, I only have ntp installed and my Xfce clock is fine.

Offline

#3 2017-05-19 21:39:26

treebeard
Member
Registered: 2017-05-09
Posts: 5

Re: Time zone

My displayed time was out one hour after a 'simple' install of RC2 from a live DVD.
I'm not sure if my system clock was out but the clock plugin and the 'last amended' time on edited files were both out.

In the end i fixed it using

$ sudo dpkg-reconfigure tzdata

Using the arrow keys I selected the correct region and city.
It confirmed the changed timezone and the clock plugin updated at the start of the next minute.

I don't think I was asked for either locale or timezone by the RC2 'simple' installer and I had to repair both which took some time to read up on. Might be worth RC3 prompting for selection of both as I found it quite difficult to fix both these settings after the event. I think the installer must have asked for a language for which I would have selected English but I ended up with en-US when I needed en-GB and I have no idea how it selected my timezone but it wasn't quite right.

I soon sorted it out though and am really happy with Devuan.

For anyone interested in correcting the locale settings:

enter

$ locale

It probably says en_US

make sure that debconf package is installed.
Then enter

$ sudo dpkg-reconfigure locales

You'll see a long list of locales, and you can navigate that list with the up/down arrow keys.
Pressing the space bar toggles the locale under the cursor.
Make sure to select at least one UTF-8 locale.
Tab out of list and press return on OK button.
The final question of dpkg-reconfigure locales is to select the default locale.
Use arrows to choose and then press return.
Changes take effect after a reboot

I also then had to run this command to replace the $locale 'C' settings (which behaved like en-US) with my regional settings:

$ sudo update-locale LC_ALL=en_GB.UTF-8 LANG=en_GB.UTF-8

Log in again, or else you won't see the changes.

Last edited by treebeard (2017-05-19 22:52:28)

Offline

#4 2017-05-19 22:40:31

fsmithred
Member
Registered: 2016-11-25
Posts: 114

Re: Time zone

Thanks for pointing that out. I thought I enabled the pre-install scripts for simple install. Time zone and locale debconf dialogs should run at the beginning of the installation. They do in expert install, and post-rc2 also has keyboard settings at the same time. The simple install button is going to disappear in a future installer. Simple can be achieved with the expert install by ignoring all the checkboxes and proceeding without changing anything.

The default timezone should be UTC. That's what I get when I boot live media.

You can set the locale at boot, too. Take the second item in the boot menu, press TAB, and backspace to erase the locale code. Then replace it with your own. That runs a hook script that creates a file with the following lines (with your locale code for example.)
/etc/profile.d/zz_locale.sh

export LANG=en_GB.UTF-8
export LC_ALL=en_GB.UTF-8

But that won't change the keyboard. When editing the boot command, you could also add

keyboard-layouts=xx

where xx is the lower-case two-letter country code. In your case, I think that would be gb.

Or, on the xfce desktop, and the keyboard layout plugin to the panel, add codes (choose from the list) and use that to switch layouts.

Edit: keyboard-layouts gets a two-letter code.

Last edited by fsmithred (2017-05-20 19:15:18)

Offline

#5 2017-05-19 23:00:25

treebeard
Member
Registered: 2017-05-09
Posts: 5

Re: Time zone

The default timezone should be UTC

Yes I think it probably did default to UTC.
I'm in the UK where we are on British Summer Time, which would make UTC one hour out for me until I adjusted the timezone/local settings.

Offline

#6 2017-05-20 02:38:40

yeti
Member
Registered: 2017-02-23
Posts: 3

Re: Time zone

Apropos timezones... what happens with the payback of the "stolen hour" at the end of DST?
Will cron run jobs in that time range twice?


"They may have computers, and other weapons of mass destruction." — Janet Reno
"Isch ahbe fertisch!" — Sisyphos
"Logic, my dear Zoe, merely enables one to be wrong with authority." — The 2nd Doctor
"DNA is a four letter word." — yeti.

Offline

Board footer