The officially official Devuan Forum!

You are not logged in.

#1 2017-05-12 10:31:37

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

[SOLVED] can't get splash screen UEFI install (only scrolling text)

Hi I have managed boot the latest image 'devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso' on an old BIOS/MBR laptop but having problems getting to the usual splash screen when booting in a new UEFI/GPT laptop.

When it boots, it immediately displays lots of text then stops abruptly and never gets into the splash screen, here is a screenshot of where it stops ... http://imgur.com/a/S2ipN  I entered the usual '$ ls /sys/firmware' command and it does show 'efi' in the output so it is booting in EFI mode, it's just not giving me the splash screen to run the live desktop

I have burned it in Linux Mint using it's default USB writing tool which usually gives me no problems and also in Windows using Rufus with Partition scheme & target system type: GPT partition scheme for UEFI.

Has anyone seen this before?  Any help would be appreciated, as I am keen to try Devuan to see what it's like when installed.

Last edited by hughparker1 (2017-05-14 19:01:27)

Offline

#2 2017-05-12 11:05:18

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

No, I haven't seen that except when I was trying to boot to console. You should not need to log in to the desktop - it should happen automatically.
It's an isohybrid image, so anything that just copies it bit by bit to the whole device should work. I don't know what Mint or Rufus does, but if Rufus needs to know that it's for uefi, then it's probably doing something about that, and it should not. If you have a running linux, you can just use dd.

Please check the following commands:

tty          #which tty are you connected to?
ps ax |grep slim       # is the display manager running?
sudo runlevel
cat .xsession-errors
sudo less /var/log/Xorg.0.log    # look for lines starting with EE

Try ctrl-alt-F7 (maybe F8 or F9) to see if that gets you to the desktop.

If slim is not running, try starting it:

sudo service slim start

Check the sha256sum to make sure the download was good.

$ sha256sum devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso
ac38f0c7d983f8ce93f7b261274fef30823022707b96fc1c09f6b9a1b0c3709d  devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso

Offline

#3 2017-05-12 14:15:53

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:

No, I haven't seen that except when I was trying to boot to console. You should not need to log in to the desktop - it should happen automatically.
It's an isohybrid image, so anything that just copies it bit by bit to the whole device should work. I don't know what Mint or Rufus does, but if Rufus needs to know that it's for uefi, then it's probably doing something about that, and it should not. If you have a running linux, you can just use dd.

Please check the following commands:

tty          #which tty are you connected to?
ps ax |grep slim       # is the display manager running?
sudo runlevel
cat .xsession-errors
sudo less /var/log/Xorg.0.log    # look for lines starting with EE

Try ctrl-alt-F7 (maybe F8 or F9) to see if that gets you to the desktop.

If slim is not running, try starting it:

sudo service slim start

Check the sha256sum to make sure the download was good.

$ sha256sum devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso
ac38f0c7d983f8ce93f7b261274fef30823022707b96fc1c09f6b9a1b0c3709d  devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso

Thanks for quick reply, here is the output from the commands...

http://i.imgur.com/cMShUXE.jpg

also output from sudo less /var/log/Xorg.0.log    # with lines starting with EE

http://i.imgur.com/87PEEzb.jpg   

I checked the file I downloaded with sha256sum

$ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS

hugh@sony-solus ~/Downloads $ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS
devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso: OK
hugh@sony-solus ~/Downloads $

so file looks good. not sure what I'm doing wrong. Does the output from the commands tell us anything?  I'm not an expert on linux to be honest, still learning I'm afraid.  Any advice would be appreciated.

Offline

#4 2017-05-12 15:06:49

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

At the boot menu, press 'e' to edit the boot entry. Use the arrow keys to navigate to the linux line and add the word, nomodeset to the line. Then ctrl-x to boot.

Offline

#5 2017-05-12 16:19:16

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

hughparker1 wrote:

I checked the file I downloaded with sha256sum

$ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS

hugh@sony-solus ~/Downloads $ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS
devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso: OK
hugh@sony-solus ~/Downloads $

I don't understand what you did here. Where did devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS come from? You could not have downloaded it, because there's no such file on the server. All the sums are in one file. Did you look at the output of the command to see that it matched the number I posted?

Offline

#6 2017-05-12 19:42:05

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:
hughparker1 wrote:

I checked the file I downloaded with sha256sum

$ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS

hugh@sony-solus ~/Downloads $ sha256sum -c --ignore-missing devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS
devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso: OK
hugh@sony-solus ~/Downloads $

I don't understand what you did here. Where did devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso.SHA256SUMS come from? You could not have downloaded it, because there's no such file on the server. All the sums are in one file. Did you look at the output of the command to see that it matched the number I posted?

thanks for feedback.  I downloaded the sha256sums file from the server and renamed it to make it clear what it was for as I had other files with similar names, here is the contents of the file...

f7f5c54394c663e00e90671fcbd5f49da0b00a813ed842a8c113a08fcdf729a8  devuan_jessie_1.0.0-RC2_amd64-live.iso
ac38f0c7d983f8ce93f7b261274fef30823022707b96fc1c09f6b9a1b0c3709d  devuan_jessie_1.0.0-RC2_amd64_uefi-live.iso
bd72961ddd44e8ce61eaf3fa680c268a18db062daf80e8549612eec6addba971  devuan_jessie_1.0.0-RC2_i386-live.iso

I checked the code is the same

Offline

#7 2017-05-12 19:52:27

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:

At the boot menu, press 'e' to edit the boot entry. Use the arrow keys to navigate to the linux line and add the word, nomodeset to the line. Then ctrl-x to boot.

Thanks for quick reply.  I did as instructed and it has successfully booted to the desktop, looks like Xfce.  I will install it later tonight as I need to go out now. I will come back tomorrow and let you know how it goes.

here are details for my laptop...

DELL Inspiron 5559
Processor: IntelCore i7-6500U CPU 2 Cores, 4 Logical Processors
Integrated Graphics Processor: Intel HD Graphics 520
Discrete Graphics Processor: AMD Radeon R5 M335
Drive: Crucial CT750MX3 SSD size: 750GB
Memory: 16GB

I have a couple of questions...
Q1. Is the problem caused by my graphics card?

Q2. Do you think I will need to add the word nomodeset to the Linux line after it is installed? I currently dualboot along with Debian Xfce and Windows 10.

Thanks again for your recommendation.

Last edited by hughparker1 (2017-05-12 20:04:35)

Offline

#8 2017-05-12 21:15:42

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

1. Graphics card or driver. Whichever one you want to blame. You could try the proprietary driver, but if it's working ok, there's no need.

2. Yes. Add nomodeset to /etc/default/grub and then run update-grub to generate a new menu. Then you don't have to edit at boot every time.

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"

Offline

#9 2017-05-13 11:34:04

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:

1. Graphics card or driver. Whichever one you want to blame. You could try the proprietary driver, but if it's working ok, there's no need.

2. Yes. Add nomodeset to /etc/default/grub and then run update-grub to generate a new menu. Then you don't have to edit at boot every time.

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"

thanks for your continued support. I managed to install Devuan successfully,

I chose the default option to not install the uefi boot loader as I wasn't confident enought to perform the steps described to do this manually.

I then logged into my other linux OS and ran update-grub to add Devuan to the grub menu.

Then reboot to show new grub menu and selected Devuan and pressed 'e' to edit the boot entry and add the word nomodeset to the Linux line.

Now I am logged into the Devuan Xfce desktop.

I now realise that when I modify /etc/default/grub to add nomodeset ....

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"

... and try to update-grub I get error....

hugh@DELL-INSP-DEVUAN:~$ sudo update-grub
/usr/sbin/grub-mkconfig: 250: /usr/sbin/grub-mkconfig: cannot create /boot/grub/grub.cfg.new: Directory nonexistent
hugh@DELL-INSP-DEVUAN:~$ 

This must be because I chose not to install the uefi boot loader.

Is there an easy way to do this now after the event? (without damaging my other Debian  or Windows installation)  If I knew the correct syntax to use I can use the terminal.  Thanks again for all your help so far it has been great.

EDIT: will there be any problems since I already have Debian installed previously, I was thinking of the path for boot loader \EFI\boot\bootx64.efi might be the same for both Debian and Devuan ?

EDIT2: I notice there is a package called grub-efi in Synaptic Package Manager and wondered if I just need to install that?

Also, is there any other required steps after that? bearing in mind that I already have Debian Stretch and Windows 10 on my laptop.

PS. I found that Synaptic Package Manager didn't start from the normal menu path, but I managed to run it via terminal using

$ sudo synaptic

not sure if this is a known problem or something I did wrong during the install.

Last edited by hughparker1 (2017-05-13 13:08:36)

Offline

#10 2017-05-13 22:26:39

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

When you start synaptic from the menu, you should get a window that asks for a password. If you set up the system to use a root account, use the root password, and if you set it up for sudo, use your password. If you're not getting the pop-up window for authentication, the start it from a terminal like you did until that issue is solved.

For the grub problem. You're right. Editing the config on devuan won't help if debian is in charge of boot. I can think of three ways to fix it.
1. Boot into Devuan and reinstall grub-efi-amd64
2. Boot into Devuan and run 'sudo grub-install' in a terminal. (no device name needed with uefi)
    - optional for 2: run 'sudo grub-install --bootloader-id=some-name'

In either of those cases above, grub will create a bootloader and I expect it will put itself first in the list of bootloaders. Then you'll need to run update-grub to get debian in the boot menu. WARNING: I don't know this for a fact. UEFI implementations vary from manufacturer to manufacturer, so your system might not act like mine. COMMENT: I would try #2 with the bootloader-id first, and use an id name that is something other than debian, devuan or boot. Then you will know for sure that it's the one you just made.

In my system, Debian's bootloader is in /boot/efi/EFI/debian and Devuan's is in /boot/efi/EFI/devuan. There is a /boot/efi/EFI/boot/, too. I forget where that came from, and I don't use it. Whenever I install a linux and allow grub to install, it becomes first. If I change the order of the bootloaders using efibootmgr, it shows me that the boot order has changed, and then it reverts to the previous order as soon as I reboot. Yours may act differently.

3. Boot into Debian and copy the menuentry for Devuan from /boot/grub/grub.cfg into /etc/grub.d/40_custom, add nomodeset to the linux line, and run update-grub. There will be an extra entry for Devuan in the boot menu, and that one will have nomodeset in the boot command. The entry starts with the word, menuentry and ends with a closing curly brace `}' 

Read this if you haven't, re-read it if you have: http://www.rodsbooks.com/efi-bootloaders/index.html

Last edited by fsmithred (2017-05-13 22:32:35)

Offline

#11 2017-05-14 18:46:07

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:

When you start synaptic from the menu, you should get a window that asks for a password. If you set up the system to use a root account, use the root password, and if you set it up for sudo, use your password. If you're not getting the pop-up window for authentication, then start it from a terminal like you did until that issue is solved.

I did set it up for sudo but I'm not getting the pop-up window for authentication, not sure why.

fsmithred wrote:

For the grub problem. You're right. Editing the config on devuan won't help if debian is in charge of boot. I can think of three ways to fix it.
1. Boot into Devuan and reinstall grub-efi-amd64
2. Boot into Devuan and run 'sudo grub-install' in a terminal. (no device name needed with uefi)
    - optional for 2: run 'sudo grub-install --bootloader-id=some-name'

In either of those cases above, grub will create a bootloader and I expect it will put itself first in the list of bootloaders. Then you'll need to run update-grub to get debian in the boot menu. WARNING: I don't know this for a fact. UEFI implementations vary from manufacturer to manufacturer, so your system might not act like mine. COMMENT: I would try #2 with the bootloader-id first, and use an id name that is something other than debian, devuan or boot. Then you will know for sure that it's the one you just made.

I booted into Devuan and opened synaptic package manager and installed 'grub-efi-amd64'

I took your recommendation and went with 'bootloader-id' method first, so opened terminal and ran...

$ sudo grub-install --bootloader-id=devuan-hp

hugh@DELL-INSP-DEVUAN:~$ sudo grub-install --bootloader-id=devuan-hp
Installing for x86_64-efi platform.
Installation finished. No error reported.
hugh@DELL-INSP-DEVUAN:~$

$ sudo update-grub

hugh@DELL-INSP-DEVUAN:~$ sudo update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
Found Debian GNU/Linux (9.0) on /dev/sda11
Found Linux Lite 3.4 (16.04) on /dev/sda12
Found Linux Mint 18.1 Serena (18.1) on /dev/sda13
Found MX-16 Metamorphosis (16) on /dev/sda14
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
done
hugh@DELL-INSP-DEVUAN:~$ 

So far so good, then rebooted and checked UEFI boot settings and 'devuan-hp' was shown as a new entry first on list and is now in charge of grub menu as you predicted it would be. 

Also when I pressed 'e' on the Devuan entry of the grub menu. I noticed the 'nomodeset' was already there in the Linux line, I added this the other day.

fsmithred wrote:

In my system, Debian's bootloader is in /boot/efi/EFI/debian and Devuan's is in /boot/efi/EFI/devuan. There is a /boot/efi/EFI/boot/, too.

My system has a /boot/efi/EFI/boot/ as well. I'm not sure what it does.

fsmithred wrote:

Read this if you haven't, re-read it if you have: http://www.rodsbooks.com/efi-bootloaders/index.html

I hadn't read this to be honest but I had a quick look and found the second link "How to install an EFI boot loader, in general terms" explained very clearly so thanks for the link. I now know a little bit more than I did yesterday.

Thanks for all your help I really appreciated it. I'm very happy with the final result.

Quick question, when Devuan stable is finally released, with the uefi install be a bit more automated than the current rc2 release?  Following your instructions it was quite easy to install the boot loader post install.  I thought the steps to do this during the install were a bit too difficult for a linux newbie like myself to follow.

PS. I noticed when I pressed 'e' to enter the setparams screen to look at Linux line, there were what looked like russian characters along the bottom of the screen. see screenshot... http://i.imgur.com/UyWTi5E.jpg
Similar characters were also visible along the bottom of the GRUB MENU... http://i.imgur.com/RrpgG4V.jpg
Have you seen this before? I chose UK during the install process so not sure why there is russian text showing.

Last edited by hughparker1 (2017-05-14 18:53:48)

Offline

#12 2017-05-14 18:50:55

golinux
Administrator
Registered: 2016-11-25
Posts: 2,180  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

@hughparker1 . . . I'm pretty sure you won't have to reinstall.  Just an update/upgrade should get you to the stable release.  That looks like Russian to me also.  Locales must be confused . . .

Offline

#13 2017-05-14 19:04:38

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

golinux wrote:

@hughparker1 . . . I'm pretty sure you won't have to reinstall.  Just an update/upgrade should get you to the stable release.  That looks like Russian to me also.  Locales must be confused . . .

Thanks for feedback. is there an easy way for me to check/modify Locales you mentioned?

Offline

#14 2017-05-14 20:15:35

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

Wow. The Russian is weird. Are all system messages in Russian? You can change language/locale by running

dpkg-reconfigure locales

But I don't think that will help. That's a grub message. I know there are language files in /boot/grub, but I don't know anything about how they work. Maybe some setting in /boot/grub/grub.cfg or /etc/grub.d/* thinks you want Russian.

I just learned that a big part of your problem with this install is the fact that grub-efi-amd64 is not installed in the iso. That's my error, and it will be fixed. So yes, it will be easier. You'll get a window that has some choices for what to do with grub, and one of them is to let the installer add the bootloader. All you need to do is press one button.

Offline

#15 2017-05-15 08:07:46

FOSSuser
Member
From: Surrey/Hants border UK
Registered: 2016-12-11
Posts: 167  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

Have you seen this before? I chose UK during the install process so not sure why there is russian text showing.

I have a feeling that uk is Ukranian, probably need en or gb.

Offline

#16 2017-05-15 09:43:36

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

FOSSuser wrote:

Have you seen this before? I chose UK during the install process so not sure why there is russian text showing.

I have a feeling that uk is Ukranian, probably need en or gb.

thanks for feedback, I'm not sure if I chose en or gb or uk to be honest, I'm not sure what was displayed on the list of options, I should have taken a note. but I did have to change the keyboard from US to English (UK) after the install when I rebooted, so not sure if that gives a clue or not.

Offline

#17 2017-05-15 10:21:26

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

@FOSSuser: Good call.

@hughparker1: the correct locale to choose is en_GB

Offline

#18 2017-05-15 11:13:33

hughparker1
Member
From: Scotland UK
Registered: 2017-05-12
Posts: 29  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

fsmithred wrote:

@FOSSuser: Good call.

@hughparker1: the correct locale to choose is en_GB

Thanks @FOSSuser and @fsmithred for your support

I think I must have selected  'uk_UA.UTF-8 UTF-8' as my locale because I see 'set lang=uk_UA' in my '/boot/grub/grub.cfg'

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=uk_UA
  insmod gettext

when I try to change this it doesn't seem to work....

$ sudo dpkg-reconfigure locales

  
Package configuration                                                           

 ┌──────────────────────────┤ Configuring locales ├──────────────────────────┐  
 │ Locales are a framework to switch between multiple languages and allow    │  
 │ users to use their language, country, characters, collation order, etc.   │  
 │                                                                           │  
 │ Please choose which locales to generate. UTF-8 locales should be chosen   │  
 │ by default, particularly for new installations. Other character sets may  │  
 │ be useful for backwards compatibility with older systems and software.    │  
 │                                                                           │  
 │ Locales to be generated:                                                  │  
 │                                                                           │  
 │    [ ] en_DK.UTF-8 UTF-8                                                  │  
 │    [ ] en_GB ISO-8859-1                                                   │  
 │    [ ] en_GB.ISO-8859-15 ISO-8859-15                                  ▒   │  
 │    [ ] en_GB.UTF-8 UTF-8                                              ▒   │  
 │    [ ] en_HK ISO-8859-1                                                   │  
 │                                                                           │  
 │                                                                           │  
 │                    <Ok>                        <Cancel>                   │  
 │                                                                           │  
 └───────────────────────────────────────────────────────────────────────────┘  

when I select 'en_GB.UTF-8 UTF-8' and tab to highlight <Ok> then press enter

I get this screen...

Package configuration                                                           
 ┌──────────────────────────┤ Configuring locales ├──────────────────────────┐  
 │ Many packages in Debian use locales to display text in the correct        │  
 │ language for the user. You can choose a default locale for the system     │  
 │ from the generated locales.                                               │  
 │                                                                           │  
 │ This will select the default language for the entire system. If this      │  
 │ system is a multi-user system where not all users are able to speak the   │  
 │ default language, they will experience difficulties.                      │  
 │                                                                           │  
 │ Default locale for the system environment:                                │  
 │                                                                           │  
 │                                None                                       │  
 │                                C.UTF-8                                    │  
 │                                en_US.UTF-8                                │  
 │                                uk_UA.UTF-8                                │  
 │                                                                           │  
 │                                                                           │  
 │                    <Ok>                        <Cancel>                   │  
 │                                                                           │  
 └───────────────────────────────────────────────────────────────────────────┘  

...but 'en_GB.UTF-8 UTF-8' is not on the list so I selected 'en_US.UTF-8' and pressed enter

the output in terminal now shows...

hugh@DELL-INSP-DEVUAN:~$ sudo dpkg-reconfigure locales
Generating locales (this might take a while)...
  en_US.UTF-8... done
  uk_UA.UTF-8... done
Generation complete.
hugh@DELL-INSP-DEVUAN:~$

... but when I reboot I still see the russian like characters on the grub menu screen, and my keyboard is still showing English (UK) same as before. So maybe this can't be fixed, or is there a step I missed ?

EDIT: the step I missed was

$ sudo update-grub

after reboot, I see english in the GRUB MENU smile silly me

Last edited by hughparker1 (2017-05-15 11:50:40)

Offline

#19 2017-05-15 12:17:28

FOSSuser
Member
From: Surrey/Hants border UK
Registered: 2016-12-11
Posts: 167  

Re: [SOLVED] can't get splash screen UEFI install (only scrolling text)

Glad to see you got it sorted. smile

Offline

Board footer