The officially official Devuan Forum!

You are not logged in.

#1 2022-08-16 17:34:49

Roger
Member
From: Vancouver, BC, Canada
Registered: 2019-04-06
Posts: 65  
Website

Avoiding systemd

I have just discovered a file /etc/apt/preferences.d/avoid-systemd which references a systemd-sysv package which is no longer on my system. I assume it is a remnant from the original installation when I converted a new machine from ubuntu.

Can I delete the file?

Offline

#2 2022-08-16 18:08:37

golinux
Administrator
Registered: 2016-11-25
Posts: 2,604  

Re: Avoiding systemd

Probably . . . I'm not seeing it in the package list

That being said . . . you might possibly find other systemd files present in Devuan. This post explains why.

Online

#3 2022-08-16 19:52:55

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,131  

Re: Avoiding systemd

If you have not already deleted that file, please wait. Below is the last changelog entry for the package that provided that file in the past. Latest version of the package should remove all the old files, including avoid-systemd. Please see if devuan-baseconf is installed. Let me know if it is.

If it's not, please install it and see if it removes avoid-systemd. Let me know that, too. Thanks.

If you already deleted it, then don't worry about it. It's no longer needed.

devuan-baseconf (0.6.4+devuan3.2) unstable; urgency=medium

  * Disable debian/install and debian/postinst.
  * Keep postrm to remove old files.
  * Keep package until nothing depends on it.

 -- fsmithred <fsmithred@gmail.com>  Sun, 05 Jan 2020 17:12:00 -0500

Offline

#4 2022-08-16 21:46:15

Roger
Member
From: Vancouver, BC, Canada
Registered: 2019-04-06
Posts: 65  
Website

Re: Avoiding systemd

That machine has devuan-baseconf 0.6.4+devuan3.1

I update it regularly with aptitude, but I stay with the current stable version.

The machine originally had ubuntu and I converted it using installation from a linux system. Two other machines which have been running devuan much longer, and were migrated from Debian jesse to ascii do not have the file.

Offline

#5 2022-08-16 21:52:19

Roger
Member
From: Vancouver, BC, Canada
Registered: 2019-04-06
Posts: 65  
Website

Re: Avoiding systemd

a PS: the two machines which followed the standard migration procedure do not have the devuan-baseconf package now. They have been running Devuan since ascii, through beowulf and now chimaera. All the upgrades have been done using the standard release notes.

Offline

#6 2022-08-17 07:31:34

alexkemp
Member
Registered: 2018-05-14
Posts: 72  

Re: Avoiding systemd

fsmithred wrote:

Please see if devuan-baseconf is installed. Let me know if it is.

$ locate avoid-systemd
/etc/apt/preferences.d/avoid-systemd
#
$ apt-cache search devuan-baseconf
devuan-baseconf - Devuan base config files
$ apt-cache showpkg devuan-baseconf
Package: devuan-baseconf
Versions: 
0.6.4+devuan3.1 (/var/lib/apt/lists/deb.devuan.org_merged_dists_chimaera_main_binary-amd64_Packages) (/var/lib/dpkg/status)

Already installed. I do full-system updates daily.

Offline

#7 2022-08-17 11:42:17

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,131  

Re: Avoiding systemd

My mistake. The version of devuan-baseconf with the fix is only in ceres and daedalus. If the package just gets removed on upgrade, then I guess nothing else depends on it anymore. That's good.

If someone wants to try the newer version, it's here: http://deb.devuan.org/merged/pool/DEVUA … .2_all.deb

Removing the file, removing the package or doing nothing are all equally valid courses.

Offline

Board footer