The officially official Devuan Forum!

You are not logged in.

#1 2021-04-20 12:36:08

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Beowulf is broken

ASCII -> Beowulf upgrade
boot option: Qemu/Xen enabled

# whoami
root
# uname -a
Linux desktop 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux
# echo $PATH:
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
# modprobe -c
bash: modprobe: command not found
# halt
bash: halt: command not found

WTF! >:-{

Online

#2 2021-04-20 12:40:02

dice
Member
Registered: 2020-11-22
Posts: 425  
Website

Re: Beowulf is broken

modprobe and halt are in /sbin/ so not on your $PATH by the looks of it, not broken just missing input.

edit: for my roots $PATH atleast i have /sbin/

root@beowulf:~# $PATH
-bash: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:

Last edited by dice (2021-04-20 12:43:30)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Online

#3 2021-04-20 12:46:51

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

In that case, during the upgrade this new directory should have been added to $PATH for root, but clearly it hasn't on my system. Or it was removed by the upgrade, that I can't be sure of as I didn't test it before upgrading.

[edit] Found the culprit, in /etc/profile:

if [ "`id -u`" -eq 0 ]; then
  PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
else
  PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
fi
export PATH

So, if the user uses su into root from your normal user, the id does not equate to 0 thus /sbin is not in your $PATH roll

PS: which "bright spark" had the "luminous" idea to set terminal text as bright yellow on a bright white background? You should be clobbered into sense with a foam bat! roll

Last edited by Dutch_Master (2021-04-20 12:59:47)

Online

#4 2021-04-20 12:56:04

dice
Member
Registered: 2020-11-22
Posts: 425  
Website

Re: Beowulf is broken

Im not 100% certain but i believe this might be due to the UsrMerge scheme adopted by debian. I always choose not to merge during installation.

https://wiki.debian.org/UsrMerge

Last edited by dice (2021-04-20 12:56:28)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Online

#5 2021-04-20 13:01:58

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

dice wrote:

Im not 100% certain but i believe this might be due to the UsrMerge scheme adopted by debian. I always choose not to merge during installation.

https://wiki.debian.org/UsrMerge

Regrettably, that wasn't an option during my upgrade.

Online

#6 2021-04-20 13:05:21

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: Beowulf is broken

su got moved from shadow to util-linux. I don't know what thought went into the change in root's path when you get there via 'su'. If you use 'su -' it still works the same as it used to. It's in the release notes for beowulf along with some other inherited gems and workarounds. https://files.devuan.org/devuan_beowulf … _notes.txt

Offline

#7 2021-04-20 13:07:28

dice
Member
Registered: 2020-11-22
Posts: 425  
Website

Re: Beowulf is broken

ahh just saw your edit: always use su - due to this bug report. https://bugs.debian.org/cgi-bin/bugrepo … bug=918754


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Online

#8 2021-04-20 13:10:29

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

fsmithred wrote:

su got moved from shadow to util-linux. I don't know what thought went into the change in root's path when you get there via 'su'. If you use 'su -' it still works the same as it used to. It's in the release notes for beowulf along with some other inherited gems and workarounds. https://files.devuan.org/devuan_beowulf … _notes.txt

OK, fair enough. I don't use su -, I created an alias for su to invoke su - in ~/.bash_aliases. It works, but clearly not for everything.

Online

#9 2021-04-20 15:03:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: Beowulf is broken

I hate using 'su -'. Most of the time when I become root, I'm already in the directory where I want to do stuff, and I want to stay there. I don't want to change to /root. And sometimes I want to run a graphical app as root from the user's desktop. That got lost in the change, too. Fortunately, there's a way to restore the old behavior.

ALWAYS_SET_PATH yes

in /etc/default/su

Offline

#10 2021-04-20 16:59:21

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

Yeah, I did that too now. Didn't solve all issues, I still can't load a module required for Qemu. As root:

# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
# modprobe kvm-amd
modprobe: ERROR: could not insert 'kvm_amd': Operation not supported
# modprobe kvm_amd
modprobe: ERROR: could not insert 'kvm_amd': Operation not supported
# modprobe -c | grep kvm_amd
alias cpu:type:x86,ven*fam*mod*:feature:*00C2* kvm_amd

So, what next?

Last edited by Dutch_Master (2021-04-20 16:59:53)

Online

#11 2021-04-20 20:13:37

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

Well, for the 2nd time tonight Beowulf crashed. I was browsing while playing 2 local video files (via smplayer and vlc respectively) and it froze solid. No input, audio looped continuously, no response at all. Only a hard reset could solve the issue. This was on the Xen-enabled kernel. On ASCII, this scenario was perfectly fine and it could do this literally all day and never miss a beat. Now running the non-Xen kernel, see if that changes anything.

So far, Beowulf impresses me badly for all the wrong reasons roll

Online

#12 2021-04-20 22:12:36

Altoid
Member
Registered: 2017-05-07
Posts: 761  

Re: Beowulf is broken

Hello:

fsmithred wrote:

... hate using 'su -'. Most of the time when I become root, I'm already in the directory where I want to do stuff, and I want to stay there.
I don't want to change to /root.

Ahh ...
And I thought I was the only one.  8^D

I'm trying hard to get use to su - and how it works.
Sometimes I fear that not being where I want to be (and in /root instead) will make/allow me to do something stupid.

fsmithred wrote:

... there's a way to restore the old behavior.

ALWAYS_SET_PATH yes

in /etc/default/su

But you still have to use su -, you just don't get sent to /root.
Right?

Best,

A.

Offline

#13 2021-04-20 22:29:23

GlennW
Member
Registered: 2019-07-18
Posts: 114  

Re: Beowulf is broken

Altoid wrote:

Hello:

fsmithred wrote:

... hate using 'su -'. Most of the time when I become root, I'm already in the directory where I want to do stuff, and I want to stay there.
I don't want to change to /root.

Ahh ...
And I thought I was the only one.  8^D

I'm trying hard to get use to su - and how it works.
Sometimes I fear that not being where I want to be (and in /root instead) will make/allow me to do something stupid.

fsmithred wrote:

... there's a way to restore the old behavior.

ALWAYS_SET_PATH yes

in /etc/default/su

But you still have to use su -, you just don't get sent to /root.
Right?

Best,

A.

ahh, no. I thought I was the only one! Funny, not funny.

I have nothing to add, except the ufw program complains when trying to start that user ID is 1000 when 0 is expected. Which I think may be a similar problem to the above, so I'm following this thread. Thank you.

Offline

#14 2021-04-20 22:44:16

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

My experience is, so far, that adding the set_path option in /etc/default/su outlined above works and su reverts to it's normal, expected behaviour. So, I can obtain root with a simple su, no extra dash required, and I stay in the current dir too!

Online

#15 2021-04-21 04:13:33

GlennW
Member
Registered: 2019-07-18
Posts: 114  

Re: Beowulf is broken

My appologies, I posted a reply, but I was wrong, so I deleted it... just rubish.

I had intended to creat the file /etc/default/su with the content ALWAYS_SET_PATH yes, but all I did was paste in the file address instead of the command. :'-(

Sorry for the bumb steer.

Offline

#16 2021-04-22 22:44:59

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

Well, after one too many freeze up I ditched Beowulf, tried to get Funtoo to work (but a core package for Mate failed to configure repeatedly and consequently build) then late last night I took my ASCII USB stick and booted from it. Installed ASCII, but sadly, the random freezes are still there. It might be related to Firefox, may need to look into that.

So, not a happy chappy here, to say the least >:-{  I may try Mint, but that means [shudder] systemd :puke:

Last edited by Dutch_Master (2021-04-22 22:45:39)

Online

#17 2021-04-22 22:57:07

golinux
Administrator
Registered: 2016-11-25
Posts: 2,181  

Re: Beowulf is broken

Maybe a hardware issue?

Offline

#18 2021-04-22 23:05:45

GlennW
Member
Registered: 2019-07-18
Posts: 114  

Re: Beowulf is broken

Dutch_Master wrote:

Well, after one too many freeze up I ditched Beowulf, tried to get Funtoo to work (but a core package for Mate failed to configure repeatedly and consequently build) then late last night I took my ASCII USB stick and booted from it. Installed ASCII, but sadly, the random freezes are still there. It might be related to Firefox, may need to look into that.

So, not a happy chappy here, to say the least >:-{  I may try Mint, but that means [shudder] systemd :puke:

have you tried a decent memtest?

Offline

#19 2021-04-22 23:25:29

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

Yes, I did. Unless it's deteriorated incredibly fast in the past weeks, I doubt that'll be a problem (it's been in the system for years and never failed, even with the intensive use I require from it)

Online

#20 2021-04-22 23:50:22

golinux
Administrator
Registered: 2016-11-25
Posts: 2,181  

Re: Beowulf is broken

All things are impermanent.  smile

Offline

#21 2021-04-23 12:16:24

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: Beowulf is broken

Altoid wrote:

Hello:


fsmithred wrote:

... there's a way to restore the old behavior.

ALWAYS_SET_PATH yes

in /etc/default/su

But you still have to use su -, you just don't get sent to /root.
Right?

Best,

A.

After making the edit:
Use su -if you want to cd to /root.
Use su if you want to stay in the current directory or if you want to run a graphical app as root on the user's desktop. (e.g. I frequently start gparted from terminal because I'm already in a terminal and it's easier than going up to the menu.)

@Dutch_Master: check to see if your cpu or motherboard is known to freeze with linux. I have one box that needs an extra boot option to prevent lockups.

Offline

#22 2021-04-23 13:28:42

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

I'm pretty sure it's not the mainboard, as that's been running stable for the past 6 years. Before my unfortunate "upgrade" to Beowulf, the CPU I'd put in last month was also stable. Both are fairly old so should be supported in Linux. So, I'm suspecting a remnant of Beowulf config somewhere as I've re-installed ASCII again this morning, after I removed a number of no-longer used dot files/folders in my users home dir. So far it hasn't locked up on me. See how long that lasts.

Come to think of it, it could be related to power management and/or screensaver stuff instead. I have the screensaver turned off and the power management switched off to the maximum intent, but after a period of no user input (mouse, kb), the screen still blanks itself (which is probably inside the monitor). I need to look that up and see if I can counter this behaviour (IIRC there was a kernel option to disable it, not sure)

(PS: for those who want to look it up, the mainboard is a Gigabyte F2A88XM-D3H with BIOS version F8, CPU is an AMD APU: PRO A10-8750B, no separate discrete GPU)

Online

#23 2021-04-26 17:54:09

Dutch_Master
Member
Registered: 2018-05-31
Posts: 188  

Re: Beowulf is broken

Well, 3 days on, no lockups. It seems the culprit was indeed some stray Beowulf config that got blasted when I re-installed ASCII. Good riddance!

Next step: see if AQemu works, despite the IOMMU BIOS setting being disabled by default. Goal: run Win7 as VM.

Online

Board footer