The officially official Devuan Forum!

You are not logged in.

#1 2024-05-22 12:42:52

Gonzalo_VC
Member
Registered: 2024-05-22
Posts: 3  

Packages version (suggestion)

IMHO something that Debian has failed is to offer some better versions for some packages. Yes, stability is absolutely important, but Devuan could do better in this sense. Packages like Libreoffice and Firefox have some tested versions, different from the last ("testing") launched, that can be used instead of a very old "stable" or supposedly having long term support ones.
Thanks.
Cheers!

Last edited by Gonzalo_VC (2024-05-22 12:47:10)

Offline

#2 2024-05-22 14:29:34

golinux
Administrator
Registered: 2016-11-25
Posts: 3,183  

Re: Packages version (suggestion)

That is a Debian not a Devuan issue as most of our packages come directly from upstream. Have you checked the backports repo for newer versions?

Offline

#3 2024-05-22 14:31:45

Gonzalo_VC
Member
Registered: 2024-05-22
Posts: 3  

Re: Packages version (suggestion)

OK 👍🏻  I was mistaken. Thank you!

Offline

#4 2024-05-22 14:33:00

Andre4freedom
Member
Registered: 2017-11-15
Posts: 148  

Re: Packages version (suggestion)

A true word.... Devuan may consider to just offer something like firefox-fresh or libreoffice-fresh in their repos.
It happened a few times to me that some crucial (to us) WEB-sites suddenly stop to work because of firefox-esr.
I had to download firefox from mozilla.org and install it their way, which works very well. And then, I still prefer firefox to every other browser there is.
Just a thought.

Offline

#5 2024-05-22 14:34:32

Andre4freedom
Member
Registered: 2017-11-15
Posts: 148  

Re: Packages version (suggestion)

Oh, just now I see golinux's answer. Cool.

Offline

#6 2024-05-22 15:23:14

stopAI
Member
Registered: 2023-04-04
Posts: 138  

Re: Packages version (suggestion)

If you need to use the latest versions of programs, you can take a look at Artix linux. Keep in mind that the latest versions of programs may contain not only improvements but also bugs.

Offline

#7 2024-05-22 15:37:05

quickfur
Member
Registered: 2023-12-14
Posts: 255  

Re: Packages version (suggestion)

Yes, as exemplified by the recent liblzma/xz backdoor fiasco. The latest versions (at the time) contained the backdoor, which was subsequently removed when affected distros rolled back to a known good version.

Also keep in mind that Debian security patches are usually applied to stable first, before it lands in testing. And new versions you get outside of the Debian infrastructure may not even be patched at all. Sticking with stable is generally safer.

Last edited by quickfur (2024-05-22 15:38:18)

Offline

#8 2024-05-22 18:05:12

Gonzalo_VC
Member
Registered: 2024-05-22
Posts: 3  

Re: Packages version (suggestion)

Indeed, I know the De**an philosophy is to keep safe and sound versions..The very last one is more likely to have bugs. Nevertheless, there are previous tested versions that could be used. I have a laptop with Debian and a netbook with antiX.
Cheers!

Offline

Board footer