The officially official Devuan Forum!

You are not logged in.

#1 2024-03-03 20:22:37

MageSlayer
Member
Registered: 2024-03-03
Posts: 3  

libelogind-compat has incompatible version

Hi

After dist-upgrade I am getting errors with libpam-modules-bin & related packages.
See below.
I managed to install them anyway, because otherwise OS stopped booting.

As far as I understand, it happens because libelogind-compat has version 252.9-2, but libpam-modules-bin requires 254 and later.

$ sudo apt-get install mc
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
mc is already the newest version (3:4.8.30-1).
mc set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libpam-modules-bin:i386 : Depends: libsystemd0:i386 (>= 254)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

$ sudo apt policy libelogind-compat
libelogind-compat:
  Installed: 252.9-2
  Candidate: 252.9-2
  Version table:
 *** 252.9-2 500
        500 http://deb.devuan.org/merged ceres/main amd64 Packages
        500 http://deb.devuan.org/merged excalibur/main amd64 Packages
        100 /var/lib/dpkg/status

My apt/sources.list is:

deb http://deb.devuan.org/merged ceres          main contrib non-free non-free-firmware
deb-src http://deb.devuan.org/merged ceres          main contrib non-free

deb http://deb.devuan.org/merged excalibur main non-free contrib non-free-firmware
deb-src http://deb.devuan.org/merged excalibur          main non-free contrib

Any help?

Offline

#2 2024-03-03 21:03:22

rolfie
Member
Registered: 2017-11-25
Posts: 1,081  

Re: libelogind-compat has incompatible version

Well, chaos. You have as well Testing as Unstable in your sources. What are you trying to achieve with this setup? Do you know what you are doing?

Offline

#3 2024-03-03 21:26:50

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 199  

Re: libelogind-compat has incompatible version

I read on the debian forums that sid is in a transition.  Might be best to try and wait this one out for a while.

Offline

#4 2024-03-03 21:35:31

MageSlayer
Member
Registered: 2024-03-03
Posts: 3  

Re: libelogind-compat has incompatible version

I tried having following only.

deb http://deb.devuan.org/merged excalibur main non-free contrib non-free-firmware
deb-src http://deb.devuan.org/merged excalibur          main non-free contrib

... but it does not help.

Ok, I'll try to wait a bit.

Offline

#5 2024-03-03 21:41:46

golinux
Administrator
Registered: 2016-11-25
Posts: 3,162  

Re: libelogind-compat has incompatible version

Did you follow these instructions before upgrading to Excalibur?

Online

#6 2024-03-03 21:48:38

MageSlayer
Member
Registered: 2024-03-03
Posts: 3  

Re: libelogind-compat has incompatible version

Nope.

But usrmerge is already installed for some reason:

$ sudo apt policy usrmerge
usrmerge:
  Installed: 39
  Candidate: 39
  Version table:
 *** 39 500
        500 http://deb.devuan.org/merged excalibur/main amd64 Packages
        500 http://deb.devuan.org/merged excalibur/main i386 Packages

Offline

#7 2024-03-03 22:00:18

golinux
Administrator
Registered: 2016-11-25
Posts: 3,162  

Re: libelogind-compat has incompatible version

It is mandatory in Excalibur but if upgrading from Daedalus, the merge MUST be done BEFORE the upgrade or . . . consequences. Hope you can work it out. You might be able to fix it . . .

Online

Board footer