The officially official Devuan Forum!

You are not logged in.

#1 2024-01-19 15:38:25

haon4
Member
Registered: 2024-01-19
Posts: 2  

x won't start - Segmentation Fault after fresh install

Hi, i hope I'm right here. I just installed daedalus on my old laptop. Booting etc. works, but X won't start automatically. After trying to 'startx' (I also tried sudo startx - it results in the same issue), I get a Segmentation fault. I uploaded the xorg logfile here: https://pastebin.com/JNekdqEk

Thanks in advance!

Offline

#2 2024-01-19 16:50:53

quickfur
Member
Registered: 2023-12-14
Posts: 145  

Re: x won't start - Segmentation Fault after fresh install

Which versions of xorg-* packages do you have? And which version(s) of nvidia drivers are you using (if any)?

From cursory look it appears to be an ABI incompatibility issue caused by using packages of incompatible versions. But I could be wrong.

Offline

#3 2024-01-21 11:02:59

haon4
Member
Registered: 2024-01-19
Posts: 2  

Re: x won't start - Segmentation Fault after fresh install

Here is the output of "apt list | grep xorg": https://pastebin.com/jVRwiEHy, hope this lists everything you need.
I just tried to install debian instead of devuan and it worked flawlessly. Also, I get the exact error no matter if I use the netinstall or desktop .iso for installation of devuan...

Anyway, hope this info helps since I only have a hint of a clue of what I'm doing.

Edit: btw, I also suspected it to be a NVIDIA issue since on my second laptop without a graphics card, devuan works just fine out of the box.

Last edited by haon4 (2024-01-21 11:04:47)

Offline

#4 2024-01-21 16:30:26

golinux
Administrator
Registered: 2016-11-25
Posts: 3,109  

Re: x won't start - Segmentation Fault after fresh install

Edit: btw, I also suspected it to be a NVIDIA issue . . .

Do you have non-free-firmware, non-free and contrib enabled in you sources.list? That will pull in any missing graphics drivers.

Offline

#5 2024-01-21 20:36:56

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 1,098  

Re: x won't start - Segmentation Fault after fresh install

How did you install? Which desktop environment did you choose? How have you got so many packages from "unknown" (especially both the nouveau and nvidia modules)?

Offline

Board footer