The officially official Devuan Forum!

You are not logged in.

#1 2024-01-04 01:29:29

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

[SOLVED] Stop LXDE from being automatically started

I´d rather start it myself as needed and put it on tty11.
Iḿ new to Devuan and just trying to get it setup as I like.
Thanks,
Mike

Offline

#2 2024-01-04 05:05:15

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

Assuming you are running a display manager (e.g. slim) and would prefer to boot to a console login, the traditional sysv approach would be to remove its start link from one or more runlevels, then make one of those runlevels the default.
The former is best handled with update-rc.d on Debian based systems, and the latter can be done by editing /etc/inittab, either manually or with a stream editor.

e.g.

update-rc.d slim disable 3

followed by:

sed -i 's/id:.:initdefault:/id:3:initdefault:/g' /etc/inittab

See 'man init', 'man inittab' and 'man update-rc.d' for details.

Alternatively, if you will never need a graphical login you could just uninstall the display manager altogether.

Last edited by steve_v (2024-01-04 05:08:53)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#3 2024-01-05 00:20:50

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

Re: [SOLVED] Stop LXDE from being automatically started

Thanks Steve_v,
Itś been so long since I ran a sysV init system that I had forgotten to look in /etc/init.d/.
After spending half an hour last night killing various processes with ´kill -9 nnnn´ and watching LXDE shutdown then come right back I appreciate your pointing /etc/init.d/ and update-rc.d.
I killed lightdm with ´/etc/init.d/lightdm stop´, then restarted  it on tty11 with ´śtartx -- vt11 &'.
I had already tweeked /etc/inittab to only start gettys on tty1 and tty3.
´ update-rc.d lightdm disable' will hopefully keep lightdm from starting without my starting it.

I appreciate you taking the time to help and hope this new year treats you well.
Mike

Offline

#4 2024-01-05 00:43:20

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

Mike wrote:

Itś been so long since I ran a sysV init system that I had forgotten to look in /etc/init.d/

To add insult, it's pretty difficult to find information on sysv on the 'net at large these days, as most distros have replaced the content of their online manuals and wikis with systemd stuff (as opposed to keeping both).
The debian manual for example lists sysvinit-core and insserv under "List of boot utilities", then goes on to talk about systemd and only systemd. So much for init diversity roll

OTOH, that does incentivise the local use of 'man' and 'apropos' rather than looking for lazy howtos online, which can't be a bad thing tongue

Last edited by steve_v (2024-01-05 00:47:20)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#5 2024-01-05 01:08:36

quickfur
Member
Registered: 2023-12-14
Posts: 137  

Re: [SOLVED] Stop LXDE from being automatically started

Maybe Devuan should take up the mantle and publish more info on these things online.

Offline

#6 2024-01-05 01:19:51

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

Personally I think Devuan should move to openrc as default, and pool init documentation (and service scripts) with Gentoo, Artix, Alpine and Nitrux (and maybe even GhostBSD, which is pretty cool as far as BSD desktops go wink).
But that's just me. While it does still do what it should, I have no particular love of sysv, insserv or LSB.

Last edited by steve_v (2024-01-05 01:32:09)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#7 2024-01-05 01:42:32

golinux
Administrator
Registered: 2016-11-25
Posts: 3,107  

Re: [SOLVED] Stop LXDE from being automatically started

quickfur wrote:

Maybe Devuan should take up the mantle and publish more info on these things online.

Or maybe that is something that quickfur might want to explore and curate?

Online

#8 2024-01-05 02:55:52

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

Re: [SOLVED] Stop LXDE from being automatically started

Well, I spoke too quickly.
After killing LXDE on tty7 and restatring it on tty11, I posted my message above saying solved.
When I got back to the CL on tty10 where I had executed 'srartx -- vt11 &' it seemed to be hung, a couple of carriage returns later I hit Crtl-c. This brought LXDE on ttty11 down and I couldn't get it back. I tried the same startx command that had worked before both as mike and as root. No joy. Thinking that since I had started editing my log on tty7, i quit that and exited the VT. Didn't help. As root '/etc/init.d/lightdm start', the LXDE executable. No joy, said started but didn't show. As root, '/etc/init.d/lightdm restart'. Same result. Running 'top' showed that Xorg was running but no display manager and no xterm. I killed Xorg and tried all the things I'd tried before, still no joy.
Thinking perhaps I'd have better luck if I shutdown Devuan and restarted.
In 5-6 tries Devuan failed to start to the point of being able to to login.
A couple of times it never even showed a screen but several times it got to the login screen but wouldn't accept key strokes so no login.
The times it booted messages flash by on the screen saying apparmor failed.
Some distributions have a chance durring boot to get into a simple console to try to repair a broken system.
Has Devuan such that I simply didn't see or am I remembering that from MS Windows?
I'm back in Debian for Raspberry PI now in order to post.
Looks like I'll likely have to reinstall Devuan.
Unless someone has a better idea.
Be well,
Mike

Offline

#9 2024-01-05 03:26:22

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

You might try the usual tricks, like issuing a sysrq unraw or sak at an unresponsive login prompt, booting into runlevel 1 or S from the kernel command line, or at a pinch just passing sulogin (or even just sh) as init to boot direct to a shell and bypass normal startup altogether.

The "recovery shell" you mention is probably either runlevel 1 (or the synonymous "single") as above, or an initrd shell you'll be dropped into if the root fs is unavailable. Pretty sure Devuan has those and always has.

The apparmor stuff is probably harmless, for some unfathomable reason it keeps getting pulled in unless you pin it, then complains because it's not configured properly. In all it's kind of difficult to diagnose something like this from here without seeing the boot process.

Last edited by steve_v (2024-01-05 03:32:08)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#10 2024-01-05 11:36:11

aluma
Member
Registered: 2022-10-26
Posts: 456  

Re: [SOLVED] Stop LXDE from being automatically started

I probably don’t understand something and will write something stupid.
But text mode was runlevel 3, and graphics mode was runlevel 5.

The telinit command, which switches runlevels, still works.
But on my Daedalus only telinit 1 switches to text mode, telinit 3 switches to graphic.

The order in which services are started is important to sysv, so another method may not work or may cause a crash.

Offline

#11 2024-01-05 11:57:39

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

Default Debian installation does not make any difference between runlevels 2-5. You may customize them to your liking. Runlevels S (single) and 1 are used for maintenance.

The common xdm only in runlevel 5 convention comes from somewhere else, I forget exactly where.

Last edited by steve_v (2024-01-05 11:58:20)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#12 2024-01-05 14:03:17

aluma
Member
Registered: 2022-10-26
Posts: 456  

Re: [SOLVED] Stop LXDE from being automatically started

@steve_v
Thanks for the tip.
I caught my eye once, but I needed text mode in ancient times only to install the nvidia driver, I forgot already. sad

And on the topic, I would install the sysv-rc-conf package, it clearly shows what is running, it’s easy to edit, and I would try to create a runlevel in text mode.

Switch with telinit command.
  But I haven't tried it myself.

Offline

#13 2024-01-05 16:50:07

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

Re: [SOLVED] Stop LXDE from being automatically started

Steve_v, I've never used sysrq before. While man, aprpops, whatis and which had nothing to say about sysrq or magic, Wikipedia filled in the blanks.
None of those gave any information about 'sak' that you mentioned and a web search mostly pointed to women's handbags and fashions.
Please explain or point me to a reference.
Thanks,
Mike

Offline

#14 2024-01-05 17:20:54

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

Magic sysrq is a kernel facility, docs here.
SAK (ctrl-alt-sysrq-k) is Secure Attention (or Access) Key and kills everything on the current tty except login.
Unraw (ctrl-alt-sysrq-r) switches the keyboard to xlate mode, which can be useful to wrest keyboard control from a misbehaving or crashed X process.
The term and kill commands might also be useful, in the case some init script or daemon has gone rampant tongue

Last edited by steve_v (2024-01-05 17:58:04)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#15 2024-01-05 19:01:32

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

Re: [SOLVED] Stop LXDE from being automatically started

Thanks for the info, Sir.
I'll go try those things now.
Mike

Offline

#16 2024-01-05 19:15:07

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

TBH the first thing I'd do is see if the system will boot to single user mode (pass "single" or "1" on the kernel command line)... But again, boot issues are difficult to diagnose remotely, so more options more better.
I mention sysrq because when getting a working shell to see what's going on or fix something is the goal, sometimes a large hammer (e.g. "Kernel, kindly kill with fire everything except init") is the most effective tool.

Last edited by steve_v (2024-01-05 19:22:37)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#17 2024-01-05 19:33:37

aluma
Member
Registered: 2022-10-26
Posts: 456  

Re: [SOLVED] Stop LXDE from being automatically started

Runlevel 1 boots without a network.
18.jpg

Offline

#18 2024-01-06 05:19:16

Mike
Member
From: East Texas, USA
Registered: 2023-12-31
Posts: 29  

Re: [SOLVED] Stop LXDE from being automatically started

Well, surprise, surprise, when I went back to boot the Devuan install, the first try it, didn't get to the login prompt but the second time I could login and every thing seemed OK, I'm begining to suspect my KVM switch which is likely 15 years old.
None the less I purged all the packages tasksel installed for LXDE so I'll have to start over there. I've seen some posts here about a minimum X install, so will persue that.

Steve_v you mention adding to the kernel command line. Would that be editing /boot/config-6.1.69 and the param: CONFIG_CMDLINE?
A line at the top of that fle says: # Automatically generated file; DO NOT EDIT.

Aluma, what program gave you that display? Apropos confif or sysv orrunlevel doesn't give me anything that looks like it might be that program. Maybe I need to install it.

I just today realized that a short script I wrote to backup personal stuff to a flash drive weekly has been failing because some process under systemd had already mounted that flash under /media/mike/ hence my mount command telling it to mount on /sdb failed, grr. I'm really getting annoyed when the system does not what I want but what someone else wants.

Guys I really appreciate your input and if you lived close by would be deligted to buy you a beer.

Be well,
Mike

Offline

#19 2024-01-06 05:47:53

steve_v
Member
Registered: 2018-01-11
Posts: 324  

Re: [SOLVED] Stop LXDE from being automatically started

aluma wrote:

Runlevel 1 boots without a network.

Well, yeah. That's kinda the point - "single user mode", no network, no services, just a single local console login for maintenance or troubleshooting. Sysv came from unix mainframes and all that.

Mike wrote:

Steve_v you mention adding to the kernel command line. Would that be editing /boot/config-6.1.69 and the param: CONFIG_CMDLINE?
A line at the top of that fle says: # Automatically generated file; DO NOT EDIT.

That's the saved kernel configuration (i.e. a copy of /usr/src/linux/.config) for the installed linux-image package, and that parameter records the default command line (if one was) specified when the kernel was compiled.

While you could recompile the kernel to change the command line, that's work, and not how most sane people do it.
Try your bootloader configuration instead tongue
Assuming you're using GRUB, permanent changes can be made by editing /etc/default/grub (GRUB_CMDLINE_LINUX variable), and running 'update-grub'.
For a one-off, you can just edit the command line (starts with 'linux=<image name>') directly from the bootloader screen by hitting 'e' on a boot entry.

The display above is sysv-rc-conf. Convenient perhaps, but not really necessary as it's just a TUI frontend for update-rc.d.

Last edited by steve_v (2024-01-06 05:52:42)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Offline

#20 2024-01-06 06:58:03

aluma
Member
Registered: 2022-10-26
Posts: 456  

Re: [SOLVED] Stop LXDE from being automatically started

@Mike
This is what I mentioned above, sysv-rc-conf package.

@steve_v
No, Unix had multi-user launch levels, but without X, with and without a network. Runlevel 1 was not used specifically for everyday work in text mode.

Convenient perhaps, but not really necessary as it's just a TUI frontend for update-rc.d.

Yes, only the interface, but it helped me discover differences in operation between the original sysv and the modern version in Chimaera .
https://dev1galaxy.org/viewtopic.php?id=5443
At the same time, it eliminates errors when typing commands. smile

Regards.

Last edited by aluma (2024-01-06 07:17:01)

Offline

Board footer