The officially official Devuan Forum!

You are not logged in.

#1 2023-11-29 07:08:52

swiitch
Member
Registered: 2023-11-26
Posts: 9  

No sound on Gnome (Daedalus)

Hello !
Fresh Daedalus installation, with Gnome as DE.
When I go to the settings there is no device listed but :

$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfc820000 irq 72
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfce00000 irq 74
 2 [U0x46d0x825    ]: USB-Audio - USB Device 0x46d:0x825
                      USB Device 0x46d:0x825 at usb-0000:09:00.3-2, high speed

When I try $ aplay /usr/share/sounds/alsa/Noise.wav I have this error (sorry, it's in French but I'll try to translate it in English as good as I can)

$ aplay /usr/share/sounds/alsa/Noise.wav
aplay: main:831: erreur à l'ouverture audio : L'hôte cible est arrêté ou en panne

It says that the host is stopped or broken-down and it can't open audio.
My user is in the audio group.

Any help is welcome and if you need more informations tell me.
Thanks. : )


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#2 2023-11-29 11:31:14

swiitch
Member
Registered: 2023-11-26
Posts: 9  

Re: No sound on Gnome (Daedalus)

I created a ~/.asoundrc file

$ cat .asoundrc 
pcm.!default {
	type hw
	card 1
}

ctl.!default {
	type hw           
	card 1
}

I'm now able to play sound with the aplay command, so, the sound works with aplay but that's all.
Maybe I'm missing a package in Gnome to setting up the sound, but which one ? Because on XFCE the sound works. I tried on a Live USB of Devuan.

Keep searching ! ^^


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#3 2023-11-29 12:48:25

stopAI
Member
Registered: 2023-04-04
Posts: 120  

Re: No sound on Gnome (Daedalus)

Hello.

Just install package

pavucontrol

and make sound card adjustment from this program....

Offline

#4 2023-11-29 13:07:21

swiitch
Member
Registered: 2023-11-26
Posts: 9  

Re: No sound on Gnome (Daedalus)

stopAI wrote:

Hello.

Just install package

pavucontrol

and make sound card adjustment from this program....

That's not what I'm looking for. I'm trying to make Gnome working. Not installing random stuff to by pass the problem.


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#5 2023-11-29 13:34:49

swiitch
Member
Registered: 2023-11-26
Posts: 9  

Re: No sound on Gnome (Daedalus)

I will explain my problem better.

I can't configure my audio settings with the Gnome's settings menu. And neither with the menu in the top bar. I'm searching what is missing for the GUI of Gnome, the one installed with the DE, to work.


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#6 2023-11-29 14:23:10

rolfie
Member
Registered: 2017-11-25
Posts: 1,016  

Re: No sound on Gnome (Daedalus)

Your problem is that Gnome like other DEs does not supply a mixer on its own.

pavucontrol, alsamixer-gui are valid options to solve the issue.

Offline

#7 2023-11-29 14:33:36

swiitch
Member
Registered: 2023-11-26
Posts: 9  

Re: No sound on Gnome (Daedalus)

rolfie wrote:

Your problem is that Gnome like other DEs does not supply a mixer on its own.

pavucontrol, alsamixer-gui are valid options to solve the issue.

Why then is there a sound entry in the gnome-control-center ? Everything is here but not configurable. That's strange.


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#8 2023-11-29 14:45:32

rolfie
Member
Registered: 2017-11-25
Posts: 1,016  

Re: No sound on Gnome (Daedalus)

Thats normal. Without a mixer the dialogue in the control center is incomplete.

Offline

#9 2023-11-29 14:56:14

swiitch
Member
Registered: 2023-11-26
Posts: 9  

Re: No sound on Gnome (Daedalus)

rolfie wrote:

Thats normal. Without a mixer the dialogue in the control center is incomplete.

alsamixer-gui not found.
And that just doesn't make sense.

Where's the documentation ? Is there even documentation installed for Gnome ?

Well, I sick of GNU/Linux for today, I'll try FreeBSD and see the video games support on it.


--
w00t w00t

CPU: AMD Ryzen 7 5700X / GPU : Radeon RX7600 / RAM : 16GB / OS : Devuan GNU+Linux Stable / Init system : SysVinit

Offline

#10 2023-11-29 17:13:50

stopAI
Member
Registered: 2023-04-04
Posts: 120  

Re: No sound on Gnome (Daedalus)

swiitch wrote:

Well, I sick of GNU/Linux for today, I'll try FreeBSD and see the video games support on it.

Good luck to you then.

But I'll put in my three cents. If you can't solve the sound problem in Gnome, then FreeBSD will be even more difficult....

Offline

#11 2023-11-29 17:50:02

rolfie
Member
Registered: 2017-11-25
Posts: 1,016  

Re: No sound on Gnome (Daedalus)

No idea about Gnome, I am a Cinnamon user. Can't stand Gnome.

Well, if you don't want to listen to other users advise, you could use the forum's search function. Here is a thread that might help you: https://dev1galaxy.org/viewtopic.php?id=5407 that bring some other mixers into the game ...

Offline

#12 2023-11-29 18:10:41

golinux
Administrator
Registered: 2016-11-25
Posts: 3,109  

Re: No sound on Gnome (Daedalus)

The desire for instant gratification is destined for frustration and disappointment. Grinders get there eventually . . .

Online

#13 2023-12-04 14:43:52

am
Member
Registered: 2023-12-04
Posts: 1  

Re: No sound on Gnome (Daedalus)

Gnome in debian 12 switched from pulseaudio to pipewire, but pipewire requires systemd in debian and devuan has not been adapted to date.

As a workaround, when you start gnome session you would have to run these commands:

wireplumber &
pipewire &
pipewire-pulse &

Offline

Board footer