The officially official Devuan Forum!

You are not logged in.

#1 2023-09-13 20:21:31

EnglishMohican
Member
Registered: 2022-09-15
Posts: 8  

[SOLVED] Shotwell dependency confusion

I am trying to install Shotwell. So far I have tried synaptic, apt and aptitude and all of them refuse because of broken/missing/held packages. They don't quite agree on what the problem is. Synaptic says it needs either default-dbus-session-bus or dbus-session-bus, Aptitude and apt sort of agree that dconf-cli is the problem.

I found an old post that said that dbus-session-bus was provided by dbus-X11 which I do have installed.

dconf-cli is listed in the repository lists but has no data against it.

Apt flags up that my libdconf1 is at 0.40.0-4 but dconf-cli depends on libdconf1=0.38.0-2. I do not understand how it knows that when there is no data against the dconf-cli entry in Synaptic.  I tried to downgrade libdconf1 using Synaptic but it wants to remove most of the software on my laptop as part of the deal.

I am running Devuan Daedalus with xfce4, all updates applied. It was originally  Chimaera which I updated by changing the repository lists in Synaptic. This has caused one problem already - the update process dropped the ntp set of packages but did not install the ntpsec set of packages to replace it - at least that seemed to be the problem. I mention this because it could be a clue.

Mostly, I do not understand the problem. I have three package managers that tell me different problems, none of which seem totally reasonable. I would like an explanation of what the real problem is and why the package managers see it differently (just for my education) and ideally a simple means of correcting things and getting Shotwell installed.

Thank you for reading as far as this and for any help you can provide.

Offline

#2 2023-09-13 21:22:03

golinux
Administrator
Registered: 2016-11-25
Posts: 3,180  

Re: [SOLVED] Shotwell dependency confusion

Sorry I don't have a solution just my experience . . .

A very long time ago in simpler times, I used shotwell and liked it. Then it started to not-shot-so-well. Went around and around on their mailing list. Nothing I tried fixed it  I moved on to gtkam . . .

Offline

#3 2023-09-13 22:26:27

Dutch_Master
Member
Registered: 2018-05-31
Posts: 279  

Re: [SOLVED] Shotwell dependency confusion

I'm using Mate and have Shotwell running just fine.

root@desktop:/home/<user># apt show shotwell
Package: shotwell
Version: 0.30.11-1
Priority: optional
Section: gnome
Maintainer: Jörg Frings-Fürst <debian@jff.email>
Installed-Size: 6,606 kB
Depends: libc6 (>= 2.29), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.2.4), libexif12 (>= 0.6.21-1~),
 libgcr-base-3-1 (>= 3.8.0), libgcr-ui-3-1 (>= 3.8.0), libgdata22 (>= 0.15.0), libgdk-pixbuf-2.0-0 (>= 2.25.2),
 libgee-0.8-2 (>= 0.10.1), libgexiv2-2 (>= 0.10.4), libglib2.0-0 (>= 2.49.5), libgphoto2-6 (>= 2.5.10),
 libgphoto2-port12 (>= 2.5.10), libgstreamer-plugins-base1.0-0 (>= 1.0.0), libgstreamer1.0-0 (>= 1.0.0), libgtk-3-0 (>= 3.21.5),
 libgudev-1.0-0 (>= 146), libjson-glib-1.0-0 (>= 1.5.2), libpango-1.0-0 (>= 1.18.0), libpangocairo-1.0-0 (>= 1.14.0), libraw20 (>= 0.16.0),
 libsoup2.4-1 (>= 2.41.90), libsqlite3-0 (>= 3.5.9), libwebkit2gtk-4.0-37 (>= 2.25.1), libxml2 (>= 2.7.4), shotwell-common (= 0.30.11-1),
 dconf-cli, default-dbus-session-bus | dbus-session-bus, librsvg2-common
Replaces: shotwell-common (<< 0.26.2-1)
<snip>
Download-Size: 1,826 kB
APT-Manual-Installed: yes
APT-Sources: http://pkgmaster.devuan.org/merged stable/main amd64 Packages

I'm not sure I upgraded to the latest stable release yet, so I might still be on Old-Stable.

HTH!

Offline

#4 2023-09-14 13:18:15

delgado
Member
Registered: 2022-07-14
Posts: 176  

Re: [SOLVED] Shotwell dependency confusion

No solution, just some thoughts:

"libdconf1=0.38.0-2" looks like chimaera. Maybe something is left-over? (packages on hold? Or pinning in /etc/apt/preferecenes)?

ntpd: on one system upgraded to daedalus I did: apt purge ntp; apt install ntpsec.

Offline

#5 2023-09-14 19:11:12

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 219  

Re: [SOLVED] Shotwell dependency confusion

I also upgraded from Chimaera, using Cinnamon as DM and (automatically upgraded) Shotwell is working.
I note both my version of Shotwell and my Depends libraries differ from Dutch Master in that the version numbers are higher.

marjorie@grendel:~$ apt show shotwell
Package: shotwell
Version: 0.30.17-1+b1
Priority: optional
Section: gnome
Source: shotwell (0.30.17-1)
Maintainer: Jörg Frings-Fürst <debian@jff.email>
Installed-Size: 6,699 kB
Depends: libc6 (>= 2.34), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.2.4), libexif12 (>= 0.6.21-1~), libgcr-base-3-1 (>= 3.8.0), libgcr-ui-3-1 (>= 3.8.0), libgdata22 (>= 0.15.0), libgdk-pixbuf-2.0-0 (>= 2.25.2), libgee-0.8-2 (>= 0.10.1), libgexiv2-2 (>= 0.10.4), libglib2.0-0 (>= 2.49.5), libgphoto2-6 (>= 2.5.10), libgphoto2-port12 (>= 2.5.10), libgstreamer-plugins-base1.0-0 (>= 1.0.0), libgstreamer1.0-0 (>= 1.0.0), libgtk-3-0 (>= 3.21.5), libgudev-1.0-0 (>= 146), libjson-glib-1.0-0 (>= 1.5.2), libpango-1.0-0 (>= 1.18.0), libpangocairo-1.0-0 (>= 1.14.0), libraw20 (>= 0.16.0), libsoup2.4-1 (>= 2.41.90), libsqlite3-0 (>= 3.5.9), libunity9 (>= 3.4.6), libwebkit2gtk-4.0-37 (>= 2.25.1), libxml2 (>= 2.7.4), shotwell-common (= 0.30.17-1), dconf-cli, default-dbus-session-bus | dbus-session-bus, librsvg2-common
Replaces: shotwell-common (<< 0.26.2-1)
Homepage: https://wiki.gnome.org/Apps/Shotwell
Tag: implemented-in::c, interface::graphical, interface::x11, role::program,
 uitoolkit::gtk, use::organizing, use::viewing, works-with-format::jpg,
 works-with::image, works-with::image:raster, x11::application
Download-Size: 1,863 kB
APT-Manual-Installed: no
APT-Sources: http://deb.devuan.org/merged daedalus/main amd64 Packages
Description: digital photo organizer

Offline

#6 2023-09-14 19:43:27

EnglishMohican
Member
Registered: 2022-09-15
Posts: 8  

Re: [SOLVED] Shotwell dependency confusion

I had another go at the problem today and although I do not understand the fine points of why or how, I now have Shotwell up and running.
Yesterday, apt thought that dconf-cli version 0.38 was available - but a dependency was libdconf1 0.38. My libdconf1 was already at 0.40 so apt refused to load dconf-cli. Synaptic knew dconf-cli existed but had no details of any sort for it.

Today, Synaptic agreed that dconf-cli 0.38 was the latest version but refused to load with an error message that I interpreted as that it could not find the file. I dug around in the devuan repository and found that 0.40 of dconf-cli should be available and it referenced the debian repository. I searched through the debian repository and found the 0.40 file, downloaded it and used dpkg to install it.  Synaptic is now happy that 0.40 of both dconf-cli and libdconf1 are available and installed and Shotwell installed happily.

I guess the problem was probably something to do with the database files for apt and Synaptic on my system not updating properly but I certainly don't know that. I could find nothing in preferences that would prevent that updating. I would have liked to understand what was actually wrong and cannot pretend my solution is anything other than a cludge but it works so I am happy.

Thank you all for your thoughts, suggestions and helpful info. My Shotwell version is now 0.30.17-1+b1 from stable. I will try gtkam as my next experiment.

Offline

Board footer