The officially official Devuan Forum!

You are not logged in.

#1 2023-08-03 05:14:25

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

[SOLVED] HDMI - no sound output; microphone - no sound input

Hi, I have recently upgraded from Devuan Chimaera to Daedalus.
I use Devuan in my laptop Dell Latitude 3420.

My kernel info is as follows:

Linux devuan-Latitude 5.10.0-22-amd64 #1 SMP Debian 5.10.178-3 (2023-04-22) x86_64 GNU/Linux
 ~$ cat  /proc/asound/pcm
00-00: HDA Analog (*) :  : playback 1 : capture 1
00-01: HDA Digital (*) :  : playback 1 : capture 1
00-03: HDMI1 (*) :  : playback 1
00-04: HDMI2 (*) :  : playback 1
00-05: HDMI3 (*) :  : playback 1
00-06: DMIC (*) :  : capture 1
00-07: DMIC16kHz (*) :  : capture 1

I generally connect to a external monitor using a HDMI cable. Both before and after the upgrade:

1. I don't get the sound output from my laptop via the HDMI cable.
2. Also, my microphone input isn't working. I need to plug in my earphones or use an external webcam + mic for  video conferencing.

Pulse audio and pavucontrol is installed. But it doesn't show the HDMI option in the "Configuration" tab and the internal microphone in the "Input Devices" tab.

This was not the case in my Asus netbook. Everything worked fine with Devuan Chimaera in that laptop [that was a 2015 model; Dell Latitude is a 2022 model].

On a side note, my Dell came with Ubuntu pre-installed. And everything works flawlessly in that. That means there is no problem with the hardware. But in Devuan, something is missing or I haven't installed some important software.

Can someone help me out?
What other info will be required from my end?

Regards,
Thanks in advance.

Last edited by vrgovinda (2023-08-04 13:54:56)

Offline

#2 2023-08-03 22:28:27

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

I'm sorry if I sound silly. Is this the right forum to post such queries? If yes, have I posted in the right category, “Desktop & multimedia”?

Offline

#3 2023-08-03 23:18:33

golinux
Administrator
Registered: 2016-11-25
Posts: 3,164  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Yes and yes. Not many Devuan users use pulseaudio which is why a response might be slow. I have never had it installed. Please be patient.

Offline

#4 2023-08-03 23:52:10

delgado
Member
Registered: 2022-07-14
Posts: 168  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

You mentioned the kernel version: 5.10 is chimaera, daedalus has 6.1 and I would use this. Maye the old kernel is still booted as default for some reason?

The following command shows all sound devices on my box:

 $ cat  /proc/asound/pcm
00-00: ALC1150 Analog : ALC1150 Analog : playback 1 : capture 1
00-01: ALC1150 Digital : ALC1150 Digital : playback 1
00-02: ALC1150 Alt Analog : ALC1150 Alt Analog : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 1 : HDMI 1 : playback 1

That's all I got ...

Offline

#5 2023-08-04 13:58:13

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

golinux wrote:

Yes and yes. Not many Devuan users use pulseaudio which is why a response might be slow. I have never had it installed. Please be patient.

Thanks a lot golinux. Yes, I'll be patient.

Last edited by vrgovinda (2023-08-04 22:02:34)

Offline

#6 2023-08-04 14:28:18

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

delgado wrote:

You mentioned the kernel version: 5.10 is chimaera, daedalus has 6.1 and I would use this. Maye the old kernel is still booted as default for some reason?

Yes. The only kernel that is installed is this. Even though I have upgraded to Daedalus [changing the sources.list --> apt update --> apt upgrade --> apt dist-upgrade], somehow, the kernel version 6.1 hasn't been installed. I have installed it now and restarted. Still no luck.

Also, the Ubuntu which came pre-installed has everything working out of the box with kernel version 5.14 and pulseaudio. I am unable to understand how.

delgado wrote:

The following command shows all sound devices on my box:

 $ cat  /proc/asound/pcm
00-00: ALC1150 Analog : ALC1150 Analog : playback 1 : capture 1
00-01: ALC1150 Digital : ALC1150 Digital : playback 1
00-02: ALC1150 Alt Analog : ALC1150 Alt Analog : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 1 : HDMI 1 : playback 1

That's all I got ...

for the same command, I got as follows:

 ~$ cat  /proc/asound/pcm
00-00: HDA Analog (*) :  : playback 1 : capture 1
00-01: HDA Digital (*) :  : playback 1 : capture 1
00-03: HDMI1 (*) :  : playback 1
00-04: HDMI2 (*) :  : playback 1
00-05: HDMI3 (*) :  : playback 1
00-06: DMIC (*) :  : capture 1
00-07: DMIC16kHz (*) :  : capture 1

Thanks a lot.

Last edited by vrgovinda (2023-08-04 21:59:05)

Offline

#7 2023-08-04 21:51:48

delgado
Member
Registered: 2022-07-14
Posts: 168  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

vrgovinda wrote:

Ubuntu which came pre-installed has everything working out of the box with kernel version 5.14 and pulseaudio. I am unable to understand if this is a problem specific to 5.10.

Don't know either, there should be no problem with 5.10. Alsa devices are looking good too.

I did a bit of testing, but have no speaker connected to any HDMI output ... .
I temporary installed pulsaudio, and could switch to a HDMI output device. The config was present.
qasmixer shows no level-fader for the HDMI audio output.

The generic name for the current kernel is "linux-image-amd64"

$ sudo apt install linux-image-amd64

should install daedalus' kernel 6.1.

Offline

#8 2023-08-04 22:08:11

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

delgado wrote:

I temporary installed pulsaudio, and could switch to a HDMI output device. The config was present.
qasmixer shows no level-fader for the HDMI audio output.

Will switching to pipewire help? I'm not an expert; If that will help, I need some directions as to how to go about it.

delgado wrote:

The generic name for the current kernel is "linux-image-amd64"

$ sudo apt install linux-image-amd64

should install daedalus' kernel 6.1.

Yes. I have installed kernel 6.1. Still, no luck.

Offline

#9 2023-08-04 22:18:46

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,144  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

When you upgraded, did you add the section non-free-firmware ?

Offline

#10 2023-08-05 08:37:57

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

ralph.ronnquist wrote:

When you upgraded, did you add the section non-free-firmware ?

Yes. non-free is enabled in all.

 cat /etc/apt/sources.list
deb http://deb.devuan.org/merged daedalus main non-free contrib
deb http://deb.devuan.org/merged daedalus-updates main contrib non-free 
deb http://deb.devuan.org/merged daedalus-security main contrib non-free

Last edited by vrgovinda (2023-08-05 17:40:05)

Offline

#11 2023-08-05 09:16:26

rolfie
Member
Registered: 2017-11-25
Posts: 1,082  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

You will need to add the NEW sub-repo non-free-firmware to be able to load something from there. Change your sources.list to:

deb http://deb.devuan.org/merged daedalus main contrib non-free non-free-firmware

Some reading:
https://www.debian.org/releases/bookwor … e-firmware

Online

#12 2023-08-05 17:49:41

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

rolfie wrote:

You will need to add the NEW sub-repo non-free-firmware to be able to load something from there. Change your sources.list to:

deb http://deb.devuan.org/merged daedalus main contrib non-free non-free-firmware

Some reading:
https://www.debian.org/releases/bookwor … e-firmware

Thanks for the info rolfie! Yes, there were some updates indeed in the non-free-firmware section.

But again, it did not solve my problem. Rebooted into 6.1 and 5.10 separately. But no luck.

I'm surprised how Devuan GNU/Linux installed in a Linux compatible laptop that has come with Ubuntu pre-installed doesn't pick up the basic hardware components like the built-in mic! The audio output through the HDMI is also not so complicated like, say, a graphics card.

Offline

#13 2023-08-05 20:47:13

delgado
Member
Registered: 2022-07-14
Posts: 168  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Sound is not a general problem. Notebooks can be special in different degrees.

A bit of googling:
Ubuntu seems to produce custom images for the Latitude 3420. https://ubuntu.com/certified/202101-28600
There was a question about missing sound here: https://askubuntu.com/questions/1291829 … -ubuntu-20
Not exactly the same model, maybe the answer applies to your case too.

Offline

#14 2023-08-06 12:33:05

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

delgado wrote:

Sound is not a general problem. Notebooks can be special in different degrees.

A bit of googling:
Ubuntu seems to produce custom images for the Latitude 3420. https://ubuntu.com/certified/202101-28600

Thanks for this link. It gave me an insight that even standard Ubuntu images may have some issues when used in place of custom OEM images.

delgado wrote:

There was a question about missing sound here: https://askubuntu.com/questions/1291829 … -ubuntu-20
Not exactly the same model, maybe the answer applies to your case too.

Imitating the method on my machine didn't work [not supposed to work either]. I need to find what is the config parameter that I should modify. Hopefully we are making inroads in resolving this issue.

Last edited by vrgovinda (2023-08-07 15:16:51)

Offline

#15 2023-08-06 12:38:19

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

I am very grateful to all the good souls that have helped so far. Thank you for giving me some inspiration to continue with Devuan.

I just tried to find what's happening during boot. from /var/log/boot (an excerpt), I got the following:

Sun Aug  6 17:52:51 2023: Setting up ALSA...
warning: 'alsactl -E HOME=/run/alsa -E XDG_RUNTIME_DIR=/run/alsa/runtime restore' failed with error message 
'alsa-lib parser.c:2783:(load_toplevel_config) Unable to find the top-level configuration file '/usr/share/alsa/ucm2/ucm.conf'.

Sun Aug  6 17:52:51 2023: alsa-lib main.c:1541:(snd_use_case_mgr_open) 
error: failed to import hw:0 use case configuration -2'...done.

Does this give any additional hint about the problem at hand?
Thanks again.

Regards.

Offline

#16 2023-08-06 15:45:51

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Hello vrgovinda, I am surmising your name is an epithet of Vishnu ?

Installed, alsa-topology-conf alsa-ucm-conf alsa-utils, maybe I only need alsa-utils.
Run /etc/init.d/alsa-utils reset

I have a ASRock mini-itx (Intel J3355 (2016.)) I use HDMI monitor with built-in speakers.
A Asus E203N laptop (Intel N3350 (2016.))
A BMAX B1 Plus mini-pc (Intel N3350 (2016.)) I use HDMI monitor with built-in speakers.

The laptop speakers and headphone socket works out of the box in Chimaera and Daedalus.

The mini-pc which 'appears' to be the 'same' hardware as the laptop, is not, /var/log/dmesg shows me that I need two ES8336 firmwares from firmware-sof-signed for sound to work. I am now on Daedalus, does it work on Chimaera, I don't know. It works on Daedalus. Note: a newer firmware from Debian testing fails! clearly seen in dmesg.

The mini-itx works out of the box, line-out, and HDMI, Daedalus.

In alsamixer, if S/PDIF is muted, HDMI - no sound.
Also, maybe, attention to PCM.

I have a music file (FILE.WAV,) which I can play in console with aplay from alsa-utils, -d 3, plays for three seconds.

mini-itx/mini-pc,
line out/headphone|speaker
aplay -D plughw:0,0 -d 3 FILE.WAV

HDMI,
aplay -D plughw:0,3 -d 3 FILE.WAV

So, for HDMI, I have /etc/asound.conf
defaults.pcm.card 0
defaults.pcm.device 3
defaults.ctl.card 0

What I have learned,
alsamixer --view all,
attempt to hear some sound, levels, mutes, etc.

If I install pavucontrol pulseaudio (which I can always uninstall,) I can configure my mini-itx line-out AND HDMI sumultaneously (I havn't figured out how to do this in console alsa yet,) and as long as I do not reset alsa, that config remains.

Useful,
https://docs.slackware.com/howtos:hardw … -hda-intel
https://docs.slackware.com/howtos:hardw … _slackware
https://bkhome.org/news/201912/sound-fi … -lake.html

Last edited by andyp67 (2023-08-06 15:56:25)

Offline

#17 2023-08-06 16:13:11

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

There's too many bloody sound modules running, thanks to the western lands binary blob wankers, stifling evolution, (screwing with nature!) the coming decades, especially China and India, will stanley knife that holding back open-source.
The kernel is a tiny kernel, wrapped up in a whopping pile of shit, pathetic.

Offline

#18 2023-08-06 16:36:34

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Advanced Linux Sound Architecture was|is a far-sighted and responsible piece of work.

Offline

#19 2023-08-07 15:47:09

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Thanks andyp67 for your inputs. Yes "Govinda" is a description for Vishnu in the form of a cowherd boy [literal meaning = one who gives pleasure to the cows and our senses].

I couldn't understand how to use alsamixer; but pavucontrol can choose the audio input and output etc. Maybe, I am not that advanced a Linux user. But one good thing that I learnt from the link that you sent was lspci -nnk

I discovered a hint from lspci -nnk in both my Devuan and Ubuntu partitions.

Saved the output of this command and did a diff -y. I found that the "kernel drivers in use" are the same for all the PCI and devices except for the Multimedia audio controller. Devuan [left] and Ubuntu [right].

00:1f.3 Multimedia audio controller [0401]: Intel Corporation | 00:1f.3 Multimedia audio controller [0401]: Intel Corporation
	Subsystem: Dell Tiger Lake-LP Smart Sound Technology  |         Subsystem: Dell Device [1028:0b20]
	Kernel driver in use: snd_hda_intel		      |		Kernel driver in use: sof-audio-pci-intel-tgl
	Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl		Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl

Can this info be of any use for us?

Last edited by vrgovinda (2023-08-07 15:54:11)

Offline

#20 2023-08-08 01:56:19

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

vrgovinda wrote:
delgado wrote:

There was a question about missing sound here: https://askubuntu.com/questions/1291829 … -ubuntu-20
Not exactly the same model, maybe the answer applies to your case too.

Imitating the method on my machine didn't work [not supposed to work either].

I need to find what is the config parameter that I should modify. Hopefully we are making inroads in resolving this issue.

Actually, when I wrote this reply, I hadn't checked for the HDMI sound output, which was my mistake.
But the following config change in /etc/modprobe.d/alsa-base.conf at the end of this file did the trick:

 snd-hda-intel dmic_detect=0

So, the HDMI sound output is solved. Hurray!! Thanks delgado.
Mic input issue is still unresolved. I think we are inching closer.

P.S.: If someone can direct me to a resource which explains this config, that will be a nice learning. The URL given by delgado, https://askubuntu.com/questions/1291829 … -ubuntu-20 and the LinuxUprising link, https://www.linuxuprising.com/2018/06/f … ue-in.html, in that answer just explain what to do, but not why and how it works.

Last edited by vrgovinda (2023-08-08 02:25:32)

Offline

#21 2023-08-08 06:07:48

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

The following is the /etc/modprobe.d/alsa-base.conf from the Ubuntu partition.

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

[Please recollect that I have two partitions -- Ubuntu [pre-installed OEM Linux Image] & Devuan. Although the microphone works in Ubuntu, it doesn't work in Devuan. I am presenting the alsa-base.conf in the /etc/modprobe.d/ directory of the Ubuntu Partition so that it can be easy to analyze the issue.]

The /etc/modprobe.d/alsa-base.conf from the Devuan partition contains only one line:

 snd-hda-intel dmic_detect=0

Offline

#22 2023-08-09 13:20:14

delgado
Member
Registered: 2022-07-14
Posts: 168  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Just curious: Does the sound work in devuan when using /etc/modprobe.d/alsa-base.conf from ubuntu?

Offline

#23 2023-08-09 20:03:04

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

Useful,

https://thesofproject.github.io/latest/ … ction.html

Every time I create a change I run alsamixer --view all and it will be different

On my BMAX B1 Plus mini-pc which has a pig codec es8336, I am trying to get sound line-out and HDMI.

My next step is to install pavucontrol & pulseaudio, and see what I am offered,
then /etc/modprobe.d/snd.conf options snd-intel-dspcfg dsp_driver=3
and see what I am offered.
dsp_driver=1 & dsp_driver=2 terminally breaks sound.

It's amazing how computers are like cars in many ways, you look at them under a 40X microscope and they're full of crap & flux and that, like under the bonnet (hood,) another, 'chipset' change, reminds me of changing a wheel bearing and in the end I did it in the car parts car park because there was like five variants.
And here I am, twenty-five years later, clean install Windows 98SE and what's the first thing to do, see if the piece of shit sound is working.
And we've had HDMI for like twenty years plug and play and we pay hard earned money for this shit.
I guess without SOF we'd certainly be up shit creek without a paddle.
IMO options snd-hda-intel model=whatever is questionable pissing in the wind.

Last edited by andyp67 (2023-08-09 20:09:22)

Offline

#24 2023-08-09 20:36:51

andyp67
Member
Registered: 2022-10-30
Posts: 228  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

https://wiki.archlinux.org/title/Advanc … leshooting

Intel Cannon Lake PCH cAVS
On Intel Cannon Lake (eg. HP ZBook 15 G6), the integrated sound chipset requires ALSA firmware, and the following kernel module parameters are required:

options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

That should enable both sound and microphone.

Offline

#25 2023-08-10 11:40:30

vrgovinda
Member
Registered: 2023-06-14
Posts: 18  

Re: [SOLVED] HDMI - no sound output; microphone - no sound input

andyp67 wrote:

https://wiki.archlinux.org/title/Advanc … leshooting

Intel Cannon Lake PCH cAVS
On Intel Cannon Lake (eg. HP ZBook 15 G6), the integrated sound chipset requires ALSA firmware, and the following kernel module parameters are required:

options snd-hda-intel dmic_detect=0
options snd-hda-intel model=laptop-amic enable=yes

That should enable both sound and microphone.

Read through all the links that you have sent. Changed the kernel module parameters. Built-in Microphone still doesn't work. All that I get is some noise when I try to record the mic input.

Last edited by vrgovinda (2023-08-10 11:55:01)

Offline

Board footer