The officially official Devuan Forum!

You are not logged in.

#1 2022-12-29 17:38:57

dcolburn
Member
Registered: 2022-11-02
Posts: 280  

[SOLVED] nginx version

Is there a reason why the nginx version in the repository is 1.18 rather than 1.19?

Their video tutorial recommends 1.19.

Or should it not represent a significant difference?

Thanks

Offline

#2 2022-12-29 17:53:08

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,097  
Website

Re: [SOLVED] nginx version

The package versions for the stable release are frozen some time before the release. That's why it's called "stable". There are a few notable exceptions to this, such as firefox-esr & chromium, because of the security risks of an outdated version.

See https://www.debian.org/doc/manuals/debi … tml#s3.1.3 & https://wiki.debian.org/DontBreakDebian … f_Syndrome for further explanations as to why the latest version might not be the best option.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII, 18.

Offline

#3 2022-12-29 18:05:50

dcolburn
Member
Registered: 2022-11-02
Posts: 280  

Re: [SOLVED] nginx version

OK, got it.

Back to chasing conflicts between files cited in a nginx video "How to Get Started With NGINX" and the files to which they link on github.

Someone didn't proof it, it seems ... sigh.

Thanks

Offline

#4 2022-12-29 18:19:38

golinux
Administrator
Registered: 2016-11-25
Posts: 2,726  

Re: [SOLVED] nginx version

That version might be in the "backports" repository. If it is, install selectively. Do not install the entire backports. You might have a look at this page

Offline

Board footer