The officially official Devuan Forum!

You are not logged in.

#1 2017-07-20 02:28:40

garyz.dev1
Member
From: U.S.-South Carolina
Registered: 2017-06-15
Posts: 89  

arm-sdk for the BBB

Trying to use the  libdevuansdk and the arm-sdk to create a BeagleBone Black image
*** I ran this on a 32bit Devuan Jessie 1.0.0  - lxde
(I did find some files in the auto.mirror.devuan website that may prove usefull)

I don't get any action out of libdevuansdk other than a "0.5 version" of libdevuansdk displayed

? #1  - do I need to use git to download the sdk  - I used the .tz files and manually placed them
? #2  - where does libdevuansdk go in relation to the arm-sdk

I know you devs are busy with ascii - but there are maybe 3 or 4 of us that would like devuan on BBB
Below is my procedures that I followed.  - could you take a quick look at it??  its copied from leafpad

*** I ran this on a 32bit Devuan Jessie 1.0.0  - lxde

** * * * * * * * * * * PREPARATIONS  * * * * * * * * *
install the dependencies as mentioned in the sdk(s) Readme.md

determine/create an /arm-sdk folder (I used ~/arm-bbb - so I may type that by mistake)

*** I used these sources for the arm-sdk  --> https://github.com/dyne/arm-sdk/tree/next
***    "       "    "   libdevuansdk  -->  https://github.com/dyne/libdevuansdk/next
*** get zuper for zsh -->  https://github.com/dyne/zuper
*** ---- /next refers to 4.9 for the bbb
*** I extracted the .tz files -- (not git clone(d))   

put the zuper & zuper.init in /arm-sdk/lib/zuper/

I put libdevuansdk folder in /arm-sdk folder
    ***BUT /arm-sdk/init.sh had a comment --> #cd lib/libdevuansdk  !!!???

set up the tool chain -edit this file,  /arm-sdk/init.sh for your toolchain --[armhf]
    [BTW -- gcc gets installed in /arm-sdk]
   
*** I ran this on a 32bit Devuan Jessie 1.0.0 and had to delete the "lib32z1"
*** from the /arm-sdk/readme.md file as it wasn't in the devuan repositories  !!!???
*** maybe need to be loaded from the debian repository ???

setup the defaults in /libdevuansdk/config file
    I changed to us.mirror vice the auto.mirror (faster ?)
    not sure if needed here:  #grz added arch  -->   arch="armhf"
    [BTW -no X stuff] modified some of the ???_packages to my taste/needs/wants

verify the /libdevuansdk/zlib files have your specifics - -
    cache::removed all Architectures: except armhf
    helpers:: approx line333 changed Architectures: from all to 'armhf'
    sysconf:: I changed the name servers from the google ones line 109 ~
    sysconf:: changed the locales info from C to
        export LC_ALL=en_US.UTF-8
        export LANG=en_US.UTF-8
        export LANGUAGE=en_US.UTF-8
               and thenn back to the original -- still no action
    vm:: changed from _64 to _32  at line 115 ~
        VBoxManage createvm --name "$vmname" --ostype Debian_32 --register || zerr

** * * * * * * * * * LIGHTS * CAMERA * ACTION ***** * * * * * * * * *
so now - lets do
zsh
source zuper   {/arm-sdk/lib/zuper}[source is a linux command]
source zuper.init
cd to the /arm-sdk
source the init.sh  [sets up the gcc toolchain]

***tried to run the arm-sdk/sdk file but it reported no distro - never asked for one
***I assume that libdevuansdk needs to be run first to generate the distro - 'devuan'

source libdevuansdk
----wait--wait---
source sdk  [in the /arm-sdk folder]

*
looks like I have gpg 1.4  so need to payattention to parazyd's email
for depends
*

Offline

#2 2017-07-20 03:01:36

golinux
Administrator
Registered: 2016-11-25
Posts: 3,109  

Re: arm-sdk for the BBB

parazyd never comes to this forum.  I suggest you post this on #devuan-arm or as an issue in git here.

Offline

#3 2017-07-21 22:25:21

garyz.dev1
Member
From: U.S.-South Carolina
Registered: 2017-06-15
Posts: 89  

Re: arm-sdk for the BBB

Well, thanks for the tip @golinux.
I did get on the #devuan-arm finally and left a note and some info for parazyd.
'
To others -- my process is wrong at this time !!!!!!!!!!!!
'
I need to run 'git' and configure it with my credentials
I need to 'git' the arm-sdk folder - AFAIK
'
another user tried to do their process and it failed for the BBB (and rPi3)
I picked up some clues/hints from their log information!
'and will incorporate it.
Have a good Day

Offline

Board footer