The officially official Devuan Forum!

You are not logged in.

#1 2021-03-09 04:35:08

netdxr
Member
Registered: 2017-04-23
Posts: 4  

[SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

Having a difficult time getting dual monitors working with a Beowulf 3.1.0 VM under VirtualBox 6.1 running on a 3.1.0 base install. The VM works fine with one display, but never brings up the second when I configure it in the VBox app. The VM OS does see the second monitor, but when I enable it in Settings->Display, the VM locks up and has to be powered down. I had a dual monitor VM partially working with 3.0, but it would randomly crash and was never stable enough to use.

Dual monitors in Centos 6 and 7 VM's work perfectly with VBox 6.1 on Beowulf 3.1, but I'd like to get rid of them and have a pure Devuan stack. Does anyone know the magic for getting this to work?

Thanks,

-Tom

Offline

#2 2021-03-09 16:19:27

bgstack15
Member
Registered: 2018-02-04
Posts: 195  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

Alas, we have no magic for you. Can you inspect /var/log/syslog and /var/log/Xorg.0.log for messages at the time you tried to enable the second monitor?


This space intentionally left blank.

Offline

#3 2021-03-10 00:24:57

netdxr
Member
Registered: 2017-04-23
Posts: 4  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

Thanks for your reply and suggestions.

The syslog, Xorg.0.log and debug logs all have a lot of Braille related messages and errors. The brltty service is also running in the process tree even though I disabled it in sysv-rc-conf.

When I enable the second monitor on the VM from Settings-Display, the last thing in Xorg.0.log is "[   750.046] (EE) No surface to present from.". Shortly afterward, I lose mouse and keyboard control and have to forcibly power down the VM.

Is there a procedure for removing all the braille related hooks to see if this is the problem? Made the attempt to do that on Beowulf 3.0 and ended up with a hopelessly broken X. Genuinely appreciate people needing braille support, but I'd like to eliminate it completely as a potential root cause in this case.

Per your suggestions, these appear every 5 seconds from in both /var/log/debug and syslog:

Mar  9 16:31:29 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:34 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:39 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:44 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:49 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:54 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:31:59 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:04 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:09 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:14 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:19 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:24 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:29 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:34 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:39 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file
Mar  9 16:32:44 dev1 brltty[569]: DBus error: send message: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service file

From Xorg.0.log:

[     7.339] (II) XINPUT: Adding extended input device "BRLTTY 5.6 Linux Screen Driver Keyboard" (type: KEYBOARD, id 13)
[     7.339] (**) Option "xkb_model" "pc105"
[     7.339] (**) Option "xkb_layout" "us"
[     7.339] (II) event8  - BRLTTY 5.6 Linux Screen Driver Keyboard: is tagged by udev as: Keyboard
[     7.339] (II) event8  - BRLTTY 5.6 Linux Screen Driver Keyboard: device is a keyboard
[    35.671] (EE) No surface to present from.
[   750.046] (EE) No surface to present from.

Thanks,

-Tom

Offline

#4 2021-03-10 14:47:34

bgstack15
Member
Registered: 2018-02-04
Posts: 195  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

Have you started with removing any packages related to brltty? And the bluez listing is related to bluetooth. If you are certain you don't need any bluetooth userspace tools installed (which you probably don't anyway, because it can't find it), make sure those are gone too.

Regardless, I seriously doubt brltty and any bluetooth/lack of bluetooth is related to preventing a display from working.


This space intentionally left blank.

Offline

#5 2021-03-12 04:35:37

netdxr
Member
Registered: 2017-04-23
Posts: 4  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

I tried removing the braille related packages when I had this problem on 3.0, but X wouldn't start after a reboot and I had no keyboard control. Spent many hours trying to resolve this to no avail. From that experience, it appears that braille support is still deeply embedded in 3.1 and given it's significant presence in the current VM logs, I suspect it may be involved this time as well.

Being unable to run a Devuan VM under VirtualBox on a Devuan host is a severe limitation that will hamper uptake of the OS for approaches like https://www.qubes-os.org/ where the goal is to containerize user application spaces for improved security and crash recovery. I'd like to file a bug to document the issue, but don't see a link on the main site. Would the devuan-dev list be the best place to start?

Thanks again for your replies,

-Tom

Offline

#6 2021-03-12 05:18:50

golinux
Administrator
Registered: 2016-11-25
Posts: 2,179  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

There is some discussion of a similar issue here

Online

#7 2021-03-12 07:42:29

netdxr
Member
Registered: 2017-04-23
Posts: 4  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

Thanks very much for your referral to that thread.

I've been instinctively selecting console-productivity during my installs without realizing it was bringing in braille support. After doing a re-install without it, the second VM display comes up and the system is stable. smile

Hope this thread will help anyone else who's encountered this issue... and now that it's resolved, I can start making even broader use of my favorite OS!

Thanks again,

-Tom

Offline

#8 2021-03-12 07:59:12

golinux
Administrator
Registered: 2016-11-25
Posts: 2,179  

Re: [SOLVED] Dual monitor VM issues with VirtualBox on 3.1.0

That's really good news!  You did not specify which iso you used.  If you used the minimal-live (which sounds like a good idea) you missed the description on the download page:

A full-featured, console-based recovery tool with a focus on accessibility for visually-impaired and blind users.

We made a special effort to serve that community which is a good thing.  In any case, really happy that it worked out for you.  I will mark this as solved then.

Online

Board footer