The officially official Devuan Forum!

You are not logged in.

#1 2021-02-13 02:51:47

beate
Member
Registered: 2019-03-25
Posts: 17  

php-fpm in chimaera current

I'm just trying to set up nginx and php-fpm on a machine running a freshly updated chimaera.
PHP version is 7.4.15-1

And this because the recent php-fpm has a dependcy on systemd (which seems to have been correct in a previous version of chimaera still offering php 7.3 - that machine actually runs beowulf and the upgrade failed because the vserver still has a 2.6 kerne (and hence i would like to go back to beowulf)).


Do i need to recompile php or is there any way to get back to the php 7.3-packaged of chimaera (i need that asap, and can live with any version of php since the latest 5.6
...)

Offline

#2 2021-02-13 03:14:33

golinux
Administrator
Registered: 2016-11-25
Posts: 2,171  

Re: php-fpm in chimaera current

Offline

#3 2021-02-13 10:43:06

beate
Member
Registered: 2019-03-25
Posts: 17  

Re: php-fpm in chimaera current

Gives some insight into the situation - but the alternative packages still seem beowulf only. Which would be an option after reverting the switch to chimaera on the 2nd machine (which is stuck to the 2.6 kernel anyway) bot not for now. But many thanks.

Last edited by beate (2021-02-13 11:19:33)

Offline

#4 2021-02-20 14:34:44

mckaygerhard
Member
Registered: 2017-04-21
Posts: 275  
Website

Re: php-fpm in chimaera current

beate wrote:

Gives some insight into the situation - but the alternative packages still seem beowulf only. Which would be an option after reverting the switch to chimaera on the 2nd machine (which is stuck to the 2.6 kernel anyway) bot not for now. But many thanks.

that's why beowullf is debian 10 and chimaera is debian 11 (Bullseye) as always devuan related does not are at top of the problems related to shitstemd..

in my repository i am currently refined and tuned the  @tdenetworks packages.. cos he only removes the build flags but the se4rvice still are there, also there's no chimaera builds.. (debian 11) so check https://build.opensuse.org/project/moni … i:lamp-vnx for uncoming 7.4 php package in next week (will arrive late cos i'm backporting, after that rebuilds are easy to follow the sury's crap)

Offline

Board footer