The officially official Devuan Forum!

You are not logged in.

#1 2019-04-30 16:47:26

Eeqmcsq
Member
Registered: 2017-09-19
Posts: 12  

Devuan Jessie: Many packages moved to local/obsolete

On my Devuan Jessie PC, many packages have been moved to the Installed (local or obsolete) status, such as apache2, openssh-client, perl, python, samba, tar.

The problem appears to be caused by a Packages file containing older versions of these packages:

http://deb.devuan.org/merged/dists/jess … ackages.gz
Last modified date: 2019-04-30 05:17
size: 8.7M

For example, apache2: My installed apache2 version is "2.4.10-10+deb8u14", but the Packages file version is "2.4.10-10+deb8u12". Any idea what's going on?

Package: apache2
Version: 2.4.10-10+deb8u12
Installed-Size: 527
Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
Architecture: amd64
Replaces: apache2.2-common, libapache2-mod-macro (<< 1:2.4.6-1~)
Provides: httpd, httpd-cgi
Depends: lsb-base, procps, perl, mime-support, apache2-bin (= 2.4.10-10+deb8u12), apache2-utils (>= 2.4), apache2-data (= 2.4.10-10+deb8u12)
Conflicts: apache2.2-common (<< 2.3~)
Pre-Depends: dpkg (>= 1.17.14)
Breaks: libapache2-mod-macro (<< 1:2.4.6-1~)
Homepage: http://httpd.apache.org/
Recommends: ssl-cert
Description: Apache HTTP Server
Description-md5: d02426bc360345e5acd45367716dc35c
Suggests: www-browser, apache2-doc, apache2-suexec-pristine | apache2-suexec-custom
Tag: role::metapackage, suite::apache
Section: httpd
Priority: optional
Filename: pool/DEBIAN/main/a/apache2/apache2_2.4.10-10+deb8u12_amd64.deb
Size: 208468
MD5sum: 0c54378f55125582eae37c07bdaab8d5
SHA1: 1c3ece302d94bc854abd1859edcdd713dbd91ebd
SHA256: a7890679b519b12578b8fe3485a2a235c8f2d5ee9f6b045e5e218aff9fef1da5

Offline

#2 2019-04-30 19:08:19

rolfie
Member
Registered: 2017-11-25
Posts: 175  

Re: Devuan Jessie: Many packages moved to local/obsolete

Possible that archiving Wheezy/Jessie about a month ago is causing issues now for packages pulled from Debian?

Rolf

Offline

#3 2019-05-31 03:02:57

Eeqmcsq
Member
Registered: 2017-09-19
Posts: 12  

Re: Devuan Jessie: Many packages moved to local/obsolete

I don't know who fixed what, but the packages that got moved to local/obsolete appears normal again. Thanks to whoever it was.

Looks like /jessie/main/binary-amd64/Packages is supposed to say that apache2 version is "2.4.10-10+deb8u12". It's actually /jessie-security/main/binary-amd64/Packages that says apache2 version is "2.4.10-10+deb8u14". Something must have happened in jessie-security a month ago, but has been fixed within the past week.

Offline

#4 2019-05-31 04:21:54

golinux
Administrator
Registered: 2016-11-25
Posts: 1,677  

Re: Devuan Jessie: Many packages moved to local/obsolete

Yes, finally some action today thanks to parazyd.  I had 73 updates waiting after I updated.

Offline

Board footer