The officially official Devuan Forum!

You are not logged in.

#1 2019-02-08 22:19:46

inukaze
Member
Registered: 2018-01-28
Posts: 84  

[SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Hi there, from 3 days ago i start to upgrade my distro version from Jessie to ASCII (Equivalent to Stretch).

I had the follow problems.
1 - Xorg start but slim does not (this is from jessie)
2 - i got new errors during boot like

[   12.537779] udevd[748]: starting version 3.2.2
[   13.140482] udevd[748]: invalid key/value pair in file /etc/udev/rules.d/20-mm-blacklist-mtk.rules on line 1, starting at character 1 ('A')
[   13.140558] udevd[748]: invalid key/value pair in file /etc/udev/rules.d/20-mm-blacklist-mtk.rules on line 2, starting at character 1 ('A')
[   13.144445] udevd[748]: invalid key/value pair in file /lib/udev/rules.d/20-virtualbox2.rules on line 1, starting at character 1 ('K')
[   13.144508] udevd[748]: invalid key/value pair in file /lib/udev/rules.d/20-virtualbox2.rules on line 2, starting at character 1 ('K')
[   13.144569] udevd[748]: invalid key/value pair in file /lib/udev/rules.d/20-virtualbox2.rules on line 3, starting at character 1 ('K')
[   14.125919] udevd[748]: invalid key/value pair in file /etc/udev/rules.d/80-persistent-usb.rules on line 1, starting at character 1 ('S')
[   14.334126] udevd[749]: starting eudev-3.2.2

content of "/etc/udev/rules.d/20-mm-blacklist-mtk.rules"

ATTRS{idVendor}==0e8d, ENV{ID_MM_DEV ICE_IGNORE}=1
ATTRS{idVendor}==6000, ENV{ID_MM_DEV ICE_IGNORE}=1

content of "/lib/udev/rules.d/20-virtualbox2.rules"

KERNEL==vboxdrv, NAME=vboxdrv, OWNER=root, GROUP=vboxusers, MODE=0660
KERNEL==vboxdrvu, NAME=vboxdrvu, OWNER=root, GROUP=vboxusers, MODE=0660
KERNEL==vboxnetctl, NAME=vboxnetctl, OWNER=root,GROUP=vboxusers, MODE=0660

content of "/etc/udev/rules.d/80-persistent-usb.rules"

SUBSYSTEM==usb, ACTION==add, ATTR{idVendor}==0e8d, ATTR{idProduct}==*

How i must write for be compatible?

The another thing is trying to solve the audio output, right now i had just "output : dummy"
because the error "ALSA error: snd_pcm_open failed: Dispositivo o recurso ocupado."

i try the follow :

cp /etc/pulse/default.pa  ~/.config/pulse/default.pa

and comment the lines

### Load several protocols
#.ifexists module-esound-protocol-unix.so
#load-module module-esound-protocol-unix
#.endif

well i think is better delete this last file.

But i really need to repair the slim don't start automatically before Xorg.

Last edited by inukaze (2019-02-21 13:47:56)

Offline

#2 2019-02-08 22:25:05

golinux
Administrator
Registered: 2016-11-25
Posts: 1,709  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Have you read the ASCII release notes?

Offline

#3 2019-02-08 23:50:09

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Ok wtf i had purge the follow packages :

 su -c "apt-get purge alsa-firmware-loaders alsa-oss alsa-tools alsa-utils apulse apulse-dbgsym gstreamer1.0-alsa libalsaplayer0 libclalsadrv2 libpulse-java libpulse-jni libpulsedsp libsox-fmt-alsa libsox-fmt-base libsox-fmt-mp3 libsox-fmt-pulse python-alsaaudio python-pyalsa sox tuxguitar-alsa volumeicon-alsa libroar2 mpd gstreamer0.10-pulseaudio gstreamer1.0-pulseaudio libcanberra-pulse pavucontrol-qt phonon-backend-gstreamer pulseaudio pulseaudio-equalizer pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-utils xfce4-pulseaudio-plugin speech-dispatcher speech-dispatcher-audio-plugins speech-dispatcher-espeak speech-dispatcher-espeak-ng pulseaudio-module-zeroconf paprefs pulseaudio-module-raop" root 

i remove all custom files and anothers temporal files with the follow commands :

 su -c "rm -rf /tmp/.esd-1000 ; rm -r /home/inukaze/.pulse* ; rm -rf /home/inukaze/.config/pulse sudo rm -rf /home/inukaze/.asoundrc" root 

i restart and right now, slim start before Xorg

After i login again to my desktop environtment i installed the follow packages

 su -c "apt-get install -y alsa-firmware-loaders alsa-oss alsa-tools alsa-utils libalsaplayer-dev libalsaplayer0 (0.99.81-2)
libclalsadrv-dev libclalsadrv2 python-alsaaudio python-pyalsa volumeicon-alsa" root 

i had started the "volume icon" i fill up the volume meter to 100% and i had working sound.

Well, the unique thing i must solve right now its the lines with bad format i ask before

Offline

#4 2019-02-08 23:56:45

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

golinux wrote:

Have you read the ASCII release notes?

Ready, i had already read the article. i purge elogin and i had installed consolekit , because i use xfce. but i change slim by lxdm

Offline

#5 2019-02-09 02:22:32

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 371  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

How i must write for be compatible?

Use double-quotes around the values.

Offline

#6 2019-02-09 04:30:59

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

ralph.ronnquist wrote:

How i must write for be compatible?

Use double-quotes around the values.

Thank you very much

Offline

#7 2019-02-09 04:47:22

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

When i install or upgrade packages i saw the follow :

insserv: warning: script 'noip2.rc' missing LSB tags and overrides
insserv: warning: script 'noip2' missing LSB tags and overrides
insserv: script noip2: service noip2 already provided!
insserv: warning: script 'savecache' missing LSB tags and overrides

How i should do to solve it ?

From the dmesg :

[   20.496462] nvidia: loading out-of-tree module taints kernel.
[   20.496486] nvidia: module license 'NVIDIA' taints kernel.

well for this i am reinstalling all my nvidia packages, for try solve it

i think this is i upgrade the distro and the version loaded of linux was diferent from current, and becuase of that the dkms don't make fine the modules needs for the system, becuase i open smplayer i and not have any video drive for output just "default"

Offline

#8 2019-02-09 05:40:10

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Well i solve the message :

insserv: warning: script 'noip2.rc' missing LSB tags and overrides
insserv: warning: script 'noip2' missing LSB tags and overrides
insserv: script noip2: service noip2 already provided!
insserv: warning: script 'savecache' missing LSB tags and overrides

just adding for example :

### BEGIN INIT INFO
# Provides:          noip2
# Required-Start:    $local_fs $network
# Required-Stop:     $local_fs
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: noip2
# Description:       Start/stop The NOIP Daemon"
### END INIT INFO

below the first line

#!/sbin/openrc-run

in the custom file -> /etc/init.d/noip2

and well removing the unnecesary files

su
insserv -r /etc/init.d/noip2.rc
rm -rf noip2.rc
insserv

Offline

#9 2019-02-09 06:43:29

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

when i restart i extract the dmesg output i see this messages :

[    1.291610] udevd[73]: Error running install command for nvidia
[   15.046814] udevd[723]: invalid key/value pair in file /etc/udev/rules.d/20-mm-blacklist-mtk.rules on line 1, starting at character 22 (',')
[   15.046889] udevd[723]: invalid key/value pair in file /etc/udev/rules.d/20-mm-blacklist-mtk.rules on line 2, starting at character 22 (',')
[   17.035514] udevd[791]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:02.1/usb1/1-9 1 3': No such file or directory

i am worry about "nvidia"

The content of /etc/udev/rules.d/20-mm-blacklist-mtk.rules right now is :

ATTRS{vendor}=="0e8d", ENV{ID_MM_DEV ICE_IGNORE}="1"
ATTRS{vendor}=="6000", ENV{ID_MM_DEV ICE_IGNORE}="1"

i really don't understand what need udev for stop that errors

How i do reduce the verbosity of OpenRC boot for example this messages

Executing: /lib/rc/sh/openrc-run.sh /lib/rc/sh/openrc-run.sh /etc/init.d/hostname.sh start

i dont want show it

Offline

#10 2019-02-09 07:53:34

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 371  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

i really don't understand what need udev for stop that errors

You need fewer spaces wink

Offline

#11 2019-02-09 19:53:45

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

ralph.ronnquist wrote:

i really don't understand what need udev for stop that errors

You need fewer spaces wink

Where, can you explain me please. because i compare with another files of rules from udev, and have the same format and are wrote in the same way. but that 2 files gave me errors, but the anothers don't

Offline

#12 2019-02-09 20:01:34

rolfie
Member
Registered: 2017-11-25
Posts: 175  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Instead of:

inukaze wrote:

The content of /etc/udev/rules.d/20-mm-blacklist-mtk.rules right now is :

ATTRS{vendor}=="0e8d", ENV{ID_MM_DEV ICE_IGNORE}="1"
ATTRS{vendor}=="6000", ENV{ID_MM_DEV ICE_IGNORE}="1"

use:

ATTRS{vendor}=="0e8d", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{vendor}=="6000", ENV{ID_MM_DEVICE_IGNORE}="1"

See the difference? Udev is not exactly pointing to the error, its just complaining that its failing.

Regards, Rolf

Offline

#13 2019-02-10 18:17:14

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

rolfie wrote:

use:

ATTRS{vendor}=="0e8d", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{vendor}=="6000", ENV{ID_MM_DEVICE_IGNORE}="1"

See the difference? Udev is not exactly pointing to the error, its just complaining that its failing.

Regards, Rolf

Thanks i really don't notice that space LOL jajaja xD the last things i see in red from dmesg output are :

[    1.274358] udevd[83]: Error running install command for nvidia
[   16.295130] udevd[798]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:02.1/usb1/1-9 1 3': No such file or directory

what is need for solve "Error running install command for nvidia" ?

i know the another error of mtp-probe have an ease solution, just installing the package named "libmtp-runtime"

and the last thing i need right now is reduce verbosity of openrc during boot [solved] (just editing the file /etc/rc.conf and set rc_verbose=no)

VirtualBox Error :

Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
One of the kernel modules was not successfully loaded. Make sure that no kernel modules from an older version of VirtualBox exist. Then try to recompile and reload the kernel modules by executing '/sbin/vboxconfig' as root (VERR_SUPDRV_COMPONENT_NOT_FOUND).

ever i must run after every restart :

/sbin/vboxconfig

because things like ethernet don't work because on every restart the modules for linux are deleted
how i can make the result of execute /sbin/vboxconfig be permanent?

Last edited by inukaze (2019-02-11 21:33:48)

Offline

#14 2019-02-13 16:14:04

rolfie
Member
Registered: 2017-11-25
Posts: 175  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

Are you using VBox from the Devuan repository or the Oracle version?

In any case, make sure you have build-essential, dkms and the headers for your kernel installed. Then missing modules should be no problem.

Good luck, Rolf

Offline

#15 2019-02-14 03:36:39

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

for ascii i don't have devuan version of virtualbox, i am using the oracle version 6.0.4 right now.

i already have headers, kernel-source, dkms, build-essential, automoc, automake, etc . . .
but i had purge the package and reinstalled again, and ever is the same, every time i restart
i must run /sbin/vboxconfig for make modules to enable the start of my virtual machines.

Offline

#16 2019-02-21 13:47:04

inukaze
Member
Registered: 2018-01-28
Posts: 84  

Re: [SOLVED]I had upgrade Jessie to Ascii and i need some fixes.[SOLVED]

i found a solution for the virtualbox thing, is very simple for me :

sudo /sbin/vboxconfig
sudo nano /etc/modules

(Add to the end of the file the follow lines) :

#VirtualBox :
# /sbin/vboxconfig , generate this file -> /lib/modules/4.9.0-8-amd64/misc/vboxnetflt.ko but is not autoloaded during boot
vboxnetflt

On my case the file of kernel module /lib/modules/4.9.0-8-amd64/misc/vboxnetflt.ko is not loaded during boot, and because of that, show me the error

Failed to open/create the internal network 'HostInterfaceNetworking-eth0' (VERR_SUPDRV_COMPONENT_NOT_FOUND).
Failed to attach the network LUN (VERR_SUPDRV_COMPONENT_NOT_FOUND).
One of the kernel modules was not successfully loaded. Make sure that no kernel modules from an older version of VirtualBox exist. Then try to recompile and reload the kernel modules by executing '/sbin/vboxconfig' as root (VERR_SUPDRV_COMPONENT_NOT_FOUND).

Offline

Board footer