The officially official Devuan Forum!

You are not logged in.

#1 2024-05-20 11:41:59

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

[SOLVED] No exit from sleep after devuan installation

After installing Daedalus everything seemed to be running smooth, except when the computer 'sleeps'. after the screen has turned off I cannot get in to the computer again unless I restart it. The computer is on as lights are still on, though I am unable to wake up the screen. Anyone have any idea why this is happening and/or what I might do to fix it?

Offline

#2 2024-05-20 12:24:23

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

This is what helped me -

https://askubuntu.com/questions/848698/ … usb-device

In short, you identify the usb devices in use and then add an entry to /etc/rc.local.

A better write-up as it pertains to devuan is located here:  https://dev1galaxy.org/viewtopic.php?id=5973

Hope this helps.

Offline

#3 2024-05-20 18:21:36

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

Thank you. I had to make a merge of the different sources, because this command didn't work for me:

grep . /sys/bus/usb/devices/*/product

I added this to /etc/rc.local:

echo enabled > /sys/bus/usb/devices/usb1/power/wakeup
echo enabled > /sys/bus/usb/devices/usb2/power/wakeup
echo enabled > /sys/bus/usb/devices/usb3/power/wakeup
echo enabled > /sys/bus/usb/devices/usb4/power/wakeup
echo enabled > /sys/bus/usb/devices/usb5/power/wakeup
echo enabled > /sys/bus/usb/devices/usb6/power/wakeup
echo enabled > /sys/bus/usb/devices/usb7/power/wakeup
echo enabled > /sys/bus/usb/devices/usb8/power/wakeup

In devices I have folders with numbers and usb1-8.   
I added sleep 30 first as I also use Daedalus. The whole block I put first in rc.local.

There is no change. Maybe I misunderstood some step.

Last edited by tyrlak (2024-05-21 08:19:19)

Offline

#4 2024-05-20 20:04:13

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

The command that did not work, did it produce any output at all?  I used these commands as user, but I don't think it would harm anything to run this as root.  I ran the command on my system as root and it produced the same desired output. 

I have used this on several systems - desktop, laptops, etc. - and it always listed all usb devices so that you could use the exact information to add to the rc.local file.  For example, the information that you added to the rc.local file does not look right.  For example, my usb devices are not listed as usb1, usb2, and so on, but rather, it lists them as 1-5, 1-6, etc. And from this I can choose the keyboard and mouse devices from the others that will not be used to wake the system up.

Granted, this is mentioned to wake from suspend and hibernate, but I have also used it to fix a situation just like yours - waking the monitor up.

Offline

#5 2024-05-20 20:06:04

golinux
Administrator
Registered: 2016-11-25
Posts: 3,229  

Re: [SOLVED] No exit from sleep after devuan installation

Note that Daedalus is not "Dead----". This is important for those doing a search of this forum. I corrected your first post earlier but perhaps you could correct the spelling in the post immediately above? Thanks!

Offline

#6 2024-05-20 20:53:01

rolfie
Member
Registered: 2017-11-25
Posts: 1,113  

Re: [SOLVED] No exit from sleep after devuan installation

Maybe it would make sense to first check the basics: the Engergy Settings on your desktop?

Which DE are you using? How have you configured the Energy Settings?

Online

#7 2024-05-21 08:22:57

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

nixer, I don't think there was any output but will check again. 
rolfie, what is DE? and could you share how I can configure energy settings? this is all new to me.

Thank you for your support <3

Offline

#8 2024-05-21 10:15:18

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

DE is desktop environment - Xfce, KDE, Mate, etc.  The energy settings are usually located in the menu.  For example, Menu > Settings > Power Manager in Xfce.

Offline

#9 2024-05-21 10:53:59

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

aha okey, so it is set to not turn off screen rn (tho this happened anyway) and hibernate after 2h of inactivity. I chose that the power button to have no function.
On another computer with Daedalus this

grep . /sys/bus/usb/devices/*/power/wakeup

works perfectly.

On the one in questions there appears a small white square on the line under the command and it is stuck there and nothing happens.

In the device folder I have folders:

1-0:1.0, 1-3.1, 1-3.2, 1-5, 2-0:1.0, 3-1, 3-1:1.1, 3-1:1.3, 4-0:1.0, 6-0:1.0, 8-0:1.0, 1-3, 1-3:1.0, 1-3:1:1.1, 1-3:2:1.0, 1-5:1.0, 3-0:1.0, 3-1:1.2, 3-1:1.4, 5-0:1.0, 7-0:1.0 and usb1, usb2, usb3, usb4, usb5, usb6, usb7, usb8

Last edited by tyrlak (2024-05-21 10:54:39)

Offline

#10 2024-05-21 11:10:45

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

The folder names under /sys/bus/usb/devices/ is correct and normal, but I don't have a clue what is causing that small white square under the command.  Is grep installed on that machine?  If not, I would think that it would throw an error.

As root, run this command to see if grep is installed.

apt policy grep

Offline

#11 2024-05-21 12:59:34

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

I have grep 3.8-5

I entered these folders and checked wakeup: 1-3.1, 1-3.2, 1-5, 1-3

They are all disabled. The others to not have wakeup, their structure is different.

so I changed to these in rc.local with the sleep 30, but it didn't work.

Last edited by tyrlak (2024-05-21 13:49:18)

Offline

#12 2024-05-21 13:47:09

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

Yes, and the purpose of this command is to specify the information to add to the /etc/rc.local file

grep . /sys/bus/usb/devices/*/product

Which in my case lists these two devices which are my usb mouse and keyboard so that I can use either one to wake the system.

/sys/bus/usb/devices/1-5/product:USB Receiver
/sys/bus/usb/devices/1-6/product:USB Receiver

Note the "1-5" and "1-6" which is necessary information to add to the rc.local file.  I do not know why this command is not working for you, and I can't think of anything else to try.  If you were to manually change these while in a running state and save the changes, it may work until a reboot.  Upon rebooting, the changes would revert back to their original settings... hence is is necessary to have this in the rc.local file so that it gets set right when booting. 

There is also a way to do this by way of a bash script, but the rc.local way was easier, and both ways need the same command to be run to set the information correctly.  So this way would not help either.

Offline

#13 2024-05-21 15:07:35

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

Out of these

1-3.1, 1-3.2, 1-5, 1-3

1-5 is Goodix USB2.0 MISC 
1-3 is USB2.0 Hub
1-3.2 EMV Smartcard reader
1-3.1 doesn't have "product" but searching with idProduct number 9309 it seems to be connected to bluetooth.

Is any of the first two useful in this issue?

Last edited by tyrlak (2024-05-21 15:08:10)

Offline

#14 2024-05-21 16:10:43

nixer
Member
From: North Carolina, USA
Registered: 2016-11-30
Posts: 204  

Re: [SOLVED] No exit from sleep after devuan installation

Is any of the first two useful in this issue?

I do not know.  On my system, it listed a total of about 7-8 devices.  All but two of them had the hardware names of the device so it made it easy to know which two were the keyboard and mouse.

Offline

#15 2024-05-22 16:12:53

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

I have probably the same or similar issue. Sometimes after suspend (xfce4-session-logout or pm-suspend script) desktop freeze or blank and everything stops. It occurs somehow randomly.

Today at given freeze, after resuming, I ttyed with root to htop to see what was going on, selected sort by MEM and found out this:

xfwm4 --display :0.0 --sm-client -id [alfanumeric-value-blahblah]

I stopped this service and all --sm-client other related stuffs and everything worked back on the main tty sys.

And now the problem has just stopped for a while... I don't know let's see if it comes back later.

So what could it be? Too old hardware?? Services not stopping or delaying??

I didn't install any additional xscreensaver theme or else, I have just what was in the iso.

Maybe this helps out

Offline

#16 2024-05-22 22:06:44

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,190  

Re: [SOLVED] No exit from sleep after devuan installation

@tyrlak, make sure your xserver-xorg-core and xserver-common packages are version 2:21.1.7-3+deb12u5devuan1 from devuan-security.

Offline

#17 2024-05-23 10:19:09

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

I can confirm that: on freeze ttying htop and stopping just

xfwm4 --display :0.0 --sm-client -id [alfanumeric-value-blahblah]

in my case works.

But randomly the freeze reoccurs (a bit less frequently), even though I can not explain why I noticed on boot a NFS error which adresses another id related problem, could this be something?

I don't have u5 version of xserver packages but I have u2 and u7 from daedalus-security.

Do I have to change to devuan-security to find out them?

Offline

#18 2024-05-23 11:02:06

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

I checked the versions of xserver-xorg-core and xserver-common and they are correct. How do I access devuan security?

I couldn't see anything like what you described DevNUp, so didn't know how I could apply/test this.

Offline

#19 2024-05-23 11:27:28

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

Let me understand...

Either you can't use at all the monitor after suspend, or you see and move a mouse with black screen and nothing else.

If the second case: I was the same as you untill I reduced the power manager do almost nothing but  pop the screensaver and suspend instead of hibernate. After that I got finally the desktop but freezed up every time I came back from a sleep state. Then I did the search in a different tty with htop to find out the problem (which I have not managed to solve anyway, I just do this every freeze).

If the first case (Monitor unaccessible): that is not my case. Mine was as described.

For now is just this. I'm on a old 32 bit desktop, so I thought maybe a hardware related issue.

Offline

#20 2024-05-24 08:10:26

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

It's the first one you mentioned. When I use the keyboard a light on the keyboard indicate that my typing (doing something) caused a reaction. However, using the keyboard doesn't lead to the screen turning on. It's the same with mouse and power button.

Offline

#21 2024-05-24 10:02:23

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

So i looked upon and found out your laptop seems to have issues with ACPI.

Are you on xfce?

If yes (and if it is a xfwm4 related problem like mine is) the only process of xfwm4 present is the one I mentioned above. For me it solves the problem and I can get it to sleep many times before it reoccurs. I agree it has to do with peripherals (usb probably), I'm not an expert, and for now it is good like this.

I would try to automate a killing of that process while suspending the system. That 's the only thing I can tell you.

Offline

#22 2024-05-24 12:08:52

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

Thank you for supporting me in finding a solution, I appreciate it a lot. I am using gnome, but have the option to switch and try other desktops if needed.

Offline

#23 2024-05-24 13:41:13

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

Well... if I am here trying solve a vital problem without running away is because I like this project, so as long as I have time and this is also helping others I'm happy with that.

I've never looked into gnome. Maybe you can instal xfce4, it wont do any bad. You can than follow that xfwm4 problem above, and see.

Gnome AFAIK is not so happy with wildly killing processes to test or solve things but I don't know much of it.

Offline

#24 2024-05-27 16:36:22

DevNUp
Member
Registered: 2024-05-22
Posts: 6  

Re: [SOLVED] No exit from sleep after devuan installation

Some progress

[    3.746627] ACPI Warning: SystemIO range 0x00000000000004B0-0x00000000000004BF conflicts with OpRegion 0x0000000000000480-0x00000000000004BF (\_SB.PCI0.SBRG.SIOR.GPIO) (20220331/utaddress-204)
[    3.746637] ACPI: OSL: Resource conflict; ACPI support missing from driver?
[    3.746639] ACPI Warning: SystemIO range 0x0000000000000480-0x00000000000004AF conflicts with OpRegion 0x0000000000000480-0x00000000000004BF (\_SB.PCI0.SBRG.SIOR.GPIO) (20220331/utaddress-204)
[    3.746644] ACPI: OSL: Resource conflict; ACPI support missing from driver?
[    3.746645] lpc_ich: Resource conflict(s) found affecting gpio_ich

This has gone away after I run Xorg -configure, copied xorg.conf to /etc/X11 (it was probably not there for obvious "suggested" things) and after having set modesetting in Device=intel and after having removed xorg-input-video-driver rebooted... prompt. No slim login, good!!!

Reinstalled xorg driver mentioned, logged in, and it goes some sort of broken hybernate instead of suspend.

Than I checked the dmesg. ACPI warning gone. Perfect. Went to remove xorg.conf, rebooted, suspend, and if I plug in something usb flavored device going away for say 30 min I gotta kill xfw4. And its good. Better than suggested. I kinda like it. For me it is solved, don't know exactly what I did but... mmm

Last edited by DevNUp (2024-05-27 16:37:22)

Offline

#25 2024-06-19 08:51:28

tyrlak
Member
Registered: 2024-04-26
Posts: 24  

Re: [SOLVED] No exit from sleep after devuan installation

SOLVED: This was the solution

- I clones this repo:  https://gitlab.com/kernel-firmware/linux-firmware.git
- I copied the amdgpu folder here --> /lib/firmware

Hope this can help someone else with this issue. Thank you everyone for your amazing support<3

Offline

Board footer