The officially official Devuan Forum!

You are not logged in.

#1 2021-10-21 01:09:56

Altoid
Member
Registered: 2017-05-07
Posts: 913  

Devuan 4 Chimaera / SLiM and WiCD

Hello:

I have just been reading Devuan 4 Chimaera Release Notes and saw two things that called my attention:

1.

Note that slim (the default Display Manager for xfce) is not
accessible. Be sure to install lightdm or gdm3 if you require an
accessible Display Manager.

Q: why is this so?
It works perfectly well in Beowulf, why not in Chimaera?

The Devuan Package Information page says it is available for chimera, daedalus and ceres:

slim
1.3.6-5.2+devuan1
http://deb.devuan.org/merged  ceres/main amd64
http://deb.devuan.org/merged  daedalus/main  amd64
http://deb.devuan.org/merged chimaera/main amd64

2.
wicd

Wicd is no longer available in Devuan 4 Chimaera having been removed
from Debian Bullseye because of it's dependency on python2 which is now
obsolete.

I have always liked wicd, other conneciton managers I tried gave me endless grief.

I think I have other applications that depend on python2 ...

Thanks in advance,

A.

Offline

#2 2021-10-21 01:58:15

golinux
Administrator
Registered: 2016-11-25
Posts: 2,357  

Re: Devuan 4 Chimaera / SLiM and WiCD

Altoid wrote:

Note that slim (the default Display Manager for xfce) is not
accessible.

Q: why is this so?

I believe that relates to accessibility features for the visually impaired.  If I weren't so lazy, I would actually read the Release Notes to confirm.

Wicd is no longer available in Devuan 4 Chimaera having been removed
from Debian Bullseye because of it's dependency on python2 which is now
obsolete.

Someone on the team is attempting to port it to python3.  Keep your fingers crossed.

Offline

#3 2021-10-21 02:52:40

Altoid
Member
Registered: 2017-05-07
Posts: 913  

Re: Devuan 4 Chimaera / SLiM and WiCD

Hello:

golinux wrote:

... believe that relates to accessibility features ...

Ahh ...
That accessibility.

Thanks for clearing that up for me.
So many things one takes for granted in life ...  8^|

golinux wrote:

Someone on the team is attempting to port it to python3.

Good to know.

The Devuan Package Information page shows this:

wicd
1.7.4+tb2-6+devuan2
http://deb.devuan.org/merged  chimaera-proposed-updates/main amd64
http://deb.devuan.org/merged  chimaera-proposed-updates/main i386
http://deb.devuan.org/merged  chimaera-proposed-updates/main arm64
http://deb.devuan.org/merged  chimaera-proposed-updates/main ppc64el

And the wicd home page says:

Awaking from deep sleep
Written for wicd by Andreas Messer on 2021-10-14

The wicd project has been in state of deep sleep for a while now while Python, GTK continue to develop. I'm trying to get it back on track. This will need several major changes to its code base and will take some time.

The previous entry in the Announcements was from 2014-12-21, almost seven years ago.
Seems more like a coma than deep sleep.

I'm in no hurry to leave Beowulf, so I can wait.

Thanks for the heads-up.

Best,

A.

Offline

#4 2021-11-09 04:38:48

ToxicExMachina
Member
Registered: 2019-03-11
Posts: 210  

Re: Devuan 4 Chimaera / SLiM and WiCD

Python3 port of wicd is already in Debian experimental repository.

Anyway removing python2 from every distro is grave mistake because it makes python a terrible choice for long term development.

Offline

#5 2021-11-09 07:42:13

rolfie
Member
Registered: 2017-11-25
Posts: 583  

Re: Devuan 4 Chimaera / SLiM and WiCD

Also SLIM is no more maintained since 7 or 8 years now. Its sort of deprecated. Lightdm is working fine (for me at least).

rolfie

Online

#6 2021-11-09 11:31:07

Altoid
Member
Registered: 2017-05-07
Posts: 913  

Re: Devuan 4 Chimaera / SLiM and WiCD

Hello:

rolfie wrote:

... SLIM is no more maintained ...
... sort of deprecated.

For the longest time more or less the same was said of Xorg-server.
But there it is, born again so to speak.

https://xorg.freedesktop.org/archive/in … 1.1.tar.gz

Reminds me of reports of deaths being greatly exaggerated ...  8^D

This thanks to someone (Povilas Kanapickas) who stepped up.
And despite this dumb Python2 decision, I believe Wicd will also survive.

Apparently SLiM (ArchWiki) it is not fully compatible with systemd, including logind sessions.

It is an excellent example of Linux philosophy, I like it much more than any of the other DMs I have tried.
ie: lightweight, easy to configure, requires minimal dependencies and is independent of the DE: ticks all the boxes.

SLiM works for me on Devuan so that's what I use.
I recall that installing SLiM solved all the auth/log-in issues I was having in Devuan by not having a DM.

--> I think it should be the default Devuan DM.

I have read that GhostBSD 10.3 dropped GDM in favour of SLiM back in 2016 and is still there.
See http://www.ghostbsd.org/10.3_enoch

Hopefully someone will eventually step up and update it so it can be used with non-systemd distributions.

Use a systemd distro?
Then use one of those other bloated DMs.

If I cannot have it in the future, I'll just opt for not using a DM and see how I manage to work things out.

Best,

A.

Last edited by Altoid (2021-11-09 12:43:20)

Offline

Board footer