The officially official Devuan Forum!

You are not logged in.

#1 2021-09-22 05:56:30

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Devuan and LEMP. PHP 7.4+?

Hello! I migrated from Debian 9 to Devuan 3. I hasn't any glodal problems, but unable to update php to 7.4. Anybody can help?

Offline

#2 2021-09-22 06:13:29

golinux
Administrator
Registered: 2016-11-25
Posts: 2,319  

Re: Devuan and LEMP. PHP 7.4+?

It looks like it's available for chimaera (bullseye) and/or ceres (sid):
https://pkginfo.devuan.org/cgi-bin/poli … 4&x=submit

There are also rebuilds for beowulf here:
https://dev1galaxy.org/viewtopic.php?pid=30493#p30493

Offline

#3 2021-09-22 06:37:30

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Re: Devuan and LEMP. PHP 7.4+?

/etc/apt/sources.list:
# webmin
deb http://download.webmin.com/download/repository/ sarge contrib

deb http://deb.devuan.org/merged beowulf main
deb http://deb.devuan.org/merged beowulf-updates main
deb http://deb.devuan.org/merged beowulf-security main

Offline

#4 2021-09-22 09:42:47

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Re: Devuan and LEMP. PHP 7.4+?

I didn't found php7.4-memcached, php7.4-msgpack, php7.4-igbinary and php7.4-imagick there sad

Offline

#5 2021-09-22 16:44:26

macondo123
Member
From: Panama
Registered: 2017-09-23
Posts: 20  

Re: Devuan and LEMP. PHP 7.4+?

Probably in Testing  or Ceres (Sid)

Offline

#6 2021-09-23 03:08:36

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Re: Devuan and LEMP. PHP 7.4+?

It recommended for NextCloud (or for WordPress, I don't remember smile)

Last edited by Aleksanders (2021-09-23 03:09:08)

Offline

#7 2021-09-23 05:07:21

steve_v
Member
Registered: 2018-01-11
Posts: 105  

Re: Devuan and LEMP. PHP 7.4+?

Aleksanders wrote:

It recommended for NextCloud

I'm running nextcloud on beowulf, with PHP 7.4.
The trick is that pkgs.tdrnetworks doesn't include everything, so you'll need packages.sury.org in your sources as well, i.e.

deb https://packages.sury.org/php/ buster main
deb https://pkgs.tdrnetworks.com/apt/devuan beowulf main

You'll likely also want something like:

Package: *
Pin: release o=deb.sury.org
Pin-Priority: 200

(or any priority lower than that assigned to tdrnetworks) in /etc/apt/preferences so the fixed packages take precedence, and stuff from sury.org is only pulled in if it doesn't exist elsewhere.

Last edited by steve_v (2021-09-23 05:07:53)


Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Online

#8 2021-09-23 06:13:33

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Re: Devuan and LEMP. PHP 7.4+?

Thanx. I added line deb https://packages.sury.org/php/ buster main to my /etc/apt/sources.list.d/php.list config file.

apt-get update --allow-insecure-repositories;apt-get upgrade found some new packages: enchant libargon2-1 libgd3 libicu65 libidn2-0 libpcre2-8-0 libpcre3 libsodium23 libxml2 libzip4 libzstd1 php-common php-pear php7.3-igbinary php7.3-imagick php7.3-memcached php7.3-msgpack. Should I update it?

When I wrote apt install php7.4-bcmath php7.4-cli php7.4-common php7.4-curl php7.4-fpm php7.4-gd php7.4-gmp php7.4-igbinary php7.4-imagick php7.4-intl php7.4-json php7.4-mbstring php7.4-memcached php7.4-msgpack php7.4-mysql php7.4-opcache php7.4-readline php7.4-soap php7.4-xml php7.4-xmlrpc php7.4-zip it found non solved dependensy: php7.4-fpm depends on systemd but it will not be installed. So I can't upgrade to 7.4 sad

Offline

#9 2021-09-23 06:15:56

Aleksanders
Member
Registered: 2021-04-21
Posts: 7  

Re: Devuan and LEMP. PHP 7.4+?

golinux wrote:

It looks like it's available for chimaera (bullseye) and/or ceres (sid):
https://pkginfo.devuan.org/cgi-bin/poli … 4&x=submit

There are also rebuilds for beowulf here:
https://dev1galaxy.org/viewtopic.php?pid=30493#p30493

How can I solve NO_PUBKEY 1CC02413BFF88108 error?

Offline

#10 2021-09-23 19:38:08

steve_v
Member
Registered: 2018-01-11
Posts: 105  

Re: Devuan and LEMP. PHP 7.4+?

As I said, the packages from tdrnetworks need a higher priority. The whole point of that repo is providing php-fpm & co without systemd deps.

~$ apt-cache policy php7.4-fpm
php7.4-fpm:
  Installed: 7.4.22-1+devuan3~1
  Candidate: 7.4.22-1+devuan3~1
  Version table:
     7.4.23-1+0~20210826.50+debian10~1.gbpb41c6a 200
        200 https://packages.sury.org/php buster/main amd64 Packages
 *** 7.4.22-1+devuan3~1 500
        500 https://pkgs.tdrnetworks.com/apt/devuan beowulf/main amd64 Packages
        100 /var/lib/dpkg/status

Once is happenstance. Twice is coincidence. Three times is enemy action. Four times is Official GNOME Policy.

Online

Board footer