The officially official Devuan Forum!

You are not logged in.

#1 2019-05-11 00:21:05

Altoid
Member
Registered: 2017-05-07
Posts: 233  

[Solved ] Change from IDE to AHCI borks Devuan ASCII installation

Hello:

Continuing with my Devuan ASCII Asus 1000HE installation.

One of the things that were not done a few years ago (7 or 8?) when I last updated the XP installation that (still) resides on the drive was to update the drivers for AHCI.

At the time XP was rolled out, AHCI was still under developement and drivers were rolled out by Intel a few years on but MS did not see it fit to include them in SP3.

I've done it now and the 1000HE seems to be a bit snappier in XP and was hoping that the same would happen with Devuan ASCII, but now it will not boot.

At a certain point at the start of the boot process, the screen reads:

Begin: Running /scripts/local-block ... done

This for about 10/12 lines, then waits for the root file system and finally quits: Gave up waiting for the file system device.

Seems Devuan now cannot find the HDD.

Common problems:
- Boot args (cat /proc/cmdline
- Check rootdelay= (did the system wait long enough?) 
- Missing modules (cat /proc/modules: ls/dev)
ALERT! UUID=[number] does not exist. Dropping to a shell!

Not susrprising as the drive is now running in AHCI mode but back then, when Devuan was installed, the drive was running in IDE mode
I've moved the goal posts/unilaterally changed condiitons, so to speak.

My bets are on a missing AHCI module but I would not know where to start to fix that.

I guess I could reinstall ASCII and be done with it but I'd like to know if it is something (relatively) simple to fix so I can learn something new from this.
But it will not boot into recovery mode, just drops to a shell I've never used:

BusyBox v1.22.1 (Debian 1:1.22.0-19+b3) built-in shell (ash)
Enter 'help' for a list of built-in comands.
(initramfs) _ 

Thanks in advance.

A.

Last edited by Altoid (2019-05-11 00:48:53)

Offline

#2 2019-05-11 00:48:21

Altoid
Member
Registered: 2017-05-07
Posts: 233  

Re: [Solved ] Change from IDE to AHCI borks Devuan ASCII installation

Hello:

Altoid wrote:

I guess I could reinstall ASCII and be done with it but I'd like to know if it is something (relatively) simple to fix so I can learn something new from this.
But it will not boot into recovery mode, just drops to a shell I've never used:

It was much easier than I would have thought.
Certainly easier to fix than the hassle I went throug to install the AHCI drivers in XP.

See:
https://askubuntu.com/questions/976071/ … de-to-ahci

This is what worked for me.
modify: /etc/initramfs-tools/modules
add the modules (each per new line):

ahci libahci

modify then this file: /etc/initramfs-tools/initramfs.conf
and change < most > into < list>

run: update-initramfs -u

Reboot to BIOS, switch to AHCI and boot Xubuntu.

Cheers,

A.

Offline

#3 2019-05-11 02:14:39

golinux
Administrator
Registered: 2016-11-25
Posts: 1,675  

Re: [Solved ] Change from IDE to AHCI borks Devuan ASCII installation

Sometimes the long way is the short way.

Offline

#4 2019-05-11 02:25:53

Altoid
Member
Registered: 2017-05-07
Posts: 233  

Re: [Solved ] Change from IDE to AHCI borks Devuan ASCII installation

Hello:

golinux wrote:

Sometimes the long way is the short way.

Quite so ...

Next time I'll do a more thorough search before posting.  =^ |
The upside is that the solution (if needed by anyone else) now has a reference here at Dev1.

EDIT:

Because of what happened here https://dev1galaxy.org/viewtopic.php?pid=16075#p16075 I had to reinstall ASCII again.

What called my attention was that, with the SATA configuration in BIOS now set at AHCI (instead of IDE), the ASCII 2.0.0_i386_netinst.iso did not do what I expected it would.

ie:
Automatically detect AHCI in the BIOS (or ask/offer), setting the proper parameters by adding ahci and libahci to /etc/initramfs-tools/modules and writing list instead of most into /etc/initramfs-tools/initramfs.conf.

Granted, I was using expert install without being one, but is Is this by design?

Maybe this could be fixed by the option most including ahci and libahci?
AHCI is needed for SSDs and these days many notebooks come with one as standard issue.

Just an idea, don't know if there's something that prevents it.

When I was not able to boot into the new installation, I tried to make the necessary changes from within (opening a terminal in the root filesystem) but was ultimately stumped by not being able to do update-initramfs -u so I had to reinstall again.

Cheers,

A.

Last edited by Altoid (2019-05-15 19:58:00)

Offline

Board footer