The officially official Devuan Forum!

You are not logged in.

#1 2018-02-05 18:09:50

Dave Null
Registered: 2018-02-05
Posts: 4  

Unable to format sdcard

Salut/Hi, pardon my globbish

I used a SD card to copy the devuan iso with dd.
It booted ok, but I now want to get my sdcard back (16GB). It has several partitions now, I just want to get back to one empty partition.

I tried GParted, but it said like

...the driver descriptor says block size is 2048K but linux says 512K...

And it crashes if I try to delete or move partitions.

So I Googled this problem.

  • Tried  to delete partitions: fdisk doesn't complain when I do w but I get the same former parts when I put the SD card back

  • Tried to do the dd if=/dev/zero of=/dev/sdb BS=2048 trick, but no change

Last edited by Dave Null (2018-02-05 18:11:06)


#2 2018-02-05 21:05:14

Registered: 2016-11-25
Posts: 3,180  

Re: Unable to format sdcard

Unfortunately, I can't answer your question but I can welcome you to the forum as our 500th member!!


#3 2018-02-05 21:56:13

From: Any witch way
Registered: 2017-07-12
Posts: 497  

Re: Unable to format sdcard

Try creating a new partition table --> msdos
After that is done, you can recreate a partition and formatted in any format.  Sometimes gparted is too dumb and too afraid to wipe everything out and those cards are a little mysteriously structured.


#4 2018-02-20 01:03:37

Registered: 2018-01-31
Posts: 10  

Re: Unable to format sdcard

Nand is 'funny' stuff
If you have a win box or vbox with win?
SD card formater does the equivelent of a fstrim on a nand device,
as well as an "optimal" format
You may notice that fstrim under linux only works on ssd drives,
not sticks or SD cards will erase the card, backup anything important


Board footer