The officially official Devuan Forum!

You are not logged in.

#1 2020-06-25 19:23:48

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi Folks,

The errors occurred when upgrading from Ascii 2.1 to Beowulf with Synaptic using the "Add downloaded packages" feature.

I have made backup copies of 3 log files of which none indicate what the errors were.

Is there somewhere else I can look for a detailed description of the errors?


The 3 log files are the following. All of these are in the /var/log/apt directory.

eipp.log.xz
history.log
term.log

At the bottom of the term.log file was the following.

Errors were encountered while processing:
/tmp/apt-dpkg-install-QwO4dY/011-libgstreamer-gl1.0-0_1.14.4-2_amd64.deb
Log ended: 2020-06-25  12:14:42


At the bottom of the history.log file are the records for the attempted upgrade with the initial 3 lines as follows with the "xxxxxx" representing my User Account.

Start-Date: 2020-06-25  11:56:40
Commandline: /usr/sbin/synaptic
Requested-By: xxxxxx (1000)

On the "Install:" line is "libgstreamer-gl1.0-0:amd64 (1.14.4-2, automatic)"

The last 2 lines of the history.log file are as follows.

Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2020-06-25  12:14:42


In the eipp.log file, "libgstreamer-gl1.0-0:amd64" is listed on Line 5 which is labelled by "Install:".

Request: EIPP 0.1
Architecture: amd64
Architectures: amd64
Remove: various packages listed here
Install: libgstreamer-gl1.0-0:amd64 is listed on this Line
Planner: internal

Further down the file it is detailed as the following.

Package: libgstreamer-gl1.0-0
Architecture: amd64
Version: 1.14.4-2
APT-ID: 22581
Multi-Arch: same
Depends: libc6 (>= 2.14), libdrm2 (>= 2.4.17), libegl1, libgbm1 (>= 8.1~0), libgl1, libglib2.0-0 (>= 2.40), libgstreamer-plugins-base1.0-0 (>= 1.8.0), libgstreamer1.0-0 (>= 1.14.4), libgudev-1.0-0 (>= 165), libwayland-client0 (>= 1.9.91), libwayland-egl1 (>= 1.15.0), libx11-6, libx11-xcb1, libxcb1
Breaks: libgstreamer-plugins-bad1.0-0 (<< 1.13.1)

Thanks!!, MTB.

Online

#2 2020-06-26 19:26:58

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi Folks,

I have some more info which I hope helps to solve this issue.

After Fixing some Broken Packages in Synaptic and starting the "Add downloaded packages" feature again, I still encountered problems with the same package as before. However, there is a little more detail in the term.log file this time as appears next.

Log started: 2020-06-25  23:53:10
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 432358 files and directories currently installed.)
Preparing to unpack .../libgstreamer-gl1.0-0_1.14.4-2_amd64.deb ...
Unpacking libgstreamer-gl1.0-0:amd64 (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0', which is also in package libgstreamer-plugins-bad1.0-0:amd64 1:1.10.4-dmo2
Preparing to unpack .../gstreamer1.0-gl_1.14.4-2_amd64.deb ...
Unpacking gstreamer1.0-gl:amd64 (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstopengl.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_amd64.deb
 /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_amd64.deb
Log ended: 2020-06-25  23:53:12

The Desktop is now partly broken and a dialogue window appears with the following text below which appear 2 buttons (Execute and Remove).

Plugin "PulseAudio Plugin" unexpectedly left the panel, do you wish to restart it?

If you press Execute the panel will try to restart the plugin otherwise it will be permanently removed from the panel.

Thanks, MTB.

Online

#3 2020-06-26 21:23:37

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

I have a couple of ideas, but nothing certain.

Maybe you could remove libgstreamer-plugins-bad1.0-0 and eliminate the conflict. Two packages should not provide the same file. Maybe the newer version doesn't have the conflicting file.

You really should remove deb-multimedia from your sources. Look in /etc/apt/sources.list, look for any files in /etc/apt/sources.list.d/ and also wherever synaptic stores its sources. That alone might fix the upgrade problem, or maybe you have a bunch of other packages from dmo that might cause problems.

dpkg -l |grep dmowill give you a list of files with dmo in the name or the version. The ones with dmo in the version are from deb-multimedia. See how many you have.

How old is this system? Was it upgraded from jessie? From a jessie beta?

Offline

#4 2020-06-27 04:43:44

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi fsmithred,

My first Devuan install was Ascii 2.0 from Live ISO.

If I recall correctly, I added the deb-multimedia repository for some DVD Authoring packages in my quest for something that could produce smooth text for subtitle tracks. As you will see below, it looks like I installed some other packages form that repository also.

I have the following files in the /etc/apt/sources.list.d directory.

connectify.list
(will uninstall/remove the related packages of the the above because
  the VPN didn't work for me and then delete this file)
 
devuan.list
(every line in the above is disabled, can I remove it?)

jami.list
riot-im.list
windscribe-repo.list


As far as I am aware, and can see, Synaptic stores its sources in the "sources.list' file but also references the files in the "/etc/apt/sources.list.d" directory.

Contained in the "/var/lib/apt/lists" directory are the following files related to deb-multimedia.org.

www.deb-multimedia.org_dists_stretch_InRelease
www.deb-multimedia.org_dists_stretch_main_binary-amd64_Packages
www.deb-multimedia.org_dists_stretch_main_i18n_Translation-en
www.deb-multimedia.org_dists_stretch_non-free_binary-amd64_Packages
www.deb-multimedia.org_dists_stretch_non-free_i18n_Translation-en

The command grep ^Package www.deb-multimedia*_Packages | awk '{print $2}' | sort -u issued with that directory being active produces a list of 633 packages. I will list them later if you think it's necessary.

The following page gave me the idea for the grep command.

How To List All Packages In A Repository On Ubuntu, Debian Or Linux Mint [APT]


ls |grep dmo in the "/var/cache/apt/archives" directory produces the following list of 120 files.

aegisub_1%3a3.2.2+dfsg-dmo4_amd64.deb
aegisub-l10n_1%3a3.2.2+dfsg-dmo4_all.deb
audacity_1%3a2.1.3-dmo1+deb9u1_amd64.deb
audacity-data_1%3a2.1.3-dmo1+deb9u1_all.deb
bdsup2sub_4.0.0-dmo1_all.deb
bombono-dvd_1%3a1.2.2-dmo13_amd64.deb
bombono-dvd-data_1%3a1.2.2-dmo13_all.deb
devede_1%3a4.8.8-dmo1_all.deb
faac_1%3a1.28-dmo5_amd64.deb
ffmpeg_3.3.9-dmo1+deb9u1_amd64.deb
gpac_1%3a0.7.1+20190313.git21f1d86ee-dmo1+deb9u3_amd64.deb
gpac-modules-base_1%3a0.7.1+20190313.git21f1d86ee-dmo1+deb9u3_amd64.deb
gstreamer1.0-libav_1.10.4-dmo1_amd64.deb
gstreamer1.0-plugins-bad_1%3a1.10.4-dmo2_amd64.deb
gstreamer1.0-plugins-ugly_1.10.4-dmo1_amd64.deb
lame_1%3a3.99.5-dmo6_amd64.deb
libaacs0_0.9.0-dmo1_amd64.deb
libaribb24-0_1.0.3-dmo1_amd64.deb
libaribb25-0_0.2.7-dmo1_amd64.deb
libasound2-plugins_1.1.4-dmo1+deb9u1_amd64.deb
libass9_2%3a0.13.7-dmo1_amd64.deb
libavdevice57_10%3a3.3.9-dmo1+deb9u1_amd64.deb
libavfilter6_10%3a3.3.9-dmo1+deb9u1_amd64.deb
libavresample3_10%3a3.3.9-dmo1+deb9u1_amd64.deb
libbabl-0.1-0_0.1.28-dmo1_amd64.deb
libbasicusageenvironment1_2%3a2017.04.26-dmo1+deb9u2_amd64.deb
libbdplus0_0.1.2-dmo1+deb8u1_amd64.deb
libdca0_0.0.5-dmo2+deb8u1_amd64.deb
libdsm3_1%3a0.2.7-dmo3_amd64.deb
libdvbpsi10_1.3.1-dmo1_amd64.deb
libebml4v5_1%3a1.3.9-dmo0+deb9u1_amd64.deb
libfaac0_1%3a1.28-dmo5_amd64.deb
libffmpegthumbnailer4v5_2.2.0-dmo4_amd64.deb
libffms2-4_1%3a2.23-dmo1_amd64.deb
libgegl-0.3-0_0.3.18-dmo1_amd64.deb
libgpac7_1%3a0.7.1+20190313.git21f1d86ee-dmo1+deb9u3_amd64.deb
libgroupsock8_2%3a2017.04.26-dmo1+deb9u2_amd64.deb
libgstreamer-plugins-bad1.0-0_1%3a1.10.4-dmo2_amd64.deb
liblavfile-2.1-0_2.1.0-dmo9_amd64.deb
liblavjpeg-2.1-0_2.1.0-dmo9_amd64.deb
liblavplay-2.1-0_2.1.0-dmo9_amd64.deb
liblivemedia58_2%3a2017.04.26-dmo1+deb9u2_amd64.deb
libmatroska6v5_1%3a1.4.5-dmo1_amd64.deb
libmicrodns0_0.1.2-dmo0~bpo9+1_amd64.deb
libmjpegutils-2.1-0_2.1.0-dmo9_amd64.deb
libmp4v2-2_2%3a2.0.0-dmo4_amd64.deb
libmpeg2encpp-2.1-0_2.1.0-dmo9_amd64.deb
libmplex2-2.1-0_2.1.0-dmo9_amd64.deb
libnfs8_1.11.0-dmo1_amd64.deb
libobs0_19.0.2-dmo2+deb9u1_amd64.deb
libogmrip1_1.0.1-dmo9_amd64.deb
libpostproc54_10%3a3.3.9-dmo1+deb9u1_amd64.deb
libquicktime2_1.2.4-dmo19+deb9u1_amd64.deb
librtmp1_2.4~20160119.gitfa8646dae-dmo5_amd64.deb
libsuil-0-0_1%3a0.8.4-dmo1+deb9u1_amd64.deb
libtwolame0_0.3.13-dmo3_amd64.deb
libusageenvironment3_2%3a2017.04.26-dmo1+deb9u2_amd64.deb
libvamp-hostsdk3v5_1%3a2.7.1-dmo1_amd64.deb
libvidstab1.0_2%3a0.98b-dmo1+deb8u1_amd64.deb
libvlc5_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlc5_3.0.11-dmo0+deb9u1_amd64.deb
libvlc-bin_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlc-bin_3.0.11-dmo0+deb9u1_amd64.deb
libvlccore9_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlccore9_3.0.11-dmo0+deb9u1_amd64.deb
libx264-150_0.150.2833+gitdf79067-dmo1+deb9u1_amd64.deb
libxine2_1.2.8-dmo5_amd64.deb
libxine2-bin_1.2.8-dmo5_amd64.deb
libxine2-doc_1.2.8-dmo5_all.deb
libxine2-ffmpeg_1.2.8-dmo5_amd64.deb
libxine2-misc-plugins_1.2.8-dmo5_amd64.deb
libxine2-plugins_1.2.8-dmo5_all.deb
libxine2-x_1.2.8-dmo5_amd64.deb
libxvidcore4_1.3.4-dmo1_amd64.deb
mencoder_4%3a1.3.0~20170413.svn37931-dmo3+deb9u5_amd64.deb
mjpegtools_2.1.0-dmo9_amd64.deb
mjpegtools-gtk_2.1.0-dmo9_amd64.deb
mkvtoolnix_9.8.0-dmo1_amd64.deb
mkvtoolnix-gui_9.8.0-dmo1_amd64.deb
mplayer_4%3a1.3.0~20170413.svn37931-dmo3+deb9u5_amd64.deb
mpv_0.27.2-dmo1+deb9u1_amd64.deb
obs-plugins_19.0.2-dmo2+deb9u1_amd64.deb
obs-studio_19.0.2-dmo2+deb9u1_amd64.deb
ogmrip_1.0.1-dmo9_amd64.deb
ogmrip-doc_1.0.1-dmo9_all.deb
phonon4qt5-backend-vlc_1%3a0.9.1-dmo1+deb9u1_amd64.deb
rtmpdump_2.4~20160119.gitfa8646dae-dmo5_amd64.deb
subtitleripper_0.5.2-dmo3_amd64.deb
tovid_0.35.2-dmo1_all.deb
tovidgui_0.35.2-dmo1_all.deb
transcode_4%3a1.1.7-dmo15_amd64.deb
transcode-doc_4%3a1.1.7-dmo15_all.deb
twolame_0.3.13-dmo3_amd64.deb
vlc_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc_3.0.11-dmo0+deb9u1_amd64.deb
vlc-bin_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-bin_3.0.11-dmo0+deb9u1_amd64.deb
vlc-data_1%3a3.0.8-dmo0+deb9u4_all.deb
vlc-data_3.0.11-dmo0+deb9u1_all.deb
vlc-l10n_1%3a3.0.8-dmo0+deb9u4_all.deb
vlc-l10n_3.0.11-dmo0+deb9u1_all.deb
vlc-plugin-base_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-base_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-notify_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-notify_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-qt_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-qt_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-samba_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-samba_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-skins2_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-skins2_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-video-output_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-video-output_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-video-splitter_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-video-splitter_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-visualization_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-visualization_3.0.11-dmo0+deb9u1_amd64.deb
x11proto-xf86vidmode-dev_2018.4-4_all.deb
x11proto-xf86vidmode-dev_2.3.1-2_all.deb
xine-ui_0.99.9-dmo14+deb9u1_amd64.deb

Not only can I not start Synaptic from the Desktop but I also could not use the Terminal (should have noted the error message).

I logged into the tty6 console and attempted the following command.

aptitude search "?origin (deb-multimedia) ?installed"

The resulting output was as follows.

Warning: Invalid locale(please review locale settings, this might lead to some problems later):
    locale::facet::_S_create_c_locale name not valid

So, I logged out of the tty6 Console and then the Desktop to Restart into another Distro to make this post.

Would it be possible to chroot into my Ascii OS to run the aptitude command and the dpkg command you suggested?

If so, would I then be able to use the chroot environment to use whatever other commands are necessary to fix the upgrade?

Thanks!!, MTB.

Online

#5 2020-06-27 10:48:59

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Wow. I think (hope) that 120 is the correct number of dmo packages installed and not 633.

You can get rid of sources.list.d/devuan.list. I don't know about the other lists. You might need to disable them temporarily and/or you might need to change the suite they're using. (stretch to buster?)

It looks like your dmo packages are older versions than what beowulf has. If you remove dmo from sources, you should be able to upgrade most of them to stock beowulf versions.

If there's something in dmo you need that isn't in the devuan repo, you can add it later. I highly recommend pinning dmo to a lower priority or disabling it altogether after you install what you want. That will prevent pulling in other stuff from dmo that you don't need or want. Just avoid dmo if you can.

And yes, you can do all this in a chroot from another system. I like to use a live-cd (or usb) for that, but rescue mode in the installer isos will also work.

Offline

#6 2020-06-27 18:02:18

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

fsmithred wrote:

And yes, you can do all this in a chroot from another system. I like to use a live-cd (or usb) for that, but rescue mode in the installer isos will also work.

Before I get started on using chroot, is there a particular reason that you use a Live System for it? Is there any difference to using chroot from a Live system as opposed to an Installed system?

Thanks!!

Online

#7 2020-06-27 18:46:00

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Yes, you can use an installed system.

Offline

#8 2020-06-28 00:48:23

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

fsmithred wrote:

Yes, you can use an installed system.

Evening fsmithred,

There appears to be multiple ways that chroot can be used but in my research the info has not been 100% detailed as to what to do for a particular scenario.

For example, should I be doing this from a Terminal opened under the root account of the Live or Installed system or should I use sudo with the Terminal opened under My User Account?

I have seen pages where the person has created a directory for a Mount Point under their home directory whilst others have done it under the /mnt directory of the File System.

I have seen people referring to differences in commands/procedures to follow dependent on whether you are using a UEFI or Legacy BIOS.

Others have mentioned the mounting of boot partitions. In my case would that be the BOOTEFI partition (Partition 1) on the same drive that I have Devuan installed on? Do I need to be doing this for my scenario?


Within the Installed system I am currently working from, the Devuan partition is identified as /dev/sdc4.

My Laptop uses UEFI.

The Installed system I am currently working from is on the Internal Hard Drive whilst Devuan is on an External Hard Drive.


Are the following instructions what I need to be doing if working from Terminal as the root account?

Create a Directory sdc4 under the /mnt directory.

Mount /dev/sdc4 to /mnt/sdc4 (mount /dev/sdc4 /mnt/sdc4)

For the above command, should I be using "-t ext4" also?

chroot into /mnt/sdc4 (chroot /mnt/sdc4)


Do I also need to be executing the following commands/procedures before the chroot command?

Create a boot/efi directory under the /mnt/sdc4 directory for the mounting of a Boot partition? Which Boot partition?

Which of the following examples that I pulled off the Internet and modified, if necessary, should I be executing?

mount -t proc none /mnt/sdc4/proc
mount -o bind /dev /mnt/sdc4/dev
mount -o bind /sys /mnt/sdc4/sys
mount --bind /dev /mnt/sdc4/dev
mount --bind /proc /mnt/sdc4/proc
mount --bind /sys /mnt/sdc4/sys
mount -t proc proc /mnt/sdc4/proc/
mount -t sysfs sys /mnt/sdc4/sys/ 
mount -o bind /tmp /mnt/sdc4/tmp/ 
mount -o bind /dev /mnt/sdc4/dev/

Are there any other Local directories that should be mounted before executing the chroot?

Thanks!!, MTB.

Online

#9 2020-06-28 09:08:22

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 767  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

If you're chrooting from a beowulf (or Debian buster) system then the easiest method is

# apt install arch-install-scripts
# mount /dev/sdc4 /mnt
# arch-chroot /mnt
[chroot] # mount -a

The arch-chroot command will (bind) mount the API filesystems automatically.

If you're doing this from ASCII then use

# mount /dev/sdc4 /mnt
# for i in proc sys dev{,/pts} ; do mount --bind /$i /mnt/$i ; done
# chroot /mnt
[chroot] # mount -a

No need to bother with /tmp and no need to create any directories under /mnt; the mount and {arch-,}choot commands need root privileges.

EDIT: s/sda/sdc/

Last edited by Head_on_a_Stick (2020-06-28 09:10:15)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#10 2020-06-28 10:14:57

HevyDevy
Member
Registered: 2019-09-06
Posts: 263  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Nice one Hoas, i didnt know arch-install-scripts were in the debian repos, this is archlinux port to debian hey?


When all the trees have been cut down, when all the animals have been hunted, when all the waters are polluted, when all the air is unsafe to breathe, only then will you discover you cannot eat money.
~ Cree Prophecy

Offline

#11 2020-06-29 17:08:43

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Head_on_a_Stick wrote:

If you're chrooting from a beowulf (or Debian buster) system then the easiest method is

# apt install arch-install-scripts
# mount /dev/sdc4 /mnt
# arch-chroot /mnt
[chroot] # mount -a

The arch-chroot command will (bind) mount the API filesystems automatically.

Hi HoaS,

Thanks for this. I also discovered your input, regarding chrooting elsewhere, after I discovered that this installed system has its own utility which when you exit automatically cleanly unmounts the partition.

However, I decided to still install what you suggested to see what operational differences there might be for my own learning.

So, following your instructions, after entering the exit command, I executed umount /dev/sdc4 which reported that the partition was busy but I couldn't find anything open, that I was aware, that could be using a file of the Devuan install. So, after a little research I used the umount -l /dev/sdc4 command which did the trick.

Can you say what would have been holding a file open on the Devuan system even though I had exited the chroot environment?

Thanks!!, MTB.

Online

#12 2020-06-29 17:17:43

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

fsmithred wrote:

Wow. I think (hope) that 120 is the correct number of dmo packages installed and not 633.

You can get rid of sources.list.d/devuan.list. I don't know about the other lists. You might need to disable them temporarily and/or you might need to change the suite they're using. (stretch to buster?)

It looks like your dmo packages are older versions than what beowulf has. If you remove dmo from sources, you should be able to upgrade most of them to stock beowulf versions.

If there's something in dmo you need that isn't in the devuan repo, you can add it later. I highly recommend pinning dmo to a lower priority or disabling it altogether after you install what you want. That will prevent pulling in other stuff from dmo that you don't need or want. Just avoid dmo if you can.

Hi again fsmithred,

So, after chrooting into Devuan, when I executed dpkg -l | grep dmo the output resulted in a listing of 122 packages which is 2 more than what was produced by ls |grep dmo in the "/var/cache/apt/archives/" directory.

aegisub                                1:3.2.2+dfsg-dmo4                      
aegisub-l10n                           1:3.2.2+dfsg-dmo4                      
audacity                               1:2.1.3-dmo1+deb9u1                    
audacity-data                          1:2.1.3-dmo1+deb9u1                    
bdsup2sub                              4.0.0-dmo1                             
bombono-dvd                            1:1.2.2-dmo13                          
bombono-dvd-data                       1:1.2.2-dmo13                          
devede                                 1:4.8.8-dmo1                           
dvdstyler                              1:3.0.3-dmo1                           
dvdstyler-data                         1:3.0.3-dmo1                           
faac                                   1:1.28-dmo5                            
ffmpeg                                 10:3.3.9-dmo1+deb9u1                   
gpac                                   1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
gpac-modules-base:amd64                1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
gstreamer1.0-libav:amd64               1:1.10.4-dmo1                          
gstreamer1.0-plugins-bad:amd64         1:1.10.4-dmo2                          
gstreamer1.0-plugins-ugly:amd64        1:1.10.4-dmo1                          
lame                                   1:3.99.5-dmo6                          
libaacs0:amd64                         0.9.0-dmo1                             
libaribb24-0                           1.0.3-dmo1                             
libaribb25-0                           0.2.7-dmo1                             
libasound2-plugins:amd64               1:1.1.4-dmo1+deb9u1                    
libass9:amd64                          2:0.13.7-dmo1                          
libavcodec57:amd64                     10:3.3.9-dmo1+deb9u1                   
libavdevice57:amd64                    10:3.3.9-dmo1+deb9u1                   
libavfilter6:amd64                     10:3.3.9-dmo1+deb9u1                   
libavformat57:amd64                    10:3.3.9-dmo1+deb9u1                   
libavresample3:amd64                   10:3.3.9-dmo1+deb9u1                   
libavutil55:amd64                      10:3.3.9-dmo1+deb9u1                   
libbabl-0.1-0:amd64                    1:0.1.28-dmo1                          
libbasicusageenvironment1              2:2017.04.26-dmo1+deb9u2               
libbdplus0                             0.1.2-dmo1+deb8u1                      
libbluray-bdj                          2:1.0.0-dmo1                           
libbluray2:amd64                       2:1.0.0-dmo1                           
libchromaprint1:amd64                  1:1.4.2-dmo1                           
libdca0:amd64                          0.0.5-dmo2+deb8u1                      
libdsm3:amd64                          1:0.2.7-dmo3                           
libdvbpsi10:amd64                      1:1.3.1-dmo1                           
libebml4v5:amd64                       1:1.3.9-dmo0+deb9u1                    
libfaac0:amd64                         1:1.28-dmo5                            
libfdk-aac1:amd64                      1:0.1.5-dmo2                           
libffmpegthumbnailer4v5:amd64          1:2.2.0-dmo4                           
libffms2-4:amd64                       1:2.23-dmo1                            
libgegl-0.3-0:amd64                    1:0.3.18-dmo1                          
libgpac7:amd64                         1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
libgroupsock8                          2:2017.04.26-dmo1+deb9u2               
libgstreamer-plugins-bad1.0-0:amd64    1:1.10.4-dmo2                          
libilbc2:amd64                         2.0.2-dmo4                             
libkvazaar3:amd64                      1:1.1.0-dmo1                           
liblavfile-2.1-0:amd64                 2:2.1.0-dmo9                           
liblavjpeg-2.1-0:amd64                 2:2.1.0-dmo9                           
liblavplay-2.1-0:amd64                 2:2.1.0-dmo9                           
liblivemedia58                         2:2017.04.26-dmo1+deb9u2               
libmatroska6v5:amd64                   1:1.4.5-dmo1                           
libmfx0:amd64                          1.21-dmo1                              
libmicrodns0:amd64                     0.1.2-dmo0~bpo9+1                      
libmjpegutils-2.1-0:amd64              2:2.1.0-dmo9                           
libmp3lame0:amd64                      1:3.99.5-dmo6                          
libmp4v2-2:amd64                       2:2.0.0-dmo4                           
libmpeg2encpp-2.1-0:amd64              2:2.1.0-dmo9                           
libmplex2-2.1-0:amd64                  2:2.1.0-dmo9                           
libnfs8:amd64                          1.11.0-dmo1                            
libobs0                                1:19.0.2-dmo2+deb9u1                   
libogmrip1:amd64                       1.0.1-dmo9                             
libopenh264-2:amd64                    1.6.0-dmo3                             
libpostproc54:amd64                    10:3.3.9-dmo1+deb9u1                   
libquicktime2:amd64                    3:1.2.4-dmo19+deb9u1                   
librtmp1:amd64                         2:2.4~20160119.gitfa8646dae-dmo5       
libsuil-0-0:amd64                      1:0.8.4-dmo1+deb9u1                    
libswresample2:amd64                   10:3.3.9-dmo1+deb9u1                   
libswscale4:amd64                      10:3.3.9-dmo1+deb9u1                   
libtwolame0:amd64                      1:0.3.13-dmo3                          
libusageenvironment3                   2:2017.04.26-dmo1+deb9u2               
libvamp-hostsdk3v5:amd64               1:2.7.1-dmo1                           
libvidstab1.0                          2:0.98b-dmo1+deb8u1                    
libvlc-bin:amd64                       1:3.0.11-dmo0+deb9u1                   
libvlc5:amd64                          1:3.0.11-dmo0+deb9u1                   
libvlccore9:amd64                      1:3.0.11-dmo0+deb9u1                   
libwxsvg3:amd64                        3:1.5.12-dmo1                          
libx264-150:amd64                      3:0.150.2833+gitdf79067-dmo1+deb9u1    
libx265-116:amd64                      1:2.4-dmo1                             
libxine2                               1:1.2.8-dmo5                           
libxine2-bin:amd64                     1:1.2.8-dmo5                           
libxine2-doc                           1:1.2.8-dmo5                           
libxine2-ffmpeg:amd64                  1:1.2.8-dmo5                           
libxine2-misc-plugins:amd64            1:1.2.8-dmo5                           
libxine2-plugins                       1:1.2.8-dmo5                           
libxine2-x:amd64                       1:1.2.8-dmo5                           
libxvidcore4:amd64                     3:1.3.4-dmo1                           
mencoder                               4:1.3.0~20170413.svn37931-dmo3+deb9u5  
mjpegtools                             2:2.1.0-dmo9                           
mjpegtools-gtk                         2:2.1.0-dmo9                           
mkvtoolnix                             9.8.0-dmo1                             
mkvtoolnix-gui                         9.8.0-dmo1                             
mplayer                                4:1.3.0~20170413.svn37931-dmo3+deb9u5  
mpv                                    1:0.27.2-dmo1+deb9u1                   
obs-plugins                            1:19.0.2-dmo2+deb9u1                   
obs-studio                             1:19.0.2-dmo2+deb9u1                   
ogmrip                                 1.0.1-dmo9                             
ogmrip-doc                             1.0.1-dmo9                             
phonon4qt5-backend-vlc:amd64           1:0.9.1-dmo1+deb9u1                    
rtmpdump                               2:2.4~20160119.gitfa8646dae-dmo5       
subtitleripper                         0.5.2-dmo3                             
tovid                                  0.35.2-dmo1                            
tovidgui                               0.35.2-dmo1                            
transcode                              4:1.1.7-dmo15                          
transcode-doc                          4:1.1.7-dmo15                          
twolame                                1:0.3.13-dmo3                          
vlc                                    1:3.0.11-dmo0+deb9u1                   
vlc-bin                                1:3.0.11-dmo0+deb9u1                   
vlc-data                               1:3.0.11-dmo0+deb9u1                   
vlc-l10n                               1:3.0.11-dmo0+deb9u1                   
vlc-plugin-base:amd64                  1:3.0.11-dmo0+deb9u1                   
vlc-plugin-notify:amd64                1:3.0.11-dmo0+deb9u1                   
vlc-plugin-qt:amd64                    1:3.0.11-dmo0+deb9u1                   
vlc-plugin-samba:amd64                 1:3.0.11-dmo0+deb9u1                   
vlc-plugin-skins2:amd64                1:3.0.11-dmo0+deb9u1                   
vlc-plugin-video-output:amd64          1:3.0.11-dmo0+deb9u1                   
vlc-plugin-video-splitter:amd64        1:3.0.11-dmo0+deb9u1                   
vlc-plugin-visualization:amd64         1:3.0.11-dmo0+deb9u1                   
x11proto-xf86vidmode-dev               2018.4-4                               
xine-ui                                0.99.9-dmo14+deb9u1

Of the 122 packages, 18 did not have a file in "/var/cache/apt/archives/". They were the following.

devede
dvdstyler
libavcodec57:amd64
libavformat57:amd64
libavutil55:amd64
libbluray-bdj
libbluray2:amd64
libchromaprint1:amd64
libfdk-aac1:amd64
libilbc2:amd64
libkvazaar3:amd64
libmfx0:amd64
libmp3lame0:amd64
libopenh264-2:amd64
libswresample2:amd64
libswscale4:amd64
libwxsvg3:amd64
libx265-116:amd64

Of the 120 packages in "/var/cache/apt/archives/", 16 were not listed by dpkg -l | grep demo. However, 15 of these appear to have been earlier versions that were previously installed whilst the last pairing is the opposite. Whether these should have been removed when the other version was installed I can't say. The following list will help to clarify I hope.

libvlc-bin_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlc-bin_3.0.11-dmo0+deb9u1_amd64.deb

libvlc5_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlc5_3.0.11-dmo0+deb9u1_amd64.deb

libvlccore9_1%3a3.0.8-dmo0+deb9u4_amd64.deb
libvlccore9_3.0.11-dmo0+deb9u1_amd64.deb

vlc_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc_3.0.11-dmo0+deb9u1_amd64.deb

vlc-bin_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-bin_3.0.11-dmo0+deb9u1_amd64.deb

vlc-data_1%3a3.0.8-dmo0+deb9u4_all.deb
vlc-data_3.0.11-dmo0+deb9u1_all.deb

vlc-l10n_1%3a3.0.8-dmo0+deb9u4_all.deb
vlc-l10n_3.0.11-dmo0+deb9u1_all.deb

vlc-plugin-base_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-base_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-notify_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-notify_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-qt_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-qt_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-samba_3.0.11-dmo0+deb9u1_amd64.deb
vlc-plugin-samba_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-skins2_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-skins2_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-video-output_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-video-output_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-video-splitter_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-video-splitter_3.0.11-dmo0+deb9u1_amd64.deb

vlc-plugin-visualization_1%3a3.0.8-dmo0+deb9u4_amd64.deb
vlc-plugin-visualization_3.0.11-dmo0+deb9u1_amd64.deb

x11proto-xf86vidmode-dev_2018.4-4_all.deb
x11proto-xf86vidmode-dev_2.3.1-2_all.deb

Using aptitude search "?origin (deb-multimedia) ?installed" in the chroot environment produces the same result as before.

Warning: Invalid locale (please review locale settings, this might lead to problems later):
  locale::facet::_S_create_c_locale name not valid

 
So, is there anymore analysis to be done before following a plan of action?

Thanks !!, MTB.

Last edited by mtbvfr (2020-06-30 03:43:52)

Online

#13 2020-06-29 18:17:49

golinux
Administrator
Registered: 2016-11-25
Posts: 1,951  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

dmo is a sure path to a frankendevuan.  smile

Offline

#14 2020-06-29 18:54:26

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

I guess the plan would be to remove whatever is blocking the upgrade and whatever else you don't need. You can probably remove all or most of the dmo packages. And anything with "deb9" in the version is for stretch/ascii.

Offline

#15 2020-06-29 19:30:35

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

fsmithred wrote:

I guess the plan would be to remove whatever is blocking the upgrade and whatever else you don't need. You can probably remove all or most of the dmo packages. And anything with "deb9" in the version is for stretch/ascii.

I forgot to ask the following.

Should I use a dpkg command or an apt-get command to uninstall the dmo packages?

If apt-get, should I use apt-get remove Package or apt-get autoremove Package? Which options should be applied?

Will the use of these also remove the associated .deb files from "/var/cache/apt/archives/"?

After the packages have been uninstalled/removed, can I, then, copy the previously downloaded non-dmo .deb files into "/var/cache/apt/archives/" before executing apt-get dist-upgrade with the Laptop not connected to the Internet from the chroot environment?


Thanks!!

Online

#16 2020-06-29 19:32:43

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 767  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

So, following your instructions, after entering the exit command, I executed umount /dev/sdc4 which reported that the partition was busy but I couldn't find anything open, that I was aware, that could be using a file of the Devuan install. So, after a little research I used the umount -l /dev/sdc4 command which did the trick.

Can you say what would have been holding a file open on the Devuan system even though I had exited the chroot environment?

Not really but you can use lsof /dev/sdc4 to list any open files.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#17 2020-06-29 23:16:32

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,559  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Use apt, apt-get or aptitude remove Package.
You probably won't need to name all of them, as some will come out automatically with others.
Aptitude will most likely remove more than the others.

You can do 'apt autoremove' afterward to get rid of unneeded packages that weren't already removed.

'apt-get autoclean' will get rid of the obsolete packages in /var/cache/apt/archives
'apt-get clean' will get rid of all the packages in /var/cache/apt/archives

After the packages have been uninstalled/removed, can I, then, copy the previously downloaded non-dmo .deb files into "/var/cache/apt/archives/" before executing apt-get dist-upgrade with the Laptop not connected to the Internet from the chroot environment?

I have no idea, but it sounds like you know what you're doing. I've never done it that way.

Offline

#18 2020-06-30 00:09:27

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

fsmithred wrote:

After the packages have been uninstalled/removed, can I, then, copy the previously downloaded non-dmo .deb files into "/var/cache/apt/archives/" before executing apt-get dist-upgrade with the Laptop not connected to the Internet from the chroot environment?

I have no idea, but it sounds like you know what you're doing. I've never done it that way.

I have no idea neither. smile That's why I am asking.

Thanks !!

Online

#19 2020-06-30 06:44:15

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 123  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

After the packages have been uninstalled/removed, can I, then, copy the previously downloaded non-dmo .deb files into "/var/cache/apt/archives/" before executing apt-get dist-upgrade with the Laptop not connected to the Internet from the chroot environment?

I use this method again and again. But always with an active internet conexion and no chroot. I think that the package manager may need the conexion to know which packages is going to get. If the package is already in /var/cache/apt/archives/ it just skip the download.

Offline

#20 2020-06-30 22:32:12

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

PedroReina wrote:

I use this method again and again. But always with an active internet conexion and no chroot. I think that the package manager may need the conexion to know which packages is going to get. If the package is already in /var/cache/apt/archives/ it just skip the download.

Hola Pedro,

Necesito usar chroot porque el escritorio es corruptado.

Su última frase parece ser confirmada por la información que encontré en el siguiente manual en línea.

Using APT Offline

Publicaré mi plan de acción, para que todos lo comenten, muy pronto.

¡Gracias!, MTB.

Online

#21 2020-06-30 22:43:38

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi Folks,

Here's the Upgrade Recovery Plan I have come up with for which I would appreciate any feedback as to possible problems I could encounter.

chroot into my Devuan system.

For Package Removal Simulation, use aptitude -s -P remove "Package Name" for following packages.

For Package Removal, use aptitude -P remove "Package Name" to remove following packages.
    After each Removal, use dpkg -l | grep dmo to check how many packages still need to be removed.

For Package Names, used by the above commands, remove the ":amd64" suffix first.

aegisub                                1:3.2.2+dfsg-dmo4                      
aegisub-l10n                           1:3.2.2+dfsg-dmo4                      
audacity                               1:2.1.3-dmo1+deb9u1                    
audacity-data                          1:2.1.3-dmo1+deb9u1                    
bdsup2sub                              4.0.0-dmo1                             
bombono-dvd                            1:1.2.2-dmo13                          
bombono-dvd-data                       1:1.2.2-dmo13                          
devede                                 1:4.8.8-dmo1                           
dvdstyler                              1:3.0.3-dmo1                           
dvdstyler-data                         1:3.0.3-dmo1                           
faac                                   1:1.28-dmo5                            
ffmpeg                                 10:3.3.9-dmo1+deb9u1                   
gpac                                   1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
gpac-modules-base:amd64                1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
gstreamer1.0-libav:amd64               1:1.10.4-dmo1                          
gstreamer1.0-plugins-bad:amd64         1:1.10.4-dmo2                          
gstreamer1.0-plugins-ugly:amd64        1:1.10.4-dmo1                          
lame                                   1:3.99.5-dmo6                          
libaacs0:amd64                         0.9.0-dmo1                             
libaribb24-0                           1.0.3-dmo1                             
libaribb25-0                           0.2.7-dmo1                             
libasound2-plugins:amd64               1:1.1.4-dmo1+deb9u1                    
libass9:amd64                          2:0.13.7-dmo1                          
libavcodec57:amd64                     10:3.3.9-dmo1+deb9u1                   
libavdevice57:amd64                    10:3.3.9-dmo1+deb9u1                   
libavfilter6:amd64                     10:3.3.9-dmo1+deb9u1                   
libavformat57:amd64                    10:3.3.9-dmo1+deb9u1                   
libavresample3:amd64                   10:3.3.9-dmo1+deb9u1                   
libavutil55:amd64                      10:3.3.9-dmo1+deb9u1                   
libbabl-0.1-0:amd64                    1:0.1.28-dmo1                          
libbasicusageenvironment1              2:2017.04.26-dmo1+deb9u2               
libbdplus0                             0.1.2-dmo1+deb8u1                      
libbluray-bdj                          2:1.0.0-dmo1                           
libbluray2:amd64                       2:1.0.0-dmo1                           
libchromaprint1:amd64                  1:1.4.2-dmo1                           
libdca0:amd64                          0.0.5-dmo2+deb8u1                      
libdsm3:amd64                          1:0.2.7-dmo3                           
libdvbpsi10:amd64                      1:1.3.1-dmo1                           
libebml4v5:amd64                       1:1.3.9-dmo0+deb9u1                    
libfaac0:amd64                         1:1.28-dmo5                            
libfdk-aac1:amd64                      1:0.1.5-dmo2                           
libffmpegthumbnailer4v5:amd64          1:2.2.0-dmo4                           
libffms2-4:amd64                       1:2.23-dmo1                            
libgegl-0.3-0:amd64                    1:0.3.18-dmo1                          
libgpac7:amd64                         1:0.7.1+20190313.git21f1d86ee-dmo1+deb9
libgroupsock8                          2:2017.04.26-dmo1+deb9u2               
libgstreamer-plugins-bad1.0-0:amd64    1:1.10.4-dmo2                          
libilbc2:amd64                         2.0.2-dmo4                             
libkvazaar3:amd64                      1:1.1.0-dmo1                           
liblavfile-2.1-0:amd64                 2:2.1.0-dmo9                           
liblavjpeg-2.1-0:amd64                 2:2.1.0-dmo9                           
liblavplay-2.1-0:amd64                 2:2.1.0-dmo9                           
liblivemedia58                         2:2017.04.26-dmo1+deb9u2               
libmatroska6v5:amd64                   1:1.4.5-dmo1                           
libmfx0:amd64                          1.21-dmo1                              
libmicrodns0:amd64                     0.1.2-dmo0~bpo9+1                      
libmjpegutils-2.1-0:amd64              2:2.1.0-dmo9                           
libmp3lame0:amd64                      1:3.99.5-dmo6                          
libmp4v2-2:amd64                       2:2.0.0-dmo4                           
libmpeg2encpp-2.1-0:amd64              2:2.1.0-dmo9                           
libmplex2-2.1-0:amd64                  2:2.1.0-dmo9                           
libnfs8:amd64                          1.11.0-dmo1                            
libobs0                                1:19.0.2-dmo2+deb9u1                   
libogmrip1:amd64                       1.0.1-dmo9                             
libopenh264-2:amd64                    1.6.0-dmo3                             
libpostproc54:amd64                    10:3.3.9-dmo1+deb9u1                   
libquicktime2:amd64                    3:1.2.4-dmo19+deb9u1                   
librtmp1:amd64                         2:2.4~20160119.gitfa8646dae-dmo5       
libsuil-0-0:amd64                      1:0.8.4-dmo1+deb9u1                    
libswresample2:amd64                   10:3.3.9-dmo1+deb9u1                   
libswscale4:amd64                      10:3.3.9-dmo1+deb9u1                   
libtwolame0:amd64                      1:0.3.13-dmo3                          
libusageenvironment3                   2:2017.04.26-dmo1+deb9u2               
libvamp-hostsdk3v5:amd64               1:2.7.1-dmo1                           
libvidstab1.0                          2:0.98b-dmo1+deb8u1                    
libvlc-bin:amd64                       1:3.0.11-dmo0+deb9u1                   
libvlc5:amd64                          1:3.0.11-dmo0+deb9u1                   
libvlccore9:amd64                      1:3.0.11-dmo0+deb9u1                   
libwxsvg3:amd64                        3:1.5.12-dmo1                          
libx264-150:amd64                      3:0.150.2833+gitdf79067-dmo1+deb9u1    
libx265-116:amd64                      1:2.4-dmo1                             
libxine2                               1:1.2.8-dmo5                           
libxine2-bin:amd64                     1:1.2.8-dmo5                           
libxine2-doc                           1:1.2.8-dmo5                           
libxine2-ffmpeg:amd64                  1:1.2.8-dmo5                           
libxine2-misc-plugins:amd64            1:1.2.8-dmo5                           
libxine2-plugins                       1:1.2.8-dmo5                           
libxine2-x:amd64                       1:1.2.8-dmo5                           
libxvidcore4:amd64                     3:1.3.4-dmo1                           
mencoder                               4:1.3.0~20170413.svn37931-dmo3+deb9u5  
mjpegtools                             2:2.1.0-dmo9                           
mjpegtools-gtk                         2:2.1.0-dmo9                           
mkvtoolnix                             9.8.0-dmo1                             
mkvtoolnix-gui                         9.8.0-dmo1                             
mplayer                                4:1.3.0~20170413.svn37931-dmo3+deb9u5  
mpv                                    1:0.27.2-dmo1+deb9u1                   
obs-plugins                            1:19.0.2-dmo2+deb9u1                   
obs-studio                             1:19.0.2-dmo2+deb9u1                   
ogmrip                                 1.0.1-dmo9                             
ogmrip-doc                             1.0.1-dmo9                             
phonon4qt5-backend-vlc:amd64           1:0.9.1-dmo1+deb9u1                    
rtmpdump                               2:2.4~20160119.gitfa8646dae-dmo5       
subtitleripper                         0.5.2-dmo3                             
tovid                                  0.35.2-dmo1                            
tovidgui                               0.35.2-dmo1                            
transcode                              4:1.1.7-dmo15                          
transcode-doc                          4:1.1.7-dmo15                          
twolame                                1:0.3.13-dmo3                          
vlc                                    1:3.0.11-dmo0+deb9u1                   
vlc-bin                                1:3.0.11-dmo0+deb9u1                   
vlc-data                               1:3.0.11-dmo0+deb9u1                   
vlc-l10n                               1:3.0.11-dmo0+deb9u1                   
vlc-plugin-base:amd64                  1:3.0.11-dmo0+deb9u1                   
vlc-plugin-notify:amd64                1:3.0.11-dmo0+deb9u1                   
vlc-plugin-qt:amd64                    1:3.0.11-dmo0+deb9u1                   
vlc-plugin-samba:amd64                 1:3.0.11-dmo0+deb9u1                   
vlc-plugin-skins2:amd64                1:3.0.11-dmo0+deb9u1                   
vlc-plugin-video-output:amd64          1:3.0.11-dmo0+deb9u1                   
vlc-plugin-video-splitter:amd64        1:3.0.11-dmo0+deb9u1                   
vlc-plugin-visualization:amd64         1:3.0.11-dmo0+deb9u1                   
x11proto-xf86vidmode-dev               2018.4-4                               
xine-ui                                0.99.9-dmo14+deb9u1

Once all the above packages are removed, use apt autoremove.

Use apt-get autoclean to remove obsolete packages in the /var/cache/apt/archives directory.

Manually remove any remaining "dmo" packages in the /var/cache/apt/archives directory.

Remove all "dmo" packages from the directory I previously used for the packages I downloaded with the Bash script file that was created by Synaptic.

Execute the apt-get update command.

Perform the "3.2. Operation" step of Chapter 3. Using APT and wget from the Using APT Offline online manual (this could be what Synaptic does when the "Generate package download script" feature is used.) to check what package files already downloaded are still required and also to check if there are any new packages to be downloaded.

I will look at the output in the "uris" Output file first, before executing the awk command, and maybe use that for the basis of a comparison in a Spreadsheet as well as with the Diffuse Merge Tool graphical application. For any packages that I haven't previously downloaded, I can manually create a Bash script file using the wget command.

Once I have all the required packages in the 1 directory, then, I can execute the apt-get -o dir::cache::archives="/disc/" dist-upgrade command with "/disc/" being replaced by MY directory location.

Thanks!!, MTB.

Last edited by mtbvfr (2020-07-01 03:41:01)

Online

#22 2020-07-01 08:28:44

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 123  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

mtbvfr wrote:

Once I have all the required packages in the 1 directory, then, I can execute the apt-get -o dir::cache::archives="/disc/" dist-upgrade command with "/disc/" being replaced by MY directory location.

Excelent! Thanks for sharing.

Offline

#23 2020-07-01 16:39:53

mtbvfr
Member
Registered: 2017-07-29
Posts: 60  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Hi Folks,

I have partially(?) solved the locale problem it appears but not sure.

After some more research I executed locale-gen followed by dpkg-reconfigure locales.

Now, I do not get the original error output but when I execute dpkg-reconfigure locales I receive the following response.

/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed

dpkg -l |grep locale produces the following.

ii  krb5-locales                                                1.15-1+deb9u1                             all          internationalization support for MIT Kerberos
ii  libboost-locale1.62.0:amd64                                 1.62.0+dfsg-4                             amd64        C++ facilities for localization
iU  libboost-locale1.67.0:amd64                                 1.67.0-13+deb10u1                         amd64        C++ facilities for localization
ii  libencode-locale-perl                                       1.05-1                                    all          utility to determine the locale encoding
iU  liblocale-gettext-perl                                      1.07-3+b4                                 amd64        module using libc functions for internationalization in Perl
iU  locales                                                     2.28-10                                   all          GNU C Library: National Language (locale) data [support]
iU  python-apt-common                                           1.8.4.1                                   all          Python interface to libapt-pkg (locales)
ii  util-linux-locales                                          2.29.2-1+devuan2.1                        all          locales files for util-linux

Thanks!! MTB.

Online

#24 2020-07-01 17:57:29

rolfie
Member
Registered: 2017-11-25
Posts: 359  

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

From a native Beowulf install:

# dpkg -l | grep locale
ii  krb5-locales                                      1.17-3                              all          internationalization support for MIT Kerberos
ii  libdatetime-locale-perl                           1:1.23-1                            all          Perl extension providing localization support for DateTime
ii  libencode-locale-perl                             1.05-1                              all          utility to determine the locale encoding
ii  liblocale-gettext-perl                            1.07-3+b4                           amd64        module using libc functions for internationalization in Perl
ii  locales                                           2.28-10                             all          GNU C Library: National Language (locale) data [support]
ii  python-apt-common

My first candidate for removal would be the libboost-packages, then the util-linux from ASCII.

rolfie

Last edited by rolfie (2020-07-01 17:58:16)

Offline

#25 2020-07-01 19:35:44

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 767  
Website

Re: Errors encountered processing: libgstreamer-gl1.0-0_1.14.4-2_amd64.deb

Have you tried

# apt reinstall locales
# dpkg-reconfigure locales

"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

Board footer