The officially official Devuan Forum!

You are not logged in.

#1 2024-03-07 22:30:12

grunchy
Member
Registered: 2024-01-01
Posts: 11  

[SOLVED] no time service

i have two installs of devuan daedalus+kde: qemu VM and bare-metal.

the VM was updated over existing install going back to ascii. the bare-metal
devuan was a fresh install.

i cannot find any timekeeping service running on either: no ntpd, ntpsec,
chrony, timedatectl. nothing

how is timekeeping done?

what is standard practice (if any) for timekeeping?

my thought is to install chrony+timedatectl but maybe something else is preferred?

Offline

#2 2024-03-08 01:52:53

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 595  

Re: [SOLVED] no time service

Hi, look at your services for hwclock.sh will take your bios time and use it to convert to your locale.

I found that the bios time needed to be set UTC so the locale would represent the correct time here...

If you have no network connection it may remember the time from a setting during the OS installation.

I used to try and set the correct date & time in the bios, but every OS wants to change it, putting my file-access time forward and generally making a mess.

So, set the bios to UTC and let the locales and hwclock will make the adjustment for you.

btw, using Open-Rc, rc-update (as root) lists the services.
I hope this helps.


pic from 1993, new guitar day.

Offline

#3 2024-03-08 09:02:50

aluma
Member
Registered: 2022-10-26
Posts: 535  

Re: [SOLVED] no time service

i cannot find any timekeeping service running on either: no ntpd, ntpsec,
chrony, timedatectl. nothing

Open Synaptic Package Manager and see if they are installed.

Offline

#4 2024-03-08 09:38:57

rolfie
Member
Registered: 2017-11-25
Posts: 1,081  

Re: [SOLVED] no time service

ntpdate and ntpsec are not installed by default in Daedalus, has to be done afterwards. With ntpsec the conf dir has moved to /etc/ntpsec.

BTW: timedatectl is a systemd tool, afaik not present on Devuan.

Offline

#5 2024-03-08 13:02:06

delgado
Member
Registered: 2022-07-14
Posts: 166  

Re: [SOLVED] no time service

chrony is a possible choice for a ntp daemon. Just install it and you're good to go.

Remarks:
The meta-package ntp (or ntpd) will installs the default time-sync daemon.
I do not know timedatectl. In general, it's a bad idea to install two services for one issue.
In case of a VM: The time comes from the host, so ntp is probably not needed.

Offline

#6 2024-03-08 14:40:00

aluma
Member
Registered: 2022-10-26
Posts: 535  

Re: [SOLVED] no time service

Chrony has one drawback - there are no letters “ntp” in the name and the synaptic does not shows it unless specifically specified. smile

Offline

#7 2024-03-09 04:04:13

stultumanto
Member
Registered: 2023-12-12
Posts: 58  

Re: [SOLVED] no time service

ntpsec is the "default" time daemon that will be installed if you run 'apt install ntp'. There's also the aforementioned chrony, as well as openntpd, which comes from OpenBSD. I just install with ntpsec on my systems since it's the default, and I didn't have a pressing reason to use one of the others. IIRC setup was entirely automatic; I didn't need to edit any init scripts or config files. However, I did run 'dpkg-reconfigure tzdata' to set my correct time zone.

Offline

#8 2024-03-10 01:26:43

grunchy
Member
Registered: 2024-01-01
Posts: 11  

Re: [SOLVED] no time service

thanks for the help/advise everyone! i got it sorted now. i only need a NTP client as there is
an NTP server on my lan. chrony installed without issue. added "-4" flag to /etc/default/chrony
and the server ip to /etc/chrony/chrony.conf and rebooted. 'chronyc tracking' shows things
as working as desired.

the first time chrony started-up and did a sync it adjusted the system clock by 30 seconds!
my mobo realtime clock must drift a lot.

Offline

Board footer