The officially official Devuan Forum!

You are not logged in.

#1 2021-02-20 05:29:49

Registered: 2017-06-20
Posts: 7  

SOLVED refract pw not working after install

i also tried the default passowrds as well and they are not working.  what the what?  i know i changed them and that they matched or the thing wouldnt have allowed the next step... which i think was exiting and rebooting.  OI  how to get around THAT?  is 18 characters too long for refracta or something?

apparently so

so here we are.  installed a thgird time with an 8 digit password and changed it after first boot to what i want it to be

Last edited by LizziAS (2021-02-20 05:51:33)


#2 2021-02-20 14:32:17

Registered: 2016-11-25
Posts: 1,857  

Re: SOLVED refract pw not working after install

Thanks. I never noticed that. Most of my installs are tests, so I use very short passwords. The yad dialog window only takes 18 characters, but it stores more if you type them. I'm not sure why it didn't use your long password.

I tried running the code in a terminal (as root), and it works. I'll have to try it in an install.

Here's the code for that window with the output of my 20-character password entry.

~# pass_entry=$(yad --form --title=$"Configure $pass_dialog password" --center --borders=10 --button=$"OK":0 \
--text=$"You should reset the $pass_dialog password.\nUse TAB to change fields." \
--field=$"Enter new $pass_dialog password::H" \
--field=$"Confirm new $pass_dialog password::H"  \
--field=$"Use current password\? (not recommended)":CHK \

Trim the output, check it and feed it into the passwd command, and it works.

newpass=$(echo $pass_entry|awk -F "|" '{print $1}')
echo $newpass

/bin/bash -c "echo -e \"$newpass\n$newpass\n\" | passwd $newusername"
New password: Retype new password: passwd: password updated successfully


Board footer