The officially official Devuan Forum!

You are not logged in.

#1 2021-02-07 02:21:44

pootler
Member
Registered: 2020-08-03
Posts: 33  

appimages?

HI,

I am using  a reasonably fresh( 2 month) old install of devuan.

I am trying to run an appimage.

It is for an email client - called Criptext.

In ''properties'' for the image, , I have altered the permission to read & write, and also made the image ''executable''

However, no matter what I do , the app will not run upon double click.

Any ideas what I am doing wrong :-)

Thanks

pootler

Offline

#2 2021-02-07 05:51:29

szutt
Member
Registered: 2019-02-03
Posts: 31  

Re: appimages?

Maybe this is due to sandboxing. Try adding --no-sandbox to the launch command. I found that : https://www.reddit.com/r/debian/comment … s_without/

Offline

#3 2021-02-07 09:47:50

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 190  
Website

Re: appimages?

pootler wrote:

the app will not run upon double click.

Try to start the file from terminal. May be there are some messsage.

Offline

#4 2021-02-07 09:52:26

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: appimages?


Black Lives Matter

Offline

#5 2021-02-07 13:52:28

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

ok - so far this is what I have :-)

keith@devuan:~/Downloads$ sudo chmod u+x * Criptext-latest.AppImage
[sudo] password for keith:
keith@devuan:~/Downloads$ ./Criptext-latest.AppImage
[11157:0207/134338.395343:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_CripteZQiVuj/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap
keith@devuan:~/Downloads$ ./Criptext-latest.AppImage --no-sandbox

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:154:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:155:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:584:27: The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:585:28: The style property GtkWidget:interior-focus is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:586:28: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.306: Theme parsing error: gtk-widgets.css:587:26: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.308: Theme parsing error: gtk-widgets.css:1344:25: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.308: Theme parsing error: gtk-widgets.css:1345:25: The style property GtkRange:stepper-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.308: Theme parsing error: gtk-widgets.css:1346:34: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.308: Theme parsing error: gtk-widgets.css:1347:28: The style property GtkRange:stepper-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(criptext:11189): Gtk-WARNING **: 13:44:12.308: Theme parsing error: gtk-widgets.css:1348:34: The style property GtkRange:trough-under-steppers is deprecated and shouldn't be used anymore. It will be removed in a future version
couldn't lock 16384 bytes of memory (libgcrypt): Cannot allocate memory
** Message: 13:44:15.087: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
{"level":"error","message":"Unhandled Rejection: The name org.freedesktop.secrets was not provided by any .service files","stack":"Error: The name org.freedesktop.secrets was not provided by any .service files","timestamp":"2021-02-07T13:44:22.528Z"}

I have no idea what this means - any advice from experienced users?

THanks

Pootler

Offline

#6 2021-02-07 14:01:24

dice
Member
Registered: 2020-11-22
Posts: 441  
Website

Re: appimages?

If you want my advice, dont use appimages. Use services like tutanota or protonmail and learn how to use gpg to encrypt messages over the net. Ive used tutanota to send encrypted emails that they say are end to end encrypted only for the recipient who uses yahoo is able to fully read the email i sent that was supposedly encrypted.I would be surprised if this cryptext email is actually end to end encrypted.

edit: i guess im just reiterating that the endpoint of end to end encryption is a security risk. Most services offer encrypted tansfer of emails, but if doesn't land at the other end encrypted then it is not truly end to end encrypted imo.

Last edited by dice (2021-02-07 14:18:01)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Online

#7 2021-02-07 14:46:59

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: appimages?

pootler wrote:
[11157:0207/134338.395343:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_CripteZQiVuj/chrome-sandbox is owned by root and has mode 4755.

Did you follow that advice?

pootler wrote:
** Message: 13:44:15.087: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files

That dbus service file is provided by the gnome-keyring package


Black Lives Matter

Offline

#8 2021-02-07 19:47:12

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

dice wrote:

If you want my advice, dont use appimages. Use services like tutanota or protonmail and learn how to use gpg to encrypt messages over the net. Ive used tutanota to send encrypted emails that they say are end to end encrypted only for the recipient who uses yahoo is able to fully read the email i sent that was supposedly encrypted.I would be surprised if this cryptext email is actually end to end encrypted.

edit: i guess im just reiterating that the endpoint of end to end encryption is a security risk. Most services offer encrypted tansfer of emails, but if doesn't land at the other end encrypted then it is not truly end to end encrypted imo.

HI,

Already used Protonmail for a year.

Would rather have my mail stored locally.

Pootler

Offline

#9 2021-02-07 20:00:51

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

Head_on_a_Stick wrote:
pootler wrote:
[11157:0207/134338.395343:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_CripteZQiVuj/chrome-sandbox is owned by root and has mode 4755.

Did you follow that advice?

pootler wrote:
** Message: 13:44:15.087: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files

That dbus service file is provided by the gnome-keyring package


Hi,

So -- how do I alter the permissions for that temporary mount point? - isn't the program aborted , hence the tmp mount point is aborted as well??

Certainly can't find it in the file system---WARNING--- noob.

Cheers

Keith

Offline

#10 2021-02-08 11:39:41

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: appimages?

Just install the gnome-keyring package and see if that fixes things.


Black Lives Matter

Offline

#11 2021-02-08 12:19:50

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

O.K.

that was wierd?

I tried to install gnome keyring using synaptic.

it said in order to install this it had to remove - a long list of stuff?

In fact this list was so long I didn't do it - it even included xfce4  stuff, and other appimages I have that work fine? - whats going on there!

I found the .deb package that I installed instead.

Didn't seem to make any difference.

So went to the link Dice gave about missing libraries.

Tried to install the packages that included the libraries.

I still can't run by double clicking, but if I run from terminal using <--no-sandbox>, it runs.

Now just need to find a way of running from the desktop without having to go into terminal all the time:-)

cheers

pootler

Offline

#12 2021-02-08 13:07:08

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 190  
Website

Re: appimages?

pootler wrote:

I still can't run by double clicking, but if I run from terminal using <--no-sandbox>, it runs.

Now just need to find a way of running from the desktop without having to go into terminal all the time:-)

Easy-peasy: edit the .desktop file

Offline

#13 2021-02-08 13:10:40

dice
Member
Registered: 2020-11-22
Posts: 441  
Website

Re: appimages?

I didnt give you a link about missing libraries that was the other dice wink

I would seriously reconsider installing this JavaScript/Electron monstrosity.

Last edited by dice (2021-02-08 13:11:02)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Online

#14 2021-02-08 13:25:34

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: appimages?

pootler wrote:

I tried to install gnome keyring using synaptic.

it said in order to install this it had to remove - a long list of stuff?

In fact this list was so long I didn't do it - it even included xfce4  stuff, and other appimages I have that work fine? - whats going on there!

Sounds like http://forums.debian.net/viewtopic.php?t=104157

Can we see

apt install --simulate gnome-keyring

Might be best to open another thread about this though.


Black Lives Matter

Offline

#15 2021-02-08 20:28:21

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

dice wrote:

I didnt give you a link about missing libraries that was the other dice wink

I would seriously reconsider installing this JavaScript/Electron monstrosity.


my bad :-(

Thing is, I would like to investigate this app - so now I have it working, I'll live with it  to see

Cheers

Pootler

Last edited by pootler (2021-02-08 20:39:35)

Offline

#16 2021-02-08 20:38:34

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

Can we see

apt install --simulate gnome-keyring

Might be best to open another thread about this though.


here is the output:

apt install --simulate gnome-keyring
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-keyring is already the newest version (3.28.2-5).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


- since I avoided anything catastrophic, I might just leave this - I sense the rabbit hole might be a bit deep for a noob  :-)

pootler

Offline

#17 2021-02-08 21:58:25

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: appimages?

pootler wrote:

I might just leave this

If you are suffering with the "metapackage problem" then you could find most of your desktop removed if you don't pay close attention to package management.

Is anything slated for autoremoval?

apt --simulate autoremove

If that command gives a list of packages then read the link I supplied in my last post and open a new thread if you can't figure out how to fix things. If the command doesn't list anything then just ignore this post.


Black Lives Matter

Offline

#18 2021-02-09 22:56:04

pootler
Member
Registered: 2020-08-03
Posts: 33  

Re: appimages?

apt --simulate autoremove
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

looks like I can breathe easy

Cheers

pootler

Offline

Board footer