The officially official Devuan Forum!

You are not logged in.

#1 2017-10-06 21:33:03

bbatten
Member
Registered: 2017-07-02
Posts: 14

[SOLVED] Devuan skypeforlinux dependency problem

Hi,

I'm trying to install the latest skypeforlinux (8.8.76.61628) on Devuan Jessie, with this result.

The following packages have unmet dependencies:
 skypeforlinux : Depends: libdbus-1-3 (>= 1.8.22) but 1.8.20-1+devuan1.1 is to be installed
E: Unable to correct problems, you have held broken packages.
-su(root)#


Any ETA for a libdbus update?

Thanks,

Last edited by bbatten (2017-10-19 16:59:31)

Offline

#2 2017-10-06 22:00:06

golinux
Administrator
Registered: 2016-11-25
Posts: 650

Re: [SOLVED] Devuan skypeforlinux dependency problem

Have you tried backports?

Online

#3 2017-10-07 00:41:53

bbatten
Member
Registered: 2017-07-02
Posts: 14

Re: [SOLVED] Devuan skypeforlinux dependency problem

Hi,

Thanks for the quick reply. I think so. Here's what I have in /etc/apt/sources.list:

deb [arch=amd64,i386] http://auto.mirror.devuan.org/merged jessie-backports main contrib non-free

Good?
After "apt-get update" I show:

[109] bryan: aptitude versions libdbus-1-3
Package libdbus-1-3:                        
i A 1.8.20-1+devuan1.1                            stable                    500 

Package libdbus-1-3:i386:
i A 1.8.20-1+devuan1.1                            stable                    500 
[110] bryan:


Doesn't seem to be showing anything tagged with "backports", though, even though it "got" all the entries.

Offline

#4 2017-10-19 16:57:32

bbatten
Member
Registered: 2017-07-02
Posts: 14

Re: [SOLVED] Devuan skypeforlinux dependency problem

Did update -> dist-upgrade yesterday and lo and behold, skypeforlinux installs!

Offline

Board footer