The officially official Devuan Forum!

You are not logged in.

#1 2020-06-21 05:12:53

erdos
Member
Registered: 2018-06-04
Posts: 48  

no sound after beowulf upgrade

i upgraded to beowulf from ascii today, but after upgrade, i have no sound coming from youtube in firefox on xfce desktop.

settings- pulseaudio volume control displays and stuck at
"Establishing connection to PulseAudio. Please wait..."

Offline

#2 2020-06-21 05:36:46

golinux
Administrator
Registered: 2016-11-25
Posts: 2,076  

Re: no sound after beowulf upgrade

Please read the Beowulf Release Notes.

Offline

#3 2020-06-21 06:19:50

erdos
Member
Registered: 2018-06-04
Posts: 48  

Re: no sound after beowulf upgrade

thanks, that solved it!

Pulseaudio
- If you have no sound, make sure the following line in
   /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented as
   shown here:

   #autospawn=no

Pulseaudio is gone for beowulf?  there's still the pulseaudio volume control in App Menu, which i used for enable the sound in ascii.

Offline

#4 2020-06-21 09:56:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,645  

Re: no sound after beowulf upgrade

Pulseaudio is still around in beowulf. The difference is that if you're using systemd, you should not let pulseaudio autospawn itself, because systemd will do that for you. Since this is devuan and there is no systemd to handle everything, pulseaudio has to autospawn itself.

PA is removable if you prefer to be without it.

Offline

#5 2020-06-21 15:47:05

berni51
Member
From: Germany
Registered: 2018-12-20
Posts: 29  
Website

Re: no sound after beowulf upgrade

Momento! I had to make the same pulseaudo modification to get sound on my Archlinux machine. And Archlinux (unfortunately) uses systemd.

Regards
Berni

Offline

#6 2020-06-26 05:16:07

LU344928
Member
Registered: 2020-02-13
Posts: 31  

Re: no sound after beowulf upgrade

berni51 wrote:

Archlinux (unfortunately) uses systemd.

Have you looked into using Artix?
https://artixlinux.org/

Offline

#7 2020-06-26 08:32:50

berni51
Member
From: Germany
Registered: 2018-12-20
Posts: 29  
Website

Re: no sound after beowulf upgrade

Yes, I found and tried artixlinux too. It runs fine, but I removed it as well as archlinux, because I'm a Devuan.fanboy. And since Beowulf with a 5.5 kernel runs perfect, I am back. :-)

Offline

#8 2020-10-28 07:56:27

serq
Member
Registered: 2017-07-01
Posts: 8  

Re: no sound after beowulf upgrade

golinux wrote:

Please read the Beowulf Release Notes.

Thank' s , it  solved

Offline

#9 2020-10-28 08:03:58

serq
Member
Registered: 2017-07-01
Posts: 8  

Re: no sound after beowulf upgrade

erdos wrote:

thanks, that solved it!

Pulseaudio
- If you have no sound, make sure the following line in
   /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented as
   shown here:

   #autospawn=no

Pulseaudio is gone for beowulf?  there's still the pulseaudio volume control in App Menu, which i used for enable the sound in ascii.

Thank you very much
But, in my case, I had to reboot the computer twice, after the first time I did not find any sound cards, no wi-fi

Last edited by serq (2020-10-28 09:05:42)

Offline

Board footer