The officially official Devuan Forum!

You are not logged in.

#1 2020-08-13 13:32:37

walterbyrd
Member
Registered: 2018-07-30
Posts: 38  

Cannot install VLC

Dependency hell.

# apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-plugin-video-output (= 3.0.11-0+deb9u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Trying to fix broken packages:

# apt-get update --fix-missing
Hit:1 http://deb.devuan.org//merged ascii InRelease              
Hit:2 http://deb.devuan.org//merged ascii-security InRelease
Hit:3 http://deb.devuan.org//merged ascii-updates InRelease
Reading package lists... Done
root@fir:/etc/apt/sources.list.d# 

So that's done. Now trying to install vlc-plugin-video-output

# apt-get install vlc-plugin-video-output
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc-plugin-video-output : Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                                    libgles2
E: Unable to correct problems, you have held broken packages.

Continuing down the dependency hell rabbit hole.

# apt-get install libgles2-mesa
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgles2-mesa : Depends: libglapi-mesa (= 13.0.6-1+b2) but 18.3.6-2+deb10u1 is to be installed
E: Unable to correct problems, you have held broken packages.
# apt-get install libgles2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libgles2-mesa' instead of 'libgles2'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgles2-mesa : Depends: libglapi-mesa (= 13.0.6-1+b2) but 18.3.6-2+deb10u1 is to be installed
E: Unable to correct problems, you have held broken packages.

Last edited by walterbyrd (2020-08-13 13:36:35)

Offline

#2 2020-08-13 14:00:04

Altoid
Member
Registered: 2017-05-07
Posts: 474  

Re: Cannot install VLC

Hello:

walterbyrd wrote:

Dependency hell.

Could you post your surces list?

~$ cat /etc/apt/sources.list

I run on an updated Devuan ascii 2.0

~$ uname -a
Linux devuan 4.9.0-13-amd64 #1 SMP Debian 4.9.228-1 (2020-07-05) x86_64 GNU/Linux
~$ 
# apt-get update && apt-get upgrade && apt-get install -f
Hit:1 http://deb.devuan.org/merged ascii InRelease
Hit:2 http://deb.devuan.org/merged ascii-security InRelease
Hit:3 http://deb.devuan.org/merged ascii-updates InRelease
Hit:4 http://deb.devuan.org/devuan ascii-proposed InRelease
Hit:5 http://deb.devuan.org/merged ascii-backports InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
# 

Here's my sources.list, please disregard the comments:

~$ cat /etc/apt/sources.list

deb http://deb.devuan.org/merged/ ascii main 
deb http://deb.devuan.org/merged/ ascii-security main 
deb http://deb.devuan.org/merged/ ascii-updates main 

# needed x virtualbox backport - enable to update package
deb http://deb.devuan.org/devuan/ ascii-proposed main contrib non-free 
deb http://deb.devuan.org/merged/ ascii-backports non-free contrib main 

# needed x nvidia non-free drivers installation
deb http://deb.devuan.org/merged/ ascii contrib 
deb http://deb.devuan.org/merged/ ascii non-free 

# virtual box repository 
# deb http://download.virtualbox.org/virtualbox/debian/ stretch non-free contrib  

With those sources, if I try to install vlc, I get this:

# apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
vlc is already the newest version (3.0.11-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
# 

Same with the plugin:

# apt-get install vlc-plugin-video-output
Reading package lists... Done
Building dependency tree       
Reading state information... Done
vlc-plugin-video-output is already the newest version (3.0.11-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
# 

Check your sources.list, maybe there's something there that should not be or maybe there's something missing.

Cheers,

A.

Offline

#3 2020-08-13 14:35:01

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,624  

Re: Cannot install VLC

libgles2-mesa : Depends: libglapi-mesa (= 13.0.6-1+b2) but 18.3.6-2+deb10u1 is to be installed

deb10u1 in the version means first revision for debian 10, which is buster, which is also beowulf. Decide whether you're running ascii or beowulf and stick to one. Let us know what you put in sources.list.d, too.

Offline

#4 2020-08-13 19:11:08

walterbyrd
Member
Registered: 2018-07-30
Posts: 38  

Re: Cannot install VLC

My present /etc/apt/sources.list

# deb cdrom:[Devuan GNU/Linux 2.1 (ascii) amd64 DVD1 - 2019-10-21 03:55:08 UTC]/ ascii main non-free

deb http://us.deb.devuan.org/merged ascii main non-free contrib
deb-src http://us.deb.devuan.org/merged ascii main non-free contrib

deb http://us.deb.devuan.org/merged ascii-security main non-free contrib
deb-src http://us.deb.devuan.org/merged ascii-security main non-free contrib

deb http://us.deb.devuan.org/merged ascii-updates main non-free contrib
deb-src http://us.deb.devuan.org/merged ascii-updates main non-free contrib

# deb http://auto.mirror.devuan.org/merged
# deb-src http://auto.mirror.devuan.org/merged

I have changed this. When I was trying to install plexmediaserver, I added some debian sources, because I thought that was the only way I could get it to work.

These are the debian sources that I had:

# deb http://deb.debian.org/debian buster main contrib non-free
# deb https://downloads.plex.tv/repo/deb ./public main

in /etc/apt/sources.list.d

-rw-r--r-- 1 root root 211 Aug 11 09:52 devuan.list
-rw-r--r-- 1 root root 226 Jul 20 04:01 plexmediaserver.list

In devuan.list

# autogenerated by devuan-baseconf
# decomment following lines to  enable the developers devuan repository
#deb http://packages.devuan.org/devuan ascii main
#deb-src http://packages.devuan.org/devuan ascii main

In plexmediaserver.list

# When enabling this repo please remember to add the PlexPublic.Key into the apt setup.
# wget -q https://downloads.plex.tv/plex-keys/PlexSign.key -O - | sudo apt-key add -
#deb https://downloads.plex.tv/repo/deb/ public main

Last edited by walterbyrd (2020-08-13 19:18:28)

Offline

#5 2020-08-13 22:48:37

Altoid
Member
Registered: 2017-05-07
Posts: 474  

Re: Cannot install VLC

Hello:

walterbyrd wrote:

... trying to install plexmediaserver, I added some debian sources ...
These are the debian sources that I had:

# deb [url]http://deb.debian.org/debian[/url] buster main contrib non-free <-- Error: it's either ascii or buster. Can't be both. 
# deb [url]https://downloads.plex.tv/repo/deb[/url] ./public main

fsmithred can surely expand on this more than I could, ie: how to fix it.

But what I'm sure of is that # deb http://deb.debian.org/debian buster main contrib non-free should not be/have been there.

BTW: please use code to insert code and quote to insert a quote.

Cheers,

A.

Last edited by Altoid (2020-08-13 22:50:17)

Offline

#6 2020-08-14 05:55:35

larsH
Member
Registered: 2020-05-05
Posts: 129  

Re: Cannot install VLC

Hi

You might have created a monster devuandebian. with parts from different distributions and versions. If you did get installed something from debian buster, you have at least upgraded some of the main parts of your system (libc among others). As I see it you have three options:

1) You might try to downgrade by using apt-get -t ascii dist-upgrade. Look carefully what it want to do. It might fail because downgrading is not supported

2)You might try to upgrade by changing your sources to beowulf. Run apt update, and then apt-get -t beowulf dist-upgrade. Look carefully what it want to do. It might have problems due to different packages between debian and devuan

3) Reinstall. That I am sure will do it.

Have a nice day
Lars H

Offline

#7 2020-08-14 19:06:40

rolfie
Member
Registered: 2017-11-25
Posts: 401  

Re: Cannot install VLC

walterbyrd wrote:

Dependency hell.

We could reply: What the hell are you doing here?

Before you try to clean out your installation you better read some literature about sources.list and Franken-Debian. Here are some useful links.
You could start on the main page of Devuan.org: https://devuan.org/,
about installation: https://devuan.org/os/install,
about releases: https://devuan.org/os/releases
about sources.list recommendations: https://devuan.org/os/packages

about FrankenDebian: https://wiki.debian.org/DontBreakDebian

HTH, rolfie

Edith: added link to the Debian Wiki.

Last edited by rolfie (2020-08-14 21:19:48)

Offline

#8 2020-08-14 19:10:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,624  

Re: Cannot install VLC

Not much to add to all the good advice that was given. If you choose to upgrade, here' the ascii to beowulf upgrade guide. It might help.
https://devuan.org/os/documentation/dev … to-beowulf

Offline

#9 2020-08-15 14:30:59

Vernon
Member
Registered: 2020-07-19
Posts: 89  

Re: Cannot install VLC

No problems for me installing VLC on Beowulf

/etc/apt/sources.list

deb http://deb.devuan.org/merged beowulf main non-free contrib                  
deb-src http://deb.devuan.org/merged beowulf main non-free contrib              
                                                                                
deb http://deb.devuan.org/merged beowulf-security main non-free contrib         
deb-src http://deb.devuan.org/merged beowulf-security main non-free contrib     
                                                                                                          
deb http://deb.devuan.org/merged beowulf-updates main non-free contrib          
deb-src http://deb.devuan.org/merged beowulf-updates main non-free contrib      

Last edited by Vernon (2020-08-15 14:31:33)

Offline

#10 2020-08-16 20:35:54

walterbyrd
Member
Registered: 2018-07-30
Posts: 38  

Re: Cannot install VLC

Upgrade?

# uname -a
Linux fir 4.9.0-13-amd64 #1 SMP Debian 4.9.228-1 (2020-07-05) x86_64 GNU/Linux

Is that not the most recent version?

Do I really have to nuke my entire installation just to get VLC to install?

Last edited by walterbyrd (2020-08-16 20:41:41)

Offline

#11 2020-08-16 22:26:31

walterbyrd
Member
Registered: 2018-07-30
Posts: 38  

Re: Cannot install VLC

Okay. I nuked my entire system, and I am now rebuilding.

The good news is: VLC installed right away.

The bad news is: I now realize, I did not just add debian repositories just for plex. I also need them for everything else.

For example, I need to install AMD drivers for graphics. Are there devauan repositories for that?

Whenever I go to a search engine, "devuan" is treated like a misspelling of "debian." I always get instructions for debian, and that often includes adding debian repositories.

For example: here are some instruction on how to install "devuan" AMD drivers:
https://linuxconfig.org/how-to-install- … -10-buster

I have not installed drivers for my HP printer yet, are there devuan repositories for that?

--------------------------

Note: I was able to get the AMD and foomatic drivers. Some of it was on the DVD.

I suppose I developed of habit of just searching for procedures to do things. With most distros, that is just too easy. With Devuan, that often does not work. The procedures are usually for Debian.

Last edited by walterbyrd (2020-08-17 00:14:38)

Offline

#12 2020-08-17 01:30:57

golinux
Administrator
Registered: 2016-11-25
Posts: 2,033  

Re: Cannot install VLC

You shouldn't need to download any packages directly from Debian.  The "merged" designation in the devuan source line takes care of fetching packages directly from Debian.

Offline

#13 2020-08-18 11:55:06

Vernon
Member
Registered: 2020-07-19
Posts: 89  

Re: Cannot install VLC

walterbyrd wrote:

I have not installed drivers for my HP printer yet, are there devuan repositories for that?

What is your printer model number?

Offline

Board footer