The officially official Devuan Forum!

You are not logged in.

#1 2020-02-13 07:59:52

LU344928
Member
Registered: 2020-02-13
Posts: 8  

[Solved] Font rendering?

Hello, I'm new here. Thanks for providing this distro and forum. Hope this is the right place for this topic.

I just tried the recent live release -  devuan_ascii_2.1_amd64_desktop-live.iso - no immediate plans to install to the hard drive yet. First thing I noticed was the blurry-like font on Firefox. The desktop font is better though not quite as clear as I've seen on Xfce releases of MX Linux and PCLinuxOS, There doesn't seem to be any problem with the display driver as videos play normally. It's just the font. It's like seeing it on an old CRT monitor past its prime. How to fix?

Thanks in advance.

Last edited by LU344928 (2020-02-15 10:46:52)

Offline

#2 2020-02-13 17:11:50

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: [Solved] Font rendering?

If you use TrueType fonts then try

# dpkg-reconfigure fontconfig-config

And change the font tuning method to "Autohinter".

Otherwise navigate to Applications Menu → Settings → Appearance → Fonts and play with the hinting method. MX use "slight" hinting.

It's probably also worth noting that MX-19 is based on Debian buster and so has a newer version of fontconfig. Have you tried the Refracta beta image? That uses a beowulf base with the same fontconfig version as MX-19 (but it has hinting set to "none" in the stock desktop).


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#3 2020-02-13 17:25:44

golinux
Administrator
Registered: 2016-11-25
Posts: 1,870  

Re: [Solved] Font rendering?

In Xfce Jessie the option is "anti-aliasing".  I also use "slight" hinting and find it helps to use a semibold font like Open Sans.

Offline

#4 2020-02-15 09:58:13

LU344928
Member
Registered: 2020-02-13
Posts: 8  

Re: [Solved] Font rendering?

Hi Head_on_a_Stick. Thanks for taking the time to reply.

Head_on_a_Stick wrote:

If you use TrueType fonts then try

# dpkg-reconfigure fontconfig-config

And change the font tuning method to "Autohinter".

Tried that and got 'command not found' so I guess those fonts are not installed?

Otherwise navigate to Applications Menu → Settings → Appearance → Fonts and play with the hinting method. MX use "slight" hinting.

No discernible difference, even when set to full.

It's probably also worth noting that MX-19 is based on Debian buster and so has a newer version of fontconfig. Have you tried the Refracta beta image? That uses a beowulf base with the same fontconfig version as MX-19 (but it has hinting set to "none" in the stock desktop).

No, haven't tried it yet but will soon, thanks.

Offline

#5 2020-02-15 10:02:32

LU344928
Member
Registered: 2020-02-13
Posts: 8  

Re: [Solved] Font rendering?

Hi golinux, thanks for the reply.

golinux wrote:

In Xfce Jessie the option is "anti-aliasing".  I also use "slight" hinting and find it helps to use a semibold font like Open Sans.

The default here is Sans but no Open Sans option, closest on the list is OpenSymbol, thanks.

Offline

#6 2020-02-15 10:24:45

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 556  
Website

Re: [Solved] Font rendering?

LU344928 wrote:

Tried that and got 'command not found' so I guess those fonts are not installed?

They're not fonts, the package is for configuration of the fontconfig package.

So try

# apt install fontconfig fontconfig-config
# dpkg-reconfigure fontconfig fontconfig-config

You may even find that the hinting options start making a difference afterwards.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#7 2020-02-15 10:43:51

LU344928
Member
Registered: 2020-02-13
Posts: 8  

Re: [Solved] Font rendering?

Head_on_a_Stick wrote:
LU344928 wrote:

Tried that and got 'command not found' so I guess those fonts are not installed?

They're not fonts, the package is for configuration of the fontconfig package.

So try

# apt install fontconfig fontconfig-config
# dpkg-reconfigure fontconfig fontconfig-config

You may even find that the hinting options start making a difference afterwards.

Turned out the package was already installed:

root@devuan:~# apt install fontconfig fontconfig-config
Reading package lists... Done
Building dependency tree       
Reading state information... Done
fontconfig is already the newest version (2.11.0-6.7+b1).
fontconfig set to manually installed.
fontconfig-config is already the newest version (2.11.0-6.7).
fontconfig-config set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So:

root@devuan:~# dpkg-reconfigure fontconfig fontconfig-config
Regenerating fonts cache... done.
root@devuan:~# 

That did the trick, much clearer now. Still not that impressed with the Sans one so will play around with the others. Many thanks.

Offline

Board footer