The officially official Devuan Forum!

You are not logged in.

#1 2019-09-06 15:00:11

Raul
Member
Registered: 2019-09-05
Posts: 4  

Audacity 2.2.

Hello,

(I am new here)

I am using Ascii very satisfactorily and do not want, for the time being anyway, to migrate to a newer system. But I would need to use a higher version of Audacity, not 2.1 any longer but rather 2.2 (or even 2.3) if possible.  Is there anything in Devuan like the backports in Debian, where some later packages were made available for earlier versions of the OS?  Where can I find a .deb-package Audacity 2.2.?

    Thanks

    Raúl

Offline

#2 2019-09-06 15:23:33

golinux
Administrator
Registered: 2016-11-25
Posts: 1,710  

Re: Audacity 2.2.

Welcome to the forum, Raul!

It looks like  Audacity 2.2 is in Beowulf and 2.3 in Ceres (Sid):
https://pkginfo.devuan.org/cgi-bin/d1pk … elease=any

You can try adding backports:

deb     http://deb.devuan.org/merged ascii-backports main

Or you could try backporting it yourself.

Offline

#3 2019-09-06 18:35:30

Raul
Member
Registered: 2019-09-05
Posts: 4  

Re: Audacity 2.2.

Thanks.  But no, I do not find it in the backports repository and if I try to install it from the beowulf repository with aptitude it is clear it won't work. Too many dependencies are broken.  The only way would be to update to beowulf.

Thanks again

Raúl

Offline

#4 2019-09-06 18:38:20

golinux
Administrator
Registered: 2016-11-25
Posts: 1,710  

Re: Audacity 2.2.

You could try to backport it yourself.   Perhaps someone here can walk you through it.  Wish I could but alas not that adventurous . . .

Offline

#5 2019-09-06 20:48:59

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,207  

Re: Audacity 2.2.

You're in luck. I backported audacity-2.2.2 last year for personal use, but I haven't actually used it. It does install in ascii. Packages for audacity and audacity-data are here if you want to try them. (amd64 only)
http://distro.ibiblio.org/refracta/file … _packages/

I don't recall having any trouble backporting the package. Might be a good one to try if you wanted.

Offline

#6 2019-09-08 14:20:14

Raul
Member
Registered: 2019-09-05
Posts: 4  

Re: Audacity 2.2.

Thanks to you all!  Unfortunately my machine works on i386 so I cannot use a amd64-package.

In the end I upgraded ascii to beowulf with the help of "Tips for successfully migrating Ascii DE to Beowulf as of 11-08-2018".  It seems to be working well and I have audacity 2.2.

Thanks again
Raúl

Offline

Board footer