The officially official Devuan Forum!

You are not logged in.

#1 2019-02-08 21:19:49

rolfie
Member
Registered: 2017-11-25
Posts: 175  

root-Terminal on Beowulf

My VM with Beowulf amd64/Mate/lightdm/elogind is working now.

What I am missing is a way to create a direct menu path to a root terminal as I had up to ASCII. Was simply done by creating a new menu entry with the command line gksu mate-terminal. Now gksu has been dropped. What would be the replacement? I tried with pkexec mate-terminal instead, am asked to enter the root-PW and nothing else happens.

I consider opening a user terminal and to use su - instead just as a workaround. su has a srewed default path and is unusable.

Suggestions?

Thanks, Rolf

Offline

#2 2019-02-08 22:05:03

golinux
Administrator
Registered: 2016-11-25
Posts: 1,709  

Re: root-Terminal on Beowulf

gksu has been deprecated as you noted.  Use pkexec.  Discussion here.  I can now launch from panel and to custom actions. Bit of a pain though . . .

Also a recent update overwrote my working policykit backend.  Make sure the debian one hasn't slipped in.

Online

#3 2019-02-09 15:28:45

rolfie
Member
Registered: 2017-11-25
Posts: 175  

Re: root-Terminal on Beowulf

I have looked at the thread, and analysed what I have here.

The policykit stuff I have is version 0.105-25, seems to be complete. As authentification agent the package polkit-mate-authentication-agent-1 is installed.

# apt list policykit* --installed
Auflistung... Fertig
policykit-1/testing,now 0.105-25+devuan1 amd64  [Installiert,automatisch] 

# apt list libpolkit* --installed
Auflistung... Fertig
libpolkit-agent-1-0/testing,now 0.105-25+devuan1 amd64  [Installiert,automatisch]
libpolkit-backend-1-0/testing,now 0.105-25+devuan1 all  [Installiert,automatisch]
libpolkit-backend-elogind-1-0/testing,now 0.105-25+devuan1 amd64  [Installiert,automatisch]
libpolkit-gobject-1-0/testing,now 0.105-25+devuan1 all  [Installiert,automatisch]
libpolkit-gobject-elogind-1-0/testing,now 0.105-25+devuan1 amd64  [Installiert,automatisch]

Maybe I need to give the version 0.105-18 a try. Other ideas?

Thanks, Rolf

Offline

#4 2019-02-09 16:12:56

rolfie
Member
Registered: 2017-11-25
Posts: 175  

Re: root-Terminal on Beowulf

Update: after adding a policy-file, mate-terminal as root is opened. Geany can be used.

Question remains if this is a good path setting for a root terminal?

echo $PATH
/usr/sbin:/usr/bin:/sbin:/bin:/root/bin

Next step: see how mate-system-log is doing.
Update: works after adding another policy.

Thanks, Rolf

Last edited by rolfie (2019-02-09 16:31:30)

Offline

#5 2019-02-09 18:47:21

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,205  

Re: root-Terminal on Beowulf

Root's path in ascii and jessie was this. If you don't have anything in /usr/local/ the path you're using is fine.

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

I added the following line to /root/.bashrc and now I can get root with 'su' and still run commands in *sbin and still open graphical apps on user desktop and still be in the same directory. I don't know the reason they changed it, but it certainly got in the way of my workflow.

export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

Offline

#6 2019-02-09 18:53:54

golinux
Administrator
Registered: 2016-11-25
Posts: 1,709  

Re: root-Terminal on Beowulf

fsmithred wrote:

I don't know the reason they changed it, but it certainly got in the way of my workflow.

Wasn't that due to the merged /usr in stretch/beowulf?

Online

#7 2019-02-09 19:44:40

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,205  

Re: root-Terminal on Beowulf

golinux wrote:
fsmithred wrote:

I don't know the reason they changed it, but it certainly got in the way of my workflow.

Wasn't that due to the merged /usr in stretch/beowulf?

I don't think so. If it were due to that, I'd expect /usr/sbin/ to be in the path, but all the sbins are gone when you get root with 'su'. If you use 'su -' instead, you get the sbins in your path, but then your working directory changes to /root and  you can't run a graphical app in the user's desktop.

Offline

Board footer