The officially official Devuan Forum!

You are not logged in.

#1 2018-08-12 13:07:21

fred43
Member
Registered: 2018-08-03
Posts: 4  

Tips for successfully migrating Ascii DE to Beowulf as of 11-08-2018

The DE is:

lightdm with libpam-elogind, a partial xfce4-desktop  and the exim4-light-daemon


Warning:

Please don't blame me if your system gets hosed. It happened to me but I could quickly re-install the original OS from a backup and try again using a different approach. I succeeded with this endeavour on the 11-08-2018, I am mentioning the date as the testing-branch is a moving target.

If you are in a hurry - don't do it! Read any output from 'aptitude' very carefully when it presents you with alternatives to work around dependency problems.

IMPORTANT: You have to be familiar with a testing-branch. You are warned!


Motivation:

Using Debian-testing for *many* years I suddenly had that "bee in the bonnet" to move a Devuan-stable to the testing branch. My present Debian-testing (with sysv-init) is actually my main OS but I started feeling a bit uncomfortable since consolkit-1 got dropped by the Debian-Team and with no elogind and friends in sight to replace it.


Preamble:

This is not a HowTo Document rather a collection of comments and tips to get the job done in one way or another (makeshift aproach). Moving a DE from stable (ascii) to testing (beowulf) is presently a *fairly* tricky business. The emphasis is on moving a DE.

Now lets get this out of our way. Right now, merged/beowulf and merged/ceres is not functioning the same way as the Debian buster and sid branches. It seems that Devuan specific packages are not trickling down fast enough from experimental to unstable to testing. I can well imagine that the Devuan-Project just simply does not have the resources and manpower to do it any faster.

For that very reason one can't just do an apt-get dist-upgrade! For a DE you need devuan-branded 'policykit-1' and 'consolekit and friends' or 'libpam-elogind and friends'. These packages are presently simply *not* available in beowulf or ceres.


Now let's start.

The tools I used are aptitude (ncurses bases package manager which in IMHO is a bit cleverer in working out dependeny-problems as apt-get) and orphaner (an alternative for finding unused packages) from the deborphan package.

I reduced the DE (in my case, xfce4) but left lightdm and the mailserver (apt-listchanges) installed.

Made a backup of the root-partition.

Changed in the /etc/apt/sources.list the word 'ascii' to 'beowulf' and created a file /etc/apt/preferences.d/avoid_some_beo with the following content:

  Package: policykit-1
  Pin: release a=beowulf
  Pin-Priority: -1

  Package: libpolkit-agent-1-0
  Pin: release a=beowulf
  Pin-Priority: -1 

  Package: libpolkit-backend-1-0
  Pin: release a=beowulf
  Pin-Priority: -1

  Package: libpolkit-gobject-1-0
  Pin: release a=beowulf
  Pin-Priority: -1

and then I issued the command: apt-get update


Remember "apt-get dist-upgrade" does give you a hosed system. If you don't believe me try it with the -s switch and then you will notice that the new debian-branded policykit-1 will be installed which in turn uninstalls the devuan-branded vital stuff (ie libpolkit-backend-elogind-1-0).

Now I started from the terminal (as root) the application aptitude and then I pressed: U for Upgrade.

aptitude then told me that it has got a dependency problem. In response to it, press: e and cycle thrugh the 2 or 3 different solutions to the dependency-problem.

Accept the one where policykit-1 will not be upgraded and libpolkit-backend-elogind-1-0 and friends will be left in place (not wiped out).

Press: g and inspect the displayed list for correctness and confirm the correctness by pressing g again otherwise cancel pending action.

After completion of the upgrade under the heading "Obsolete and Locally Created Packages", I did find libpam-elogind and friends. This confirms that apparently all went well, in other words the vital ascii based devuan-branded packages did make the migration.

Then I closed aptitude and used orphaner to tell me which packages orphaner thinks are obsolete and I recorded the name of these packages on a piece of paper.

After closing orphaner and starting aptitude again I then carefully removed the *truly* obsolete packages and landed with the following list in aptitude:

elogind, eudev, libpam-elogind, clearlook-phenix-darkpurpy-themes, gnome-icon-theme-extras, linux-image-4.9.0.7-amd64, libelogind0, libeudev1, libpolkit-backend-elogind-1-0, libpolkit-gobject-elogind-1-0, libuper-glib1 and darkpurpy-icon-theme.

Then I closed aptitude again.

In order to reflect the fact that this is a Devuan and not a Debian-Distro make changes to the following files in the /etc directory: devuan_verson, issue, issue.net and os-release. 

I issued the command: update-grub

and then rebooted the OS - and all worked!!! Mind you, the command su behaves differently (had to read the mail which apt-listchange generated for me). BTW, gksu is gone because Debian ditched it!

I reinstalled the print-server (no problem during the install and is fully functional) and then pulseaudio. There is however a slight initial problem with pulseaudio! I had to edit the file /etc/pulse/client.conf.d/00-disable-autospawn.conf as per instruction inside that file and pulseaudio works now perfectly.

Note: As I use eth0, I can't tell you if the wifi-packages will function properly. Personally, ignoring network-manager, I don't see a reason why they should not work.


My final ramblings:

My beowulf-system seems to run fine. I know, its early days but I must admit I expected it to be worse. My "Beowulf Desktop Environment" has 11 Devuan packages from ascii, 6 from beowulf and the rest is *pure* Debian buster.

Will I keep this installation? Most probably I will but let's wait and see if the beowulf-branch develops towards a more functional state of affairs, in other words in a less makeshift migration setup. I personally do not like the idea to have *vital* packages borrowed from the ascii-branch. I will have to keep a weary eye on them!

My sincere thanks to the Devuan devs, testers and bug-reporters for providing a good OS without the systemd octopus. I tip my hat!

Last edited by fred43 (2018-08-12 13:14:20)

Offline

Board footer