The officially official Devuan Forum!

You are not logged in.

#26 2018-06-26 16:20:06

Sanssystemd
Member
Registered: 2017-06-01
Posts: 13  

Re: Black Screen on Devuan Ascii - acpi=off solves it (undesirable)

I've tried both, on root i got a display (1024x768)
As a regular user i got nothing.

Offline

#27 2018-06-26 17:03:56

golinux
Administrator
Registered: 2016-11-25
Posts: 1,218  

Re: Black Screen on Devuan Ascii - acpi=off solves it (undesirable)

Things changed in stretch.  Thank Debian.  IIRC it had something to do with wayland.

Online

#28 2018-06-27 07:02:04

Sanssystemd
Member
Registered: 2017-06-01
Posts: 13  

Re: Black Screen on Devuan Ascii - acpi=off solves it (undesirable)

For now there seems to be no real solution for this, so i went back to Jessie.
What i don't understand is why an older machine like my i386 upgraded smoothly?, no hitch whatsoever.

I'll keep looking for a real solution of course smile

Offline

#29 2018-06-27 07:47:51

cynwulf
Member
Registered: 2017-10-09
Posts: 178  

Re: Black Screen on Devuan Ascii - acpi=off solves it (undesirable)

Sanssystemd wrote:

I've tried both, on root i got a display (1024x768)
As a regular user i got nothing.

You have X.org log files and the ~/.xsession-errors file to refer to.

Also once you run X as root you can break Xauth.  It's often necessary to clear up any of these dotfiles, before attempting to startx again as a normal user.

Last edited by cynwulf (2018-06-27 07:49:04)

Offline

#30 2018-06-28 23:03:57

Sanssystemd
Member
Registered: 2017-06-01
Posts: 13  

Re: Black Screen on Devuan Ascii - acpi=off solves it (undesirable)

Upgraded again to Ascii.

First deleted ~/.Xauthority, disabled a line of script i had put in /etc/X11/Xsession  , then rebooted and started a desktop via SliM
Desktop turned out to be in mode 1024x768.
I then changed my ~/.Xprofile, it turned out that i had to change 'VGA1' in 'VGA-1' in that file.
Re-enabled my line in /etc/X11/Xsession
Lo and behold, after restarting X the correct resolution was activated!!

The only thing left to do now is to make a xorg.conf file because X isn't capable of detecting my Intel driver.

Thanks for the given suggestions , got me searching in the right direction smile

Offline

Board footer