The officially official Devuan Forum!

You are not logged in.

#1 2020-04-02 11:56:57

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 669  
Website

[BUG] beowulf beta netinst. ISO does not configure locales or timezone

Apologies if this is the wrong section — I couldn't find a "Bugs" sub-forum and reportbug wants a package name, which doesn't seem appropriate for problems with the ISO image.

Anyway, as the title says the installer fails to configure the locales package correctly:

empty@devuan:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
empty@devuan:~$

/etc/locale.gen had all the locales commented out but /etc/default/locale was populated correctly.

This is easily fixed with

# dpkg-reconfigure locales

But I think it should already be properly configured for a freshly installed system.

I used this image, the SHA256SUM matched. No desktop was selected but the "standard system utilities" were installed. I chose OpenRC as the init system but I presume that wouldn't be relevant for this particular problem. The system is running under QEMU/KVM in a Debian buster host.

I did mention this in the beowulf beta thread but it was lost in the noise.

And incidentally the GRUB menu describes the system as "Debian GNU/Linux", which doesn't seem ideal.

Last edited by Head_on_a_Stick (2020-04-02 14:11:24)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#2 2020-04-02 12:12:11

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 38  

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

Head_on_a_stick wrote:

Anyway, as the title says the installer fails to configure the locales package correctly:

As you mention OpenRC I assume you're using the 'expert' option on one of the full isos. Which iso though?

I installed using the devuan_beowulf_3.0.0_beta_amd64_desktop.iso and installed to disk and locales seems OK:

marjorie@grendel:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

Offline

#3 2020-04-02 12:21:05

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 669  
Website

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

Marjorie wrote:

As you mention OpenRC I assume you're using the 'expert' option on one of the full isos. Which iso though?

The netinstall image, as per the link in my OP. I didn't change the priority in the installer, I just ran through the default "Install" option.

Marjorie wrote:

I installed using the devuan_beowulf_3.0.0_beta_amd64_desktop.iso and installed to disk and locales seems OK

Ah, interesting. So perhaps it's just the netinstall then.

EDIT: changed the thread title to indicate the image used.

Last edited by Head_on_a_Stick (2020-04-02 12:24:52)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#4 2020-04-02 12:41:06

HevyDevy
Member
Registered: 2019-09-06
Posts: 194  

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

I used the same iso and had the same issue with locales and also with tzdata not being set properly.

Offline

#5 2020-04-02 12:49:07

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 669  
Website

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

^ The tzdata package was configured for me, did you see the options for localisation in the installer?


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#6 2020-04-02 13:05:20

HevyDevy
Member
Registered: 2019-09-06
Posts: 194  

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

Head_on_a_Stick wrote:

^ The tzdata package was configured for me, did you see the options for localisation in the installer?

Yes i did see that but when the install was complete and i rebooted, date was showing actual coordinated universal time from memory as i chose UTC computer time settings. Not a big deal though, as easy fixed with dpkg reconfigure tzdata. Maybe i missed something but im sure i did the correct procedure as i have done before by setting the computer to use UTC and tzdata to Australia/Brisbane.

Offline

#7 2020-04-02 13:34:50

golinux
Administrator
Registered: 2016-11-25
Posts: 1,919  

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

Head_on_a_Stick wrote:

Apologies if this is the wrong section — I couldn't find a "Bugs" sub-forum and reportbug wants a package name, which doesn't seem appropriate for problems with the ISO image.

Oh, but it is!

https://git.devuan.org/devuan/devuan-in … aster/docs

Online

#8 2020-04-02 14:10:07

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 669  
Website

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

Correction:

I wrote:

The tzdata package was configured for me

I was mistaken, the timezone is also not configured and was set to 'Etc/UTC'.

golinux wrote:

Oh, but it is!

Thanks. I've just used reportbug from the installed system, I'll edit this post with the bug number once I get a reply.


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

#9 2020-05-12 16:01:31

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 669  
Website

Re: [BUG] beowulf beta netinst. ISO does not configure locales or timezone

The report has been received and assigned to #454: https://bugs.devuan.org/cgi/bugreport.cgi?bug=454

With thanks to ralph.ronnquist for not complaining about my crappy bug reporting skills :-)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." — Antoine de Saint-Exupéry

Offline

Board footer