The officially official Devuan Forum!

You are not logged in.

#1 2018-06-24 20:49:59

Registered: 2017-07-02
Posts: 34  

[SOLVED] elogind package bug

I've been getting this error:

Jun 24 12:47:38 Pentium90 dbus[3632]: [system] Activated service 'org.freedesktop.login1' failed: Cannot launch daemon, file not found or permissions invalid

"locate org.freedesktop.login1" shows:


"dpkg -S" shows "/usr/share/dbus-1/system-services/org.freedesktop.login1.service" to be part of elogind. That file has:

[22] bryan: cat /usr/share/dbus-1/system-services/org.freedesktop.login1.service#  This file is part of elogind.
#  elogind is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

[D-BUS Service]
Exec=/usr/lib/elogind/elogind --daemon
[23] bryan:

Unfortunately /usr/lib/elogind/elogind does not exist. Instead, there is /usr/lib/elogind/elogind-cgroups-agent, which is listed as part of the elogind package.
I changed the Exec line to read Exec=/usr/lib/elogind/elogind-cgroups-agent --daemon. Things seem to be OK. I'll post a little later with an update on results.

Last edited by bbatten (2018-07-01 16:39:37)


#2 2018-06-24 21:04:49

Registered: 2016-11-25
Posts: 1,501  

Re: [SOLVED] elogind package bug

Have you read the Release Notes?


#3 2018-07-01 16:33:01

Registered: 2017-07-02
Posts: 34  

Re: [SOLVED] elogind package bug

I read what looked like the relevant sections of the release notes and thought I understood them. Guess not.
When I next logged in after applying the changes described above, it was rejected with:

[278857.622] (EE) systemd-logind: failed to get session: Launch helper exited with unknown return code 1

I eventually found that with my configuration - xserver-xorg-legacy (with needs_root_rights=yes), XFCE4, console login, and calling startx from .bash_profile - I had to use consolekit for things to work.

Here is the section I had trouble with:

### Starting X from a console (TTY)

In Devuan 2.0 ASCII, the X server no longer requires to be run with
root privileges. As a consequence, there are some additional
requirements to be met when launching X directly from a TTY (i.e.,
through 'xinit' or 'startx'), especially on systems upgraded from
Devuan Jessie.

In Devuan 2.0 ASCII it is sufficient to install 'elogind' and
'libpam-elogind', and then use either 'startx' or 'xinit' as usual
from a regular user account. In this case, the Xorg log file will be
available under '~/.local/share/xorg/'.
Alternatively, it is still possible to run X with setuid root. In this
case, you need to install `xserver-xorg-legacy` and ensure that the
file '/etc/X11/Xwrapper.config' contains the (uncommented) line:




#4 2018-07-01 17:10:33

Registered: 2018-04-30
Posts: 176  

Re: [SOLVED] elogind package bug

I guess that's more related to XFCE than X itself then. I am running icewm with neither elogind or consolekit (obviously using xserver-xorg-legacy and needs_root_rights=yes) without problems here.


Board footer