The officially official Devuan Forum!

You are not logged in.

#1 2024-02-17 22:14:36

HunkyDory
Member
Registered: 2024-02-17
Posts: 4  

[SOLVED] app wants libxalan-c

I'm a long time Gentoo user which is my main desktop. I've installed Devuan (just upgraded to Daedalus) on a machine that was just too painfully slow to be compiling Gentoo on, and that is down in my basement brewery.

I want to share the database between my upstairs Gentoo pc and the basement brewery pc. Gentoo didn't have but an old Brewtarget software that I use so I manually upgraded it to latest brewtarget-3.0.11. Devuan only offers up to 3.0.6. Looks like lots of fixes in 3.0.11 vs 3.0.6. If I use 2 different versions, I think it won't be good for the shared database. I backup and restore it between the 2 pc's.

I installed the 3.0.11 version on this Devuan machine, but when trying to run it - it complains that there is no libxalan-c, which I think does not exist in the official repositories. So my question is - should I look around for that library and if I find it.. would it hurt anything to install? Thinking there must be a reason it isn't on the official repositories.

I could also raise an issue on the brewtarget github: https://github.com/Brewtarget/brewtarget/releases but thought I would ask here first.
thanks, HD

[edit] On the gentoo box when installing, I also had to install libxerces-c. Hopefully the Devuan box won't also want that..

Last edited by HunkyDory (2024-02-17 22:17:28)

Offline

#2 2024-02-17 22:38:24

Altoid
Member
Registered: 2017-05-07
Posts: 1,429  

Re: [SOLVED] app wants libxalan-c

Hello:

HunkyDory wrote:

... complains that there is no libxalan-c

See here for the available libxalan-c packages in Devuan.

I'd be wary of installing packages from outside the official repositories but if all dependencies are properly met, you may not run into any issues.

Best,

A.

Offline

#3 2024-02-18 05:01:37

HunkyDory
Member
Registered: 2024-02-17
Posts: 4  

Re: [SOLVED] app wants libxalan-c

Thanks Altoid!

Offline

#4 2024-02-18 11:14:13

Altoid
Member
Registered: 2017-05-07
Posts: 1,429  

Re: [SOLVED] app wants libxalan-c

Hello:

HunkyDory wrote:

Thanks ...

You're welcome.
Please let us know how you fared with this.

Best,

A.

Offline

#5 2024-02-20 05:51:57

HunkyDory
Member
Registered: 2024-02-17
Posts: 4  

Re: [SOLVED] app wants libxalan-c

I decided not to install it. I think the version (3.0.11) requires libxalan-c-111 rather than 112 which seems to be installed already. I did get some dire security warnings of "suspicious package" and mozilla wouldn't download either of those libraries.. I didn't want to fight it or investigate further. Nor did I want to muck anything up.. hopefully the versioning will catch up eventually between distros though this software probably isn't a big priority for many. Appreciate the help.  /jd

Offline

#6 2024-02-20 09:53:15

aluma
Member
Registered: 2022-10-26
Posts: 533  

Re: [SOLVED] app wants libxalan-c

This is a link to the libxalan-c111 package.
http://ftp.de.debian.org/debian/pool/ma … _amd64.deb
Taken here
https://debian.pkgs.org/10/debian-main- … 4.deb.html

I downloaded it without problems, installed it, the synaptic shows two versions that do not interfere with each other.
Brewtarget installs and works, Daedalus 5.0.
24.jpg

Last edited by aluma (2024-02-20 10:27:09)

Offline

#7 2024-02-22 01:29:17

HunkyDory
Member
Registered: 2024-02-17
Posts: 4  

Re: [SOLVED] app wants libxalan-c

I'd buy you a drink if I lived nearby. Thanks!

I'm going to give it a try now. Cheers!

[edit]: Done! Thanks again! Easy deal.

Last edited by HunkyDory (2024-02-22 02:49:20)

Offline

Board footer