The officially official Devuan Forum!

You are not logged in.

#1 2024-01-06 14:37:39

serq
Member
Registered: 2017-07-01
Posts: 11  

[SOLVED] didn't start X11, after upgrade Devuan from Chimaera to Daedalus

Hi all,  When loading I received a message like this 'failed to load nvidia/ga107/nvdec/scrubber.bin'
Solution:
adding to sources non-free-firmware
deb http://deb.devuan.org/merged daedalus main contrib non-free non-free-firmware
install the linux-headers-amd64, firmware-linux-nonfree and firmware-misc-nonfree

Migration failed, I had to do a clean installation because I didn’t know what the problem was

Offline

#2 2024-01-06 17:38:56

Andre4freedom
Member
Registered: 2017-11-15
Posts: 127  

Re: [SOLVED] didn't start X11, after upgrade Devuan from Chimaera to Daedalus

Such upgrades are supposed to fail, I guess. I suggest, in any case, to use the nouveau driver (open source). That's in sync with the kernels, no need to compile or to tinker.
May be your chances are better with a fresh install, but the next upgrade may fail again thanks to proprietary drives.

Offline

#3 2024-01-09 11:20:19

stultumanto
Member
Registered: 2023-12-12
Posts: 45  

Re: [SOLVED] didn't start X11, after upgrade Devuan from Chimaera to Daedalus

You still need the non-free nvidia firmware to use certain video acceleration features with the nouveau driver. It's discussed here:
https://nouveau.freedesktop.org/VideoAcceleration.html
The noveau driver also lacks support for a number of other features present in the proprietary driver, most notably compute. Some cards don't even have 3D support at this time. More info here:
https://nouveau.freedesktop.org/FeatureMatrix.html
I use nouveau because it does everything I need it to do, but my needs aren't all that demanding.

Offline

Board footer